General discussion

Locked

telnet problem

By m_moaz ·
when I telnet my linux box it says"connection refused by foreign host"
I have checked the inetd.conf file, it is ok
files hots.allow and hosts.deny is also empty.I have tried to run in.telnetd manually,again same problem.
any suggestion???

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

telnet problem

by D_Frost In reply to telnet problem

I'm completely shooting from the hip, but here are a few off-the-cuff ideas:

Since you checked the inetd.conf file, I have to assume that it is set up to run.

Can you telnet in from the machine itself (telnet localhost, for example).

Check the /etc/services file to see what port your server is expecting connections on, and make sure the client is using the same port. The default is usually 23, and usually you can specify a different port for your telnet client as well if needed.

Youcan also try changing the telnetd to run in various debug options (-D, for example) by modifying inetd.conf. (see "man telnetd" for a host of different options for that)I've never done it, so I can't be much more help there.

Good luck!
-D_Frost

Collapse -

telnet problem

by m_moaz In reply to telnet problem

The question was auto-closed by TechRepublic

Collapse -

telnet problem

by sukrith In reply to telnet problem

Some thing wrong!!
According to you it should work fine.Any how you please check up once again your /etc/inetd.conf file.
Once you are in that file type /telnet and you will be now on the line where you can restrict or permit telnet option and remove the # mark if any, this will be below the line of FTP option.One more important this is checkup the port which Telnet is running.By default it should be 23.Offcourse you can change if you want.You check up whether your computer from which you are trying has got the permission to telnet to that system which ur facing problem.

Collapse -

telnet problem

by m_moaz In reply to telnet problem

The question was auto-closed by TechRepublic

Collapse -

telnet problem

by nickread In reply to telnet problem

If you say your inetd.conf file is correct, then it may simply be that you don't have the telnet server installed (telnetd).

Collapse -

telnet problem

by m_moaz In reply to telnet problem

The question was auto-closed by TechRepublic

Collapse -

telnet problem

by m_moaz In reply to telnet problem

This question was auto closed due to inactivity

Back to Linux Forum
7 total posts (Page 1 of 1)  

Operating Systems Forums