General discussion

Locked

VANISHING DSN'S

By nickm172 ·
I am losing my DSN connections, when I try to create a new SYSTEM DSN everything is fine but when I actually try to use it I always get this error:

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Its not in my code or in the spelling of the DSN names or anything like that because even working ones that have been in place stopped working after I pulled them up in the ODBC config program in control panel. They were working fine till I did that. and now any that I have looked at the configuration of do not work and I can create new onces but every time I try to use it I get the error above. I've installed the latest MDAC, re-installed my SP. Articles in MSKB only refernce spelling errors in code. This is not the case because working ones that have been in place for over a year no longer work.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

VANISHING DSN'S

by PorterTech In reply to VANISHING DSN'S

You might have a problem with the odbc files in the windows\system directory. Somtimes when installing programs, SOME odbc components / files get put into the directory that leave the full set of odbc files incompatable. Do the following: (1) Create a temporary directory, and move (don't copy) all odbc*.* files from the windows\system directory into the temp. (2)Either find an updated ODBC install program, or re-install something like access, which will re-install the fully compatible odbc components. After installing odbc, you will be surprised that all previous definitions will show up, and they should all function. Good luck.

Collapse -

VANISHING DSN'S

by nickm172 In reply to VANISHING DSN'S

did that nothing changed.

Collapse -

VANISHING DSN'S

by zaq42 In reply to VANISHING DSN'S

Do the problems occurr with one ODBC driver? If so, reintsall it (may not be in MDAC). BTW: MDAC 2.0 contains code/files not in MDAC 2.1.

Are you able to access the ODBC connect via applications such as Access, Excel, etc...? That will help debugthe problem.

Another solution is to reapply the latest OS service pack. Lastly, reinstall the OS.

Hope this helps!

Andy

Collapse -

VANISHING DSN'S

by nickm172 In reply to VANISHING DSN'S

reinstalled everything. Including the latest version of MDAC.

Collapse -

VANISHING DSN'S

by nickm172 In reply to VANISHING DSN'S

This question was closed by the author

Back to Web Development Forum
5 total posts (Page 1 of 1)  

Software Forums