Question

Locked

Vlans routing using Switch and Router

By muddin ·
Yes I have the following hardware now but still can't route between two Vlans or PC does not get IP from the DHCP server(Router).
Both Vlans should be active since I have Router.

2950 12 port Switch
2651 Router duel ethernet ports
Netgear ADSL DG834PN Router

Connected:
Router 0/0 port - ADSL Router

Router 0/1 port - Trunk port of switch(f0/1)

PC - normal switch port


Followed the link below and Configured Router as DHCP server. If you want I can post "sh run" output from the Router.

Router 0/0: connected to ADSL router to get IP from ISP

Router 0/1: 10.65.194.1 255.255.254.0

Switch:
VLAN 1: 10.65.195.2 255.255.254.0
VLAN 2: 10.65.196.2 255.255.254.0


http://networking-newbie.blogspot.com/2008/10/configure-cisco-router-to-work-with_18.html

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Maybe this will help

by scott_heath In reply to Vlans routing using Switc ...

If your DHCP server is not on the same network them each VLAN needs a DHCP helper address that points to the DHCP server.

Do you have RIP or OSPF enable to discover routes? If you create VLANs without some sort of route builidng protocol enabled you will need to build the routing table manually.

Regards,
Scott

http://scottisageek.spaces.live.com

Collapse -

The fix

by r0berth2 In reply to Vlans routing using Switc ...

you need sup-interfaces on your router0/0 interface.

router0/0
no ip address
speed 100
duplex full
router0/0.1
descripiton **vlan1**
encapsulation dot1q 1
ip address 10.65.194.1 255.255.254.0
no shut
router0/0.2
description **vlan2**
encapsulation dot1q 2
ip address 10.65.196.1 255.255.254.0

then on your switch, you will need to setup as follows:
switch0/1
switchport mode trunk
speed 100
duplex full
vlan 1
name vlan1
vlan 2
name vlan2
interface vlan1
ip address 10.65.194.2 255.255.254.0
ip helper-address 10.65.194.1
no shut
interface vlan2
ip address 10.65.196.2 255.255.254.0
ip helper-address 10.65.196.1

you will need a dhcp scope for each vlan.

on the router setup a scope for vlan1:
ip dhcp excluded-address 10.65.194.1
ip dhcp excluded-address 10.65.194.2
ip dhcp excluded-address 10.65.196.1
ip dhcp excluded-address 10.65.196.2
ip dhcp pool vlan1
network 10.65.194.0 255.255.254.0
default-router 10.65.194.1
lease 14
ip dhcp pool vlan2
network 10.65.196.0 255.255.254.0
default-router 10.65.196.1
lease 14

Collapse -

My Router is a dualports FastEthernet

by muddin In reply to The fix

Do I still need to do encapsulation?

Collapse -

the reply

by r0berth2 In reply to My Router is a dualports ...

Yes you do. Why would you want to waste the 2nd ethernet port to feed the same switch? You should only have 1 cable from the router to the switch.

Collapse -

My Router f0/0 port

by muddin In reply to the reply

is connected to the ADSL Inernet Router. If I need to create sub-interfaces and IP helper to establish communications between vlans, should I not do all these onto the f0/1 port in the Router which is connected to the Switch?
Is there any rule for "ip helper-address" as you used 10.65.194.1, this is my Router address as well ?

Back to Networks Forum
6 total posts (Page 1 of 1)  

Hardware Forums