Question

Locked

why foxpro running slowly in xp ?

By SUNI_U786 ·
dear frnds,
i have pentium4 512 mb ram winxp system. my probl is when i open foxpro program(old version)cpu usage goes to 100%.then system is slow.
help me plz...

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Help with what? This is normal behavior.

by seanferd In reply to why foxpro running slowly ...

First, you have Foxpro which is probably running in fake-DOS on XP, plus you have barely enough RAM to run XP with any apps at all.

All I can suggest is: More RAM or stop any other applications from running while you are using Foxpro.

Collapse -

Reponse To Answer

by SUNI_U786 In reply to Help with what? This is n ...

hai,
these two suggestions i tried already..format my pc increase ram 1 gb then without install any other program i tried to work on foxpro i feel the same effect as before.
cpu usage showing 100%.my doubt is why this foxpro becomes slower in modern computers...also i try to work on tamedos ,same... wht to do?

Collapse -

Reponse To Answer

by seanferd In reply to Help with what? This is n ...

This is because such old apps do not run normally in modern Windows. A DOS environment must be emulated, which not only uses considerable resources in some cases, but also artificially limits resources in the emulated DOS environment.

TameDOS is still another emulator running under XP. It may or may not work better than XP's native method, but it will never be like running it under a real DOS environment.

Be aware also that you might run into unfixable problems at any time, and you'll lose all your un-saved work. I've seen this happen many times.

If you really plan on using this a lot, I'd load a DOS (or Win 95, 98) onto another system which DOS can handle.

Collapse -

Priority change

by wompai In reply to why foxpro running slowly ...

Try to set the priority of foxpro to "low" in the taskmanager:
-press CTRL+ALT+DEL
-select the foxpro program and right click it. Than click "go to process" (or anything like that)(the option at the bottom of the options-menu)
-right click on that process and set the priority to low

note: this will make sure that the processor doesn't spend all the resources on foxpro, it might increase performance of other programs but slows down the performance of foxpro.

Tip: Increase your RAM memory. As Seanferd said: 512MB is barely enough to run windows and all kinds of apps. Memory ships aren't that expansive, a good $20,- or so.

Good luck

Collapse -

Edit to remove Firefox speed tips :)

by robo_dev In reply to why foxpro running slowly ...

Firefox and Foxpro are not the same thing, last time I checked [forehead slap]

[original correct yet misguided response below]
Are you using a lot of plugins with Firefox?

Do you have good virus and spyware protection?

Clear your browser cache, cookies, and everything.

Try launching Firefox in safe mode.
http://support.mozilla.com/en-US/kb/Safe%20Mode

Shut off plugin-container...it's a memory hog.
http://forums.mozillazine.org/viewtopic.php?f=38&t=1930253

Read this guide:
http://support.mozilla.com/en-US/kb/Firefox%20consumes%20a%20lot%20of%20CPU%20resources

Collapse -

Reponse To Answer

by seanferd In reply to Edit to remove Firefox sp ...

I believe the OP means the way outdated FoxPro (Fox & MS) programming environment. But I now see there are other things called Foxpro as well, so...

Collapse -

USE VFP not foxpro2.??

by montanasman In reply to why foxpro running slowly ...

Visual Fox is fast on any machine. You need to upgrade. Yes, it means rewriting code. Otherwise you will have to live with slow. FoxPro's data engine is faster than anything around and is free with the software purchase, no need for database managers. It is the best tool for small business RAD and twice as fast to develop than any dot net.

Collapse -

Use Config.nt File to set ENV variables.

by vinod.dhall In reply to why foxpro running slowly ...

Ahh!!!.... Good OLD DOS Apps..

We generally use the following in Config.sys file in DOS for FoxPro Applications.

dos=high, umb
device=Himem.sys
files=20
Buffers=128,256

You can try the same in Config.nt file. This file must exist at SystemRoot%\System32 :

dos=high, umb
device=%SystemRoot%\System32\Himem.sys
files=20

Please take proper backup before applying these settings and do a restart after applying of these settings.

Hope it should help.

Vinod Dhall

Collapse -

Reponse To Answer

by Who Am I Really In reply to Use Config.nt File to set ...

config.nt and autoexec.nt
called by "Command.com"

try running the application after starting Command.com
rather than cmd.exe

start > run
c:\windows\system32\command.com

command.com is a more DOS program compatible DOS shell than cmd.exe is

see this short writeup:
http://www.chami.com/tips/windows/122096W.html

Collapse -

why foxpro running slowly in xp ?

by dartemov In reply to why foxpro running slowly ...

The problem is that FP DOS uses keyboard interceptor and it is this component that loads CPU not FP itself.
Many many years ago there was a program called dpakbd that mitigated the issue to some point.
Below is the piece of readme.txt. Ping me at dmartemov@gmail.com if you want to try it.
DPAKBD is a TSR that attempts to put errant DOS application
that poll the keyboard incessantly to sleep thus enabling
the CPU to service the rest of its process queue. It must be
executed in the same NTVDM as the application but before
the application is executed.

Back to Windows Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Operating Systems Forums