Discussions

WiFi DHCP / Connectivity Issues

Tags:
+
0 Votes
Locked

WiFi DHCP / Connectivity Issues

Genphlux
Okay I've been battling this Wi-Fi problem here at work and I thought I'd type it up and see if any of you could help me out.

Where I work, we have a warehouse area with an automation system & conveyor belt, as well as an administrative office area. I have recently set up a wireless network so that some of the directors and managers can take their laptops out into the warehouse and use them freely.

Configuration: Standard corporate Ethernet network. Win2k3 DHCP server is the most important information here. All Cisco switches, standard patch panels, etc. Wireless consists of two brand new Linksys WAP54G 802.11G APs. Clients are Dell & HP laptops using integrated 802.11G wireless adapters, and connecting via Windows wireless configuration. I have also tried Dell and Linksys for configuration software client-side.

Problem: No matter how I set up the network or configure the APs, the clients can rarely pull a DHCP address. And when they actually do pull one, it only stays for 2 mins or so, and they lose it again. I have tried with our WEP settings, with different WEP settings, and with the standard out-of-the-box wide-open configuration. I set static IPs for the laptops just as a troubleshooting measure, and at first it appeared to have worked OK. However, while they are connected, they have limited network access. If they try to use Citrix, it drops connection constantly. They are unable to hit network printers or shares. But they can browse the web and our intranet, intermittently.

Although I first suspected interference from our automation equipment, signal strength as well as SNR are both well within reasonable and acceptable limits. I don't think the issue is on the radio side.

I have spent countless hours on the phone with Linksys, but they are ultimately no help. Their actual official response was "Well it appears that DHCP probably isn't going to work through the AP, but it might.". WTF??

I spent some time with a packet sniffer (Ethereal) and watched the traffic. You can see that the client requests the IP address from the DHCP server like 4 times in a row before it ever gets a response back from the server. So obviously I start thinking network latency, but ping response times are just fine. The server also always replies, only once, with an IP, as if it were successfully assigned. But the client machine never officially gets the IP and uses it. Also, from the server side, looking at the DHCP logs, as far as the server is concerned it successfully assigned the IP. The logs show a successful assignment to that MAC address. Our DHCP pool has PLENTY of addresses left. We are nowhere near running out.

I have put a band-aid solution up, just to get them going, but I don't understand why it worked, and I don't need to keep it this way.

I brought in from home a Netgear 8 port SOHO router/switch. I seperated the network and used a completely different IP addressing scheme than what we use here. I patched the APs directly into the Netgear and allowed them to pull addresses from it rather than our Win2k3 DHCP server, and it works great now. It hasn't dropped once.

Also keep in mind that I have the APs set up for static IPs for the AP itself. I can remote into the web console no matter where the AP is plugged into the network, its just that the AP doesn't function as it should. It doesn't forward DHCP traffic normally.

The DHCP server works fine with any machine that is plugged into it, as long as its wired. Like I said, we have plenty of addresses in the pool and you can release/renew all day long with no problem until you try it wirelessly.

I'm sure I've left details out, as I have spent a considerable amount of time on this issue, but I need to get it working with our DHCP server and get my Netgear off the network. Any ideas?