General discussion

Locked

Win 98 DUN and Win NT 4.0 RAS

By bcasey ·
I have a client that is connecting to a NT 4 workstation running RAS. She is using Win 98 DUN. The Workstation is simply acting as a pass through for a DHCP server on the intranet to get TCP/IP addresses for access trough a router to the internet. We are acting like an ISP for her. The problem is suddenly she no longer gets to the DHCP or her computer is supplied with the wrong IP Address for the default gateway on the network. I have determined that her computer is trying to use the IP addressgiven to her computer as the router IP address. I can't figure out why. Any help would be appreciated.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by teddyrux In reply to Win 98 DUN and Win NT 4. ...

Have you checked the IP address set for the gateway on her pc. It's possible it got changed or manually set.

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by bcasey In reply to Win 98 DUN and Win NT 4. ...

Unfortunately she is in Minnesota and I am in Missouri. I can only go by what she is telling me and those things seem to be set correctly.

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by ShawnS In reply to Win 98 DUN and Win NT 4. ...

Ok I'm assuming that she has a NIC in this 98 PC as well and has a static IP normally.?.? If so you might need to create a second hardware profile and a second user log on. The first one would be for normal network logon with the NIC. the second would have the hardware profile for the modem dialup access. There buy splitting IP network settings so they don't confuse the OS.

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by bcasey In reply to Win 98 DUN and Win NT 4. ...

She is using a Laptop and no NIC. The connection was working three weeks ago and suddenly stopped. Using Winipcfg id noted that her IP address is the same as the default gateway.

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by Bill Cassada In reply to Win 98 DUN and Win NT 4. ...

Edit the TCPIP properties under the DUN connection. Clear any entries in there...except that you may want to hardcode the gateway here if she only dials in to you. Also ensure that she is set to obtain info from a DHCP server (also in the properties). Reboot. If this doesn't fix it let me know and we can get deeper into it.

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by bcasey In reply to Win 98 DUN and Win NT 4. ...

Poster rated this answer

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by troberts In reply to Win 98 DUN and Win NT 4. ...

When you say "wrong IP address for the default gateway" do you mean that the W98 machine shows that the gateway address = the address allocated by DHCP on the dial-up connection? This is standard behaviour as the assumption is that all network traffic is accessible only via the DUN connection. In a non-networked PC this is exactly what you want. If the PC connected to a LAN which has its own gateway at the same time as it is in a DUN session the PC will not be able to see the other networks outside its local one (except via DUN).

Assuming the w98 PC is standalone then in a DUN session you should see:
IP Address = Address allocated by DHCP via DUN
Default Gateway = Same address
WINS/DNS = Allocated by DHCP via DUN

My first test would be, can the client PC ping the NT Workstation? By Address? By Name?. If it can, can you ping it?
If it can't, get your client to use WINIPCFG to release the current IP settings, dial-in again and check your DHCP servers leases against the clientPC's settings.
Second test, Can the client ping another machine on the dialed-up network? By Address or Name.
If it can't, is IP forwarding enabled on the NT Workstation?

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by bcasey In reply to Win 98 DUN and Win NT 4. ...

Poster rated this answer

Collapse -

Win 98 DUN and Win NT 4.0 RAS

by bcasey In reply to Win 98 DUN and Win NT 4. ...

This question was closed by the author

Back to Windows Forum
9 total posts (Page 1 of 1)  

Operating Systems Forums