General discussion

Locked

Win 98 reboots on shutdown

By TMan12 ·
I reinstalled a fesh copy of Window 98 on a Compaq Persario 2266. It runs fine, but when I select shutdown, it reboots instead. I can change the power setting in the BIOS, but every option results in the same with the exception of disablilng the PowerManagement. When I do this, I get the screen "It is now safe to turn off your computer", which you then have to press the power button for 5 seconds before it will power off. (This is not the solution I am looking for) I have applied the shutdown fix patch fom Microsofts website as well, and downloaded all OS patches, with no luck.
Any suggestions?
P.S. I have reset all defaults in the BIOS as well.

Thanks,

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Win 98 reboots on shutdown

by Alpha-Male In reply to Win 98 reboots on shutdow ...

Usually this is caused by the system running "fast shutdown". Try disabling this and see if it helps.

Click on Start and go to run.
type msconfig
click on advanced
check disable fast shutdown
reboot

Hope this helps!

Collapse -

Win 98 reboots on shutdown

by TMan12 In reply to Win 98 reboots on shutdow ...

For some reason, this does not show up as an option on this system. This is the first time I have come accross a 98 system that does not hsve the "Disable Fast Shutdown" option.

Collapse -

Win 98 reboots on shutdown

by queen1 In reply to Win 98 reboots on shutdow ...

Is this an old copy of win98? Not win98 se? I would check power management in bios and see what that's on. I once had a buggy video card driver that caused a constant reboot check for a newer driver Good luck

Collapse -

Win 98 reboots on shutdown

by TMan12 In reply to Win 98 reboots on shutdow ...

Poster rated this answer

Collapse -

Win 98 reboots on shutdown

by oldwolfmb1 In reply to Win 98 reboots on shutdow ...

Does this compact have an Ethernet Card? Check to make sure Wake on Lan is not enabled in the bios as well.

Collapse -

Win 98 reboots on shutdown

by TMan12 In reply to Win 98 reboots on shutdow ...

Poster rated this answer

Collapse -

Win 98 reboots on shutdown

by svrarvind In reply to Win 98 reboots on shutdow ...

IRQ Steering and Device Enumeration

Select Start > Settings > Control Panel
Double-click the System icon, and select the Device Manager tab
Select View Devices by type and double-click System Devices
Select PCI bus and click on the Properties button
Adjust or Disable the settings under the IRQ Steering and/or the Settings tab to get the desired results. Make note of how you found these settings before you attempt to change them as a precaution

FIRST try changing the Device Enumeration under the Settings tab from Hardware to BIOS. This does the trick in many cases for various problems.
If Not....

Collapse -

Win 98 reboots on shutdown

by svrarvind In reply to Win 98 reboots on shutdow ...

Experiment with enabling or disabling all the combinations of possible settings to try to get the desired results. At times, the BIOS setting that you may or may not have, PnP Aware OS, also has a bearing on these settings....(See below for more info)

Make sure you do a full reboot after every change while testing.

IRQ Steering

Use IRQ Steering - Specifies that Windows programs use IRQ steering. If you select the Use IRQ Steering check box, PCI bus devices behave more like Plug and Play devices. If you click to clear the Use IRQ Steering check box, then BIOS programs dictate IRQ steering.

IRQ steering is determined by one of four routing TABLEs. Windows searches for one of the selected routing TABLEs in the order listed anduses the first one it finds.

Do not change the default settings for IRQ steering unless there is a problem with a PCI device
If there is a problem, click to clear the Get IRQ TABLE using ACPI BIOS check box and restart Windows
If the problempersists, select the Get IRQ TABLE from Protected Mode PCI BIOS 2.1 call check box and restart Windows
Select the Get IRQ TABLE from Protected Mode PCI BIOS 2.1 call check box only if a PCI device is not working properly
One combination that worked for a number of people was to go into your system's BIOS, and make sure that ACPI I/O Node is set to Enabled, and to set the IRQ Steering to Get IRQ TABLE using ACPI BIOS, while unchecking all others.

For some others unchecking the Get IRQ TABLE from Realmode PCIBIOS 2.1 Call, while leaving all other options as they where did the trick.


Assign IRQ for your Video Adapter

Another fix that worked for some people is to go in your systems BIOS, and assign an IRQ for your Video Adapter (you might not have this option in your BIOS). This also solves problems with not being able to Restart in MS-DOS mode.

Collapse -

Win 98 reboots on shutdown

by svrarvind In reply to Win 98 reboots on shutdow ...

Enable USB

In some BIOS'ses you can enable/disable USB (by assigning an IRQ to USB). A number of people where able to fix their problem by enabling USB this way, even if they did not have any USB devices attached to their system.


NotesWindows 98 SE has Fast Shutdown turned off by default in msconfig.

For information on how to access your computers BIOS, consult your computer's manual.

For more information, see this Microsoft Knowledge Base Article No. Q238096 How to Troubleshoot Windows 98 Second Edition Shutdown Problems

Collapse -

Win 98 reboots on shutdown

by TMan12 In reply to Win 98 reboots on shutdow ...

I have Disabled USB in the BIOS, and even disabled PCI Bus completley and still seem to have the problem. The only PCI card installed is a modem, and I have it disabled as well.

Back to Windows Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Operating Systems Forums