General discussion

Locked

win2k & usb printer ports

By jodaddy ·
when adding a usb printer the usb ports don't come up as a choice.the ports work because i can put another device on them and it sees them. the printer works because i can put it on another machine and it is seen also. how can i get win2k to offer usb001, usb002, etc as a viable choice of printer ports. i am on sp4 and current with all other critical patches.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by TheChas In reply to win2k & usb printer ports

For many USB devices, you need to install the driver prior to connecting the hardware.

Then, you must connect and turn on the printer for Windows to complete the installation.

Chas

Collapse -

by debian In reply to win2k & usb printer ports

ProblemMany printers today have a USB interface (Universal Serial Bus) as well as a traditional LPT interface. RDP suggest using the LPT interface whenever possible. However, some printers only come with a USB interface. Also, some workstations today only have a USB port. USB printers can be used with RDP if the following conditions are met:
USB printers must be connected to a Windows 2000 or Windows XP machine.
USB printers will not work when connected to Win95/98/ME
USB printers will not work with Novell Client software Installed
USB printer must be set up as a windows shared printer
Solution
The steps to installing a USB Printer are as follows:
Connect the USB printer to a Windows 2000 or XP workstation
Install the Windows driver software with the CD provided with the printer.
Test the printer from Windows and make sure it prints.
In Windows, share the printer (see the section above "Testing Shared printers from the command prompt" for details)
On menu 98, use option 096 to configure the printer as a Windows Shared printer (RDP Printer # 5-99). Do NOT configure the printer in RDP as a "local" printer.
Test printing with RDP, using F2-Print Screen. Make sure to choose the correct RDP Printer #, which has to be #5 to 99. You cannot use 1-4 with shared printers.
All workstations, including the workstation where the USB printer is physically connected should be able to print to the USB printer using RDP printer #5-99.
Troubleshooting - Windows 2000/XP uses must be a member of local Administrator GroupMicrosoft added significant local security to Windows 2000 and Windows XP. A user with minimal rights does not have access to write files to the "C" drive, or to re-direct printing to shared network printers, both of which are required for RDP software to function properly. To solve this problem each user of a Windows 2000 or XP workstation must be a member of the administrator group on the workstation, which gives the user complete access a

Collapse -

by debian In reply to

Use this lik it will solve your problem

http://www.resortdata.com/Customers/Knowledge/KB-DOS/K000114.htm

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums