General discussion

Locked

windows 2000 and routers

By pagc ·
My client has workstations with win2k prof. and a win2k server with this they have micronet IP Router SP866 to access the internet. The configuration of the TCP/IP protocol of each workstation, I put the IP address of the router for the gateway and for the DNS, the IP address of the internet service provider. It works fine when they need to enter the internet but the router is always connecting to the internet spending a phone call out need, each time a computer is turned on or when accessing other stations in the network. Where am I doing it wrong? Is there a configuration that I have missed? Please do help me, it is most urgent!

This conversation is currently closed to new comments.

16 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

windows 2000 and routers

by pagc In reply to windows 2000 and routers

Point value changed by question poster.

Collapse -

windows 2000 and routers

by isys In reply to windows 2000 and routers

Go to each computer, in Control Panel, Internet Options, Connections, check "Never Dial a Connection".

Collapse -

windows 2000 and routers

by pagc In reply to windows 2000 and routers

Poster rated this answer

Collapse -

windows 2000 and routers

by Pan 13 x In reply to windows 2000 and routers

there is no solution unless you change the way they are connecting to the internet. You may try with one computer , changing the default gateway to a fileserver and leave the file server the gateway of the router.

Collapse -

windows 2000 and routers

by pagc In reply to windows 2000 and routers

Poster rated this answer

Collapse -

windows 2000 and routers

by SnowManInHI In reply to windows 2000 and routers

Why does the router dial the internet every time you start a computer? A simple DNS query will cause the router to dial the internet. Since you have set the DNS entry to your ISP, it attempts to contact your ISP for that information. You could setup the server to have DNS loaded, and point the DNS to your server. If the entries that are being looked up are in the cache, the internet will not be dialed. Remember that Win2k is heavily dependant on DNS.

Collapse -

windows 2000 and routers

by ustutz In reply to windows 2000 and routers

Basically the reason you are dialing out everytime you boot is: When you boot a workstation, it has to establish connectivity to its name services. This is time, for example, when it picks the primary and secondary DNS (and WINS) servers - based on their responses.

The way around dialing out on every reboot is to set up a local DNS server on your site. Two options there - and I am shooting outside my lane on one:

1. Set up DNS on one of your own servers. Configure it to forward any unresolved querries tot he ISP DNS. (I doubt the ISP will let you set up a secondary server to their DNS, but they might - that would be even better).

2. Set up the router as a DNS forwarder (similar to how it might be set up as a BOOTP relay??). That way the router becomes the primary (and secondary) DNS server. It won't dial out just for a response check at boot time. But it would dial out for honest DNS queries. This is the one I am shooting outside my lane: I don't know what the capabilities of your router are, and how that would be configured.

Collapse -

windows 2000 and routers

by curlergirl In reply to windows 2000 and routers

Is your Win2K server running DNS? If not, it should be. You should have your workstations pointing to the internal server for DNS. You can then set up your internal server to use the ISP's DNS server(s) as forwarders. This will improve your nameresolution speed and should also limit the dial-ups to times when the Win2K server actually has to reach the ISP's DNS servers to resolve a name. Hope this helps!

Collapse -

windows 2000 and routers

by SnowManInHI In reply to windows 2000 and routers

This is wierd, I wrote an answer, saw it posted and came back and it was gone.. So if this gets duplicated, please excuse...

Anyway, What you are seeing is that Windows 2000 is trying to resolve a DNS entry and it is attempting to contact the DNS server. You have configured your DNS server as the ISP DNS server, so it attempts to check the name with the DNS server, fails, then goes to WINS to check it.

You can try the following: Setup DNS services on the Win2k server as a Caching server, set your workstation to look at the Win2k server for DNS. This should prevent some of the dialing of the internet for "no reason" though it will still initiate a call when you NEED to resolve a DNS entry that is outside of your office, but by definition then you will be using the internet. Once everything is in cache, you shouldn't have too much of a problem with auto-dials.

Collapse -

windows 2000 and routers

by SnowManInHI In reply to windows 2000 and routers

Remember that NT4 looked at WINS first, and as I understand W2k looks at DNS first to resolve machine names.

Back to Windows Forum
16 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Operating Systems Forums