Discussions

Windows 2003 Server eMail without Exchange help

+
0 Votes
Locked

Windows 2003 Server eMail without Exchange help

nblake
I have a very small network consisting of 3 workstations and a Windows 2003 Server setup. It is running DHCP, DNS, and Active Directory. I have setup my entire 3 users in AD, and have joined the domain, etc. I do not have Exchange setup yet on it. I am debating on setting it up for such a small setup. I figured I would just set up each persons email accounts in their Outlook which is OL2003(our accounts are pop3/smtp) accounts through our IE service provider. I went in and set all of the email settings on my first workstation, and went to test the connection, and it came back and said Unable to connect to the incoming mail server (POP3). Please verify server name in incoming mail server field.
Unable to connect to the incoming mail server (POP3). Please verify server name in incoming mail server field.
If that info is correct, close this dialog, click more settings and verify the port and SSL info on the advanced tab.

It said the same thing for the smtp side. This is very new to me, and this is my first server setup. Am I missing something? Can access the Internet just fine.
Any help would be appreciated.

If I posted this to the wrong spot, my appologies.
  • +
    0 Votes
    CG IT

    TCP/IP port 110 is used by POP3. a firwall might be blocking that traffic.

    +
    0 Votes
    nblake

    Could this be a possible cause:
    When I set this up from the beginning, I wanted to keep everything the same if at all possible, so when I created the domain controller on my server, I named it the same as my email address. Such as my domain would be named PCDomain and my email address would be blabla@PCDomain.com
    Though the email address is an Internet email using pop3 and smtp.

    +
    0 Votes
    Will.Conner

    I had our network here setup exactly like you are discussing before we migrated to Exchange back in 2005 so I have some experience with that setup. Below are some things to check that will hopefully identify your issue.

    1. Ensure your firewall is allowing POP3 traffic on port 110 to your e-mail server if you are accessing this from outside your network. Also ensure that SMTP on port 25 is being allowed access as well so incoming traffic can reach the server.

    2. You will need to create user accounts on the POP3 server for each of your e-mail users. Even though you are on a domain the built-in POP3/SMTP service with Server 2003 does not access active directory like Exchange does for these addresses. Make sure their username on the server is what you want their e-mail address to be. There is a POP3 interface that you will see under Administrative Tools once you add these services that will give you a very simple way to setup their mailboxes and the domain name for e-mail that you want to host. The username setup in Outlook will be username@domain.com when you set it up this way. The server requires that in case it were to be hosting multiple domains.

    3. Ensure that once you open up port 25 for SMTP that you secure your service so that it cannot be used as an open relay for spammers. I accomplished this by requiring all of my POP3 users to authenticate to send mail with the server.

    4. Ensure that the DNS settings for your domain is configured correctly and point to your Internet address so the other mail servers on the Internet can find you. To see if this is working properly with DNS inside your network and outside you can use NSLOOKUP DOMAIN.COM. That should return both your internal mail server's IP for your network and your Internet IP for anyone looking to send mail to your domain from the outside.

    Good luck with your setup.

    +
    0 Votes
    StAlphonzo

    If I'm understanding you properly you're running a Windows 2003 AD domain but are using your ISP for all mail handling. And that you Windows domain name is the same as the ISP mail? If this is the case I'd say your most immediate problem is that your clients are resolving DNS against your WIndows domain and there is no MX record. You should add an MX record in your DNS server that points to your ISP's mail server.

    If this isn't the case another thing you might want to look at is SMTP authentication. There is a setting in Outlook that says something to the affect that mail server requires authentication. I can't verify the syntax because I don't have Outlook installed ion this PC but you might look for this setting and give it a try.

    +
    0 Votes
    nblake

    Yes, you are reading me correctly. The post before yours had some great suggestions too, I just haven't had a chance to work on it or try what was suggested. They also mentioned something about the MX record.
    Not trying to be an idiot, but what is the MX record, where would I get it or find out, and where do I put it in my DNS settings? I have done nothing with MX, heck, I don't even know what it is. This sounds promising and you described my network just like it is setup, but I'm not sure where to start exactly with this.
    Thanks!

    +
    0 Votes
    StAlphonzo

    To add an MX record you need open the DNS management tool on your domain controller and add the record to your main domain?s forward lookup zone. Here?s how:

    Administrative Tools  DNS (or, START RUN  dnsmgmt.msc [Enter])

    Drill down until you see the forward lookup zones folder and find your Windows domain name (which should be the same as your Internet/Mail FQDN).

    Now you need to first add an A record and then you add the MX record. The A record is needed reference or tie an external IP address to a name. MX records cannot contain IP addresses so you need to know the IP address of your current Internet mail server. Inside the forward lookup zone folder you right-click and create a new Host (A) record. Type in the IP address of your Internet mail server and then assign it a name: usually ?mail? but you can call it whatever you want, really.

    Next, right click in the same forward lookup zone folder and create a ?New Mail Exchanger? Record (MX).

    In the Fully Qualified Domain Name field type the name of the A record you just added, for instance: mail.mydomain.com. Leave the mail server priority at 10, which is fine for your application.

    If you?ve set up your Windows DNS server properly it?s likely caching records from your ISP?s DNS servers for domains it doesn?t know about. Because a Windows DNS forward lookup zone exists for your Internet domain (same as your Windows domain name), the DNS server isn?t forwarding requests to your ISP Windows DNS, in this case Your Domain Controller assumes Start of Authority (SOA) therefore it has no idea where to send mail because the MX record has not yet been added (by you!).

    Good luck.

    Pat

    +
    0 Votes
    nblake

    I am going to try all of these things. I won't get to try these things until Sat because my work schedule is overbearing right now, and I almost can't wait. I have a good feeling that I should be able to get something resolved with all of your suggestions and ideas.
    I will post back and let you know how it went. Again, thanks for everyone's help, and I have my fingers crossed :)

    +
    0 Votes
    nblake

    OK, I worked on this Sat, well part of this. Let me explain a little more in detail how I have my network setup and then maybe this will make sense.
    First, I was so looking forward to trying this mx record stuff. I was convinced this would work and fix everything.

    Internet - Modem -
    Netgear Wireless Router (DHCP off)
    - Win 2003 Server
    - domain workstation
    - DLink wired router (DHCP on)
    - stand alone PC 1 (not on domain)
    - stand alone PC 2 (not on domain)


    Everything was working fine. The DLink router is basically just an extender because I needed more ports, and that is what I had at the time. So I figured it was all good however when I tried to hook the domain workstation up on the DLink router and couldn't hit the Internet or email. So I figured it was the DHCP on the DLink router. I took that off, and could hit the internet but no email on anything that was plugged into it. So I dug around and found a switch which is what everyone told me to use.
    So that was first on my agenda Sat. I was going to switch out that switch and Dlink router, and then try to fix the email thing that I posted about.
    Switched the dlink router and switch out, and basically plugged the non domain workstations into the switch. So now it looks like this


    Internet - Modem -
    Netgear Wireless Router (DHCP off)
    - Win 2003 Server
    - domain workstation
    - SWITCH
    - stand alone PC 1 (not on domain)
    - stand alone PC 2 (not on domain)

    So now the non domain workstations can hit the Internet, but can't send or receive emails at all. I figured I need to fix this before I even start on the mail server and mx record. Since now not even the non domain PCs can email.
    It has to be a port thing or something??
    This may explain why I couldn't email with the Domain Workstation when it was logged into the domain, hitting the internet and everything just fine. I hadn't installed the mail server piece yet or anything. I was just using the pop3/smtp settings in Outlook.
    I am going to work on this again this evening, and hopefully get this figured out. Once I can get the whole switch email thing figured out then I will go forward with the mail server and MX record, etc. Any ideas on the switch issue? On a workstation that works just fine emailing and on the internet and is not on the domain, but when you plug it into the switch, it stops being able to send and receive emails?
    Any help will be sooo appreciated!!! It may be a simple fix, like opening a port?? But I don't even know where to begin on that. The windows server doesn't have the firewall turned on, and the workstations don't have their firewalls turned on, the Netgear router has a built in firewall. Could this be the cause? If so, how do I fix that?
    Thanks

  • +
    0 Votes
    CG IT

    TCP/IP port 110 is used by POP3. a firwall might be blocking that traffic.

    +
    0 Votes
    nblake

    Could this be a possible cause:
    When I set this up from the beginning, I wanted to keep everything the same if at all possible, so when I created the domain controller on my server, I named it the same as my email address. Such as my domain would be named PCDomain and my email address would be blabla@PCDomain.com
    Though the email address is an Internet email using pop3 and smtp.

    +
    0 Votes
    Will.Conner

    I had our network here setup exactly like you are discussing before we migrated to Exchange back in 2005 so I have some experience with that setup. Below are some things to check that will hopefully identify your issue.

    1. Ensure your firewall is allowing POP3 traffic on port 110 to your e-mail server if you are accessing this from outside your network. Also ensure that SMTP on port 25 is being allowed access as well so incoming traffic can reach the server.

    2. You will need to create user accounts on the POP3 server for each of your e-mail users. Even though you are on a domain the built-in POP3/SMTP service with Server 2003 does not access active directory like Exchange does for these addresses. Make sure their username on the server is what you want their e-mail address to be. There is a POP3 interface that you will see under Administrative Tools once you add these services that will give you a very simple way to setup their mailboxes and the domain name for e-mail that you want to host. The username setup in Outlook will be username@domain.com when you set it up this way. The server requires that in case it were to be hosting multiple domains.

    3. Ensure that once you open up port 25 for SMTP that you secure your service so that it cannot be used as an open relay for spammers. I accomplished this by requiring all of my POP3 users to authenticate to send mail with the server.

    4. Ensure that the DNS settings for your domain is configured correctly and point to your Internet address so the other mail servers on the Internet can find you. To see if this is working properly with DNS inside your network and outside you can use NSLOOKUP DOMAIN.COM. That should return both your internal mail server's IP for your network and your Internet IP for anyone looking to send mail to your domain from the outside.

    Good luck with your setup.

    +
    0 Votes
    StAlphonzo

    If I'm understanding you properly you're running a Windows 2003 AD domain but are using your ISP for all mail handling. And that you Windows domain name is the same as the ISP mail? If this is the case I'd say your most immediate problem is that your clients are resolving DNS against your WIndows domain and there is no MX record. You should add an MX record in your DNS server that points to your ISP's mail server.

    If this isn't the case another thing you might want to look at is SMTP authentication. There is a setting in Outlook that says something to the affect that mail server requires authentication. I can't verify the syntax because I don't have Outlook installed ion this PC but you might look for this setting and give it a try.

    +
    0 Votes
    nblake

    Yes, you are reading me correctly. The post before yours had some great suggestions too, I just haven't had a chance to work on it or try what was suggested. They also mentioned something about the MX record.
    Not trying to be an idiot, but what is the MX record, where would I get it or find out, and where do I put it in my DNS settings? I have done nothing with MX, heck, I don't even know what it is. This sounds promising and you described my network just like it is setup, but I'm not sure where to start exactly with this.
    Thanks!

    +
    0 Votes
    StAlphonzo

    To add an MX record you need open the DNS management tool on your domain controller and add the record to your main domain?s forward lookup zone. Here?s how:

    Administrative Tools  DNS (or, START RUN  dnsmgmt.msc [Enter])

    Drill down until you see the forward lookup zones folder and find your Windows domain name (which should be the same as your Internet/Mail FQDN).

    Now you need to first add an A record and then you add the MX record. The A record is needed reference or tie an external IP address to a name. MX records cannot contain IP addresses so you need to know the IP address of your current Internet mail server. Inside the forward lookup zone folder you right-click and create a new Host (A) record. Type in the IP address of your Internet mail server and then assign it a name: usually ?mail? but you can call it whatever you want, really.

    Next, right click in the same forward lookup zone folder and create a ?New Mail Exchanger? Record (MX).

    In the Fully Qualified Domain Name field type the name of the A record you just added, for instance: mail.mydomain.com. Leave the mail server priority at 10, which is fine for your application.

    If you?ve set up your Windows DNS server properly it?s likely caching records from your ISP?s DNS servers for domains it doesn?t know about. Because a Windows DNS forward lookup zone exists for your Internet domain (same as your Windows domain name), the DNS server isn?t forwarding requests to your ISP Windows DNS, in this case Your Domain Controller assumes Start of Authority (SOA) therefore it has no idea where to send mail because the MX record has not yet been added (by you!).

    Good luck.

    Pat

    +
    0 Votes
    nblake

    I am going to try all of these things. I won't get to try these things until Sat because my work schedule is overbearing right now, and I almost can't wait. I have a good feeling that I should be able to get something resolved with all of your suggestions and ideas.
    I will post back and let you know how it went. Again, thanks for everyone's help, and I have my fingers crossed :)

    +
    0 Votes
    nblake

    OK, I worked on this Sat, well part of this. Let me explain a little more in detail how I have my network setup and then maybe this will make sense.
    First, I was so looking forward to trying this mx record stuff. I was convinced this would work and fix everything.

    Internet - Modem -
    Netgear Wireless Router (DHCP off)
    - Win 2003 Server
    - domain workstation
    - DLink wired router (DHCP on)
    - stand alone PC 1 (not on domain)
    - stand alone PC 2 (not on domain)


    Everything was working fine. The DLink router is basically just an extender because I needed more ports, and that is what I had at the time. So I figured it was all good however when I tried to hook the domain workstation up on the DLink router and couldn't hit the Internet or email. So I figured it was the DHCP on the DLink router. I took that off, and could hit the internet but no email on anything that was plugged into it. So I dug around and found a switch which is what everyone told me to use.
    So that was first on my agenda Sat. I was going to switch out that switch and Dlink router, and then try to fix the email thing that I posted about.
    Switched the dlink router and switch out, and basically plugged the non domain workstations into the switch. So now it looks like this


    Internet - Modem -
    Netgear Wireless Router (DHCP off)
    - Win 2003 Server
    - domain workstation
    - SWITCH
    - stand alone PC 1 (not on domain)
    - stand alone PC 2 (not on domain)

    So now the non domain workstations can hit the Internet, but can't send or receive emails at all. I figured I need to fix this before I even start on the mail server and mx record. Since now not even the non domain PCs can email.
    It has to be a port thing or something??
    This may explain why I couldn't email with the Domain Workstation when it was logged into the domain, hitting the internet and everything just fine. I hadn't installed the mail server piece yet or anything. I was just using the pop3/smtp settings in Outlook.
    I am going to work on this again this evening, and hopefully get this figured out. Once I can get the whole switch email thing figured out then I will go forward with the mail server and MX record, etc. Any ideas on the switch issue? On a workstation that works just fine emailing and on the internet and is not on the domain, but when you plug it into the switch, it stops being able to send and receive emails?
    Any help will be sooo appreciated!!! It may be a simple fix, like opening a port?? But I don't even know where to begin on that. The windows server doesn't have the firewall turned on, and the workstations don't have their firewalls turned on, the Netgear router has a built in firewall. Could this be the cause? If so, how do I fix that?
    Thanks