General discussion

Locked

XP PRO IN WORKGROUP AND GUEST ACCOUNT

By twpps ·
HI all,
Got a little question for you. I got 2 Xp pro machine in a single workgroup(ABCD). The 2 computers see each other in the network places. But when a try to see or connect a shared. I got an error telling me... It does not accept blank password etc. I can make it work is a unable the guest account but i dont want to. Is there a way to make them communicate without using the guest account. If I open the guest account and I'm behind a Linksys firewall/router. What is the possible security risk.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

XP PRO IN WORKGROUP AND GUEST ACCOUNT

by twpps In reply to XP PRO IN WORKGROUP AND G ...

Found it in XP tip mailling list of march 7 2002

Among the many changes that Microsoft made in Windows XP are some minor yet very important changes in the security model. If you have a local network, you'll definitely want to know them. If you're not connected to a network and other users don't remotely connect to your machine, this information will not affect you.

If you're running a network and have Windows XP Home Edition or Windows XP Professional in a workgroup (not in a domain), you'll need to know that all inbound network connections are authenticated as Guest. In other words, when someone tries to access files on your machine, they are authenticated as Guest on your machine, even if they have defined a different username and password. All remote connections are treated equally: Everyone who tries to access the remote computer will have the same permissions. It's very important to realize that any user who can access your computer from the network can access the shared files.

This puts your sharing infrastructure in an all-or-nothing mode. Either you allow all users access to your shared file or deny access to everyone. This might work fine in a home environment, but it's not recommended for corporate networks.

To disable this feature and return to the old per-user permissions:


Open the Local Security Policy console in the Administrative Tools folder.
Browse down to: Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options.
Double-click on the Network Access: Sharing And Security Model For Local Accounts.
Change the settings from Guest Only to Classic. This feature is, by default, set to Classic when Windows XP Professional is joined to a domain.

Collapse -

one other thing

by madroxxx In reply to XP PRO IN WORKGROUP AND G ...

You may want to create the same user on both computers with the same password.

Collapse -

one other thing

by madroxxx In reply to XP PRO IN WORKGROUP AND G ...

You may want to create the same user on both computers with the same password.

Collapse -

Sure thing

by chris_beegle In reply to XP PRO IN WORKGROUP AND G ...

Go to Start -> Programs(Depending on Classic or XP Style Menu) -> Administrative Tools -> Local Security Policy

Local Polices -> Security Options
Set the:
Accounts: Limit local account use of blank passwords to console logon only.
to Disabled.

It'll fix ya up in a jiffy.

Back to IT Employment Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums