id="info"

Question

Locked

XP pro missing services.

By celtickerr1888 ·
Hi,
Dual boot PC (Linux, XP pro). Cannot access internet via XP. Nor can launch system restore or Help & Support. No problems under Linux.
IP address showing as null.Releasing it reurns 'already released'. Trying to renew gives error message re RCP server unavailable.
Checking services I cannot find DHCP & DNS. Is there any way I can reload them ? Any ideas as to how this happened ? Scans don't show any viruses/malware.
Thanks for any contributions.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Clients

by IC-IT In reply to XP pro missing services.

Do you have the DHCP and DNS Client Services? The message wants the Remote Procedure Call (RPC) set to automatic.
Spybot advanced mode (Tools) may show some evil BHOs or ActiveX, or stratup processess.

Collapse -

xp pro missing services

by celtickerr1888 In reply to Clients

Thanks for taking the time to reply. Problem is dns & dhcp do not appear in the list of services at all, thus I cannot restart them. No idea why this has occurred.

Collapse -

Have you tried safe mode with networking

by ComputerCookie In reply to xp pro missing services

If you try that it may work, else try system restore in safe mode.

Other than that you can back and try and repair with the XP disk.

If that fails you should reinstall.

Note, if you don't know how to use repair with your XP disk it will do nothing, ask!!

Collapse -

Windows XP missing services

by celtickerr1888 In reply to Have you tried safe mode ...

Thanks to all who replied. Couldn't access system restore from within Windows nor boot from XP CD thereby accessing Recovery console etc.presumably due to grub loader. Didn't wish to uninstall Linux so booted from Knoppix distro DVD, mounted XP partition & set to read/write. Was then able to manually recreate a valid restore point & all was well. All part of the great learning process !

Back to Networks Forum
5 total posts (Page 1 of 1)  

Hardware Forums