General discussion

Locked

Your HDD has switched to the dos mode!

By wbkern ·
When running win98 a white box, will slow down and start running slow.... I found this out by right clicking my computer foing to properties and checking system resources. A box open on the stating " your had drive has changed to DOS mode.. I added 3 more fans to the system, and the problems still happing. Has any one had this problem & / or found a answer.. Thanks, Bill

This conversation is currently closed to new comments.

16 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Your HDD has switched to the dos mode!

by joel In reply to Your HDD has switched to ...

If your disk drives are using MS-Dos compatibility mode then it could be that you have corrupted IDE drivers or it could also be a virus that has infected your master boot record.

Collapse -

Your HDD has switched to the dos mode!

by wbkern In reply to Your HDD has switched to ...

The question was auto-closed by TechRepublic

Collapse -

Your HDD has switched to the dos mode!

by RMmcp In reply to Your HDD has switched to ...

Ok, start by replacing the IDE controller driver files.

Run SFC.exe.

Select "Extract one file...".
For the name enter: MSHCD.INF
Of course the source is the Win98 CD.
Save it to :\Windows\INF

Also, extract the following file to the INF directory:
DISKDRV.INF

Now the spooky part.
Open System Properties\Device Manager.
Expand the Hard Disk Controller tree. Select the parent Bus master controller entry. Usually the first listed (do not select a Primary or Secondary; they are justpart of the parent controller) and Remove it. Scary huh!
Reboot the computer and allow it to reinstall the IDE controllers. This will be using the freshly extracted files. Hope that helps.

Collapse -

Your HDD has switched to the dos mode!

by wbkern In reply to Your HDD has switched to ...

The question was auto-closed by TechRepublic

Collapse -

Your HDD has switched to the dos mode!

by csheltcomp In reply to Your HDD has switched to ...

Reinstall over top of the current if there are no virus' present. This will(85%) of the time get rid of the dos compat. mode.

Collapse -

Your HDD has switched to the dos mode!

by wbkern In reply to Your HDD has switched to ...

The question was auto-closed by TechRepublic

Collapse -

Your HDD has switched to the dos mode!

by s.jong In reply to Your HDD has switched to ...

This problem could also be caused by a DOS atapi driver that is executed by the autoexec.bat. Check your autoexec.bat and config.sys and remove all atapi related lines in those files.

Collapse -

Your HDD has switched to the dos mode!

by wbkern In reply to Your HDD has switched to ...

The question was auto-closed by TechRepublic

Collapse -

Your HDD has switched to the dos mode!

by moflic In reply to Your HDD has switched to ...

You haven't by any chance clicked in system properties something like "disable 32bit file access for disk drives"(or something...) in file system properties? I'm on a linuxbox now, so I don't know how's exactly called, but it's in system properties>file system properties>the last tab i guess... Have you any devices installed in config.sys that drive a hdd/cdrom?

Collapse -

Your HDD has switched to the dos mode!

by wbkern In reply to Your HDD has switched to ...

The question was auto-closed by TechRepublic

Back to Windows Forum
16 total posts (Page 1 of 2)   01 | 02   Next

Operating Systems Forums