Questions

2 nics 1 windows 2003 server

Tags:
+
0 Votes
Locked

2 nics 1 windows 2003 server

mark_tyan
I am trying to assign network traffic to pass over 1 onboard Ethernet adapter. All traffic should pass over this nic. I have configured the nic with a static IP address, mask and gateway. This works fine until I add the 2nd Ethernet adapter (static ip & mask assigned, no gateway, since I can only have one gateway assigned). The only traffic I want to pass over the 2nd Ethernet adapter is vlan traffic. Keep in mind; I have Ethernet 1 that is connected to my LAN via direct connection to a layer 3 switch. Ethernet 2 is connected to another isolated switch directly plugged into the switch from the server (layer 2 switch VLAN trunking not enabled, and routing not available in the layer 2 switch) away from LAN traffic.

I only need to do this so that Ethernet 2 can manage a hardware component that is on the isolated switch. I have attempted to make routing table adjustment, but the isolated switch is just that isolated it does not have a gateway assigned, so my route settings never work successfully, or I am missing something.

The only way I have gotten this to work is disable nic1, and I can manage what I need through nic2.
sample:

win03 server
nic 1 > 192.168.1.10/255.255.255.0/gateway 192.168.1.1 (works fine)
this is connected to a HP Procurve 56oo layer 3 switch on local LAN

nic 2 > 192.168.1.25/255.255.255.0 /no gateway assigned this is plugged directly into a netgear layer 2 managed 7224 switch that is isolated from LAN.

The switch that is configured for nic 2 is 24 ports, I took 10 of those ports on that switch and created a VLAN for iscsi traffic. the remaining ports do infact have access to the local lan. So When I mention isolated, I actually should have been saying the 10-ports on the VLAN are isolated. Which infact is true, since they do not route. Since the switch is not a layer 3. I do not have the ability to trunk a port and route. If I could have just done that I would have just been able to gain access to that vlan via my lan. Nic 2 oluggs directly into the vlan to which i need access to manage a hardware device on that vlan.


I thought this might be a routing issue, but not sure

Anyones help or suggestions would be very greatly appreciated.