Questions

Access Denied on a usb drive

Tags:
+
0 Votes
Locked

Access Denied on a usb drive

mr_t_wright
Ok so my when I put my usb drive into my computer yesterday it told me "access denied" when I tried to open it. I have owner ship of it, it allows me to access it, if I right click and use "explore" but I cant save to it. And the day before I didnt have this problem...
  • +
    0 Votes
    seanferd

    You may have set it to 'read-only' somewhere.

    +
    0 Votes
    mr_t_wright

    It wasn't set to read only. I am thinking the drive letter changed, but even so, it wouldn't make scene for none of the flash drives that i put it to work. I put two in, and they both say "access denied"

    +
    0 Votes
    Jacky Howe

    Open a Command Prompt by pressing the WinKey + r and then typing <b>cmd</b> in the run box. At the command prompt type the (drive letter): and press Enter.

    drive letter is the drive letter that you are connecting to.

    type dir /ah and press Enter.

    This will display a list of the Hidden files on the Drive. Check whether the following file is there Autorun.inf and also look for suspicious .exe files.

    If the file is there

    type notepad autorun.inf and press Enter.

    Save the file to another location with an extension .txt as this will contain the executable file that is being invoked.

    Type attrib -h -r -s (drive letter):\autorun.inf and press Enter.

    Type del (drive letter):\autorun.inf


    To remove the files from the Registry and the Locations that they are invoked from follow these instructions.

    Tip! The executable file will be named in the file that you previously saved with Notepad.


    Press the WinKey + r and type in <b>msconfig</b> and press Enter. Click on the startup Tab.

    Check the list to find the file that you are looking for, expand the <u>Location</u> column to see where it is loading from in the registry.

    Press the WinKey + r and type in <b>regedt32</b> and click OK. Browse to the key listed in the <u>Location</u> column for Msconfig.

    Delete the key on the right hand side only, that specifically matches that startup file.

    Note the <b>Command</b> folder in msconfig. Browse to the folder, and delete the .exe file.

    :::::eXample:::::

    The Startup TAB of Msconfig will show you the directory where pop.exe loads from:

    <b>Command</b> c:\Windows\system32\pop.exe

    and

    <u>Location</u> will guide you to it's location in the Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    With the registry editor open find the Run key in the left window. On the right hand pane you'll see each file that is in the Run key, pop.exe will be there. Right click and Delete the entry for pop.exe.

    Browse to the c:\Windows\system32 folder, and select the pop.exe file, hold down the Shift Key and press the Del Key.

    Repeat these steps for each item that you want to remove.

    +
    0 Votes
    mjabadilla07

    hi, I got the same problem and got a question cant i just directly select on the file i want to erase and just Shift + del it right away? bec. some of my friends tells me its the easiest way but i have my doubts I'd really appreciate if you clear these things thats bugging my mind right now

    tc God bless

    +
    0 Votes
    Jacky Howe

    the file attributes before deleting the file. That's why it is suggested to use attrib. Also check the root of all of your drive letters for the autorun.

    +
    0 Votes
    mr_t_wright

    No malicious files, the autorun is there. I am still having this annoying problem

    +
    0 Votes
    Jacky Howe

    autorun file. What is it opening?

    * has the drive got a switch to enable write protection.

    EdiT: * afterthought

    +
    0 Votes
    vadrenaline

    Hello dear sir,

    I am viren, my office uses the LAN with cyberoam client and all the computers run a win xp service pack 2, quick heal security (which is password protected and password is not known to me)

    problem: the IT department of the office has disabled all the pendrives in the office, that is, when pendrive is inserted it loads its drives and in my computer f:\ removable disc appears, on clicking it "access is denied" appears.

    I have tried following methods without any use:

    1. installing drivers fro the pendrive
    2. tweaking the registery values of usbstor -->start , it was already set to 3.
    3. creating registery entry for write protect
    4. device manager usb storage is already enabled
    5. tried to access it through command prompt and start-->run, same message "access is denied"

    the IT department has recently block the use of pendrive and there are few secured computers where they are re-opened on the special permission of CEO.

    can you help...

    +
    0 Votes

    your IT department put those security features there for a reason; we can not help you bypass their security

    +
    0 Votes
    Jacky Howe

    Open a Command Prompt by pressing the WinKey + r and then typing <b>cmd</b> in the run box. At the command prompt type the (drive letter): and press Enter.

    drive letter is the drive letter that you are connecting to.

    type dir /ah and press Enter.

    This will display a list of the Hidden files on the Drive. Check whether the following file is there Autorun.inf and also look for suspicious .exe files.

    If the file is there

    type notepad autorun.inf and press Enter.

    Save the file to another location with an extension .txt as this will contain the executable file that is being invoked.

    Type attrib -h -r -s (drive letter):\autorun.inf and press Enter.

    Type del (drive letter):\autorun.inf


    To remove the files from the Registry and the Locations that they are invoked from follow these instructions.

    Tip! The executable file will be named in the file that you previously saved with Notepad.


    Press the WinKey + r and type in <b>msconfig</b> and press Enter. Click on the startup Tab.

    Check the list to find the file that you are looking for, expand the <u>Location</u> column to see where it is loading from in the registry.

    Press the WinKey + r and type in <b>regedt32</b> and click OK. Browse to the key listed in the <u>Location</u> column for Msconfig.

    Delete the key on the right hand side only, that specifically matches that startup file.

    Note the <b>Command</b> folder in msconfig. Browse to the folder, and delete the .exe file.

    :::::eXample:::::

    The Startup TAB of Msconfig will show you the directory where pop.exe loads from:

    <b>Command</b> c:\Windows\system32\pop.exe

    and

    <u>Location</u> will guide you to it's location in the Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    With the registry editor open find the Run key in the left window. On the right hand pane you'll see each file that is in the Run key, pop.exe will be there. Right click and Delete the entry for pop.exe.

    Browse to the c:\Windows\system32 folder, and select the pop.exe file, hold down the Shift Key and press the Del Key.

    Repeat these steps for each item that you want to remove.

    +
    0 Votes
    vadrenaline

    Hello dear sir,

    I am viren, my office uses the LAN with cyberoam client and all the computers run a win xp service pack 2, quick heal security (which is password protected and password is not known to me)

    problem: the IT department of the office has disabled all the pendrives in the office, that is, when pendrive is inserted it loads its drives and in my computer f:\ removable disc appears, on clicking it "access is denied" appears.

    I have tried following methods without any use:

    1. installing drivers fro the pendrive
    2. tweaking the registery values of usbstor -->start , it was already set to 3.
    3. creating registery entry for write protect
    4. device manager usb storage is already enabled
    5. tried to access it through command prompt and start-->run, same message "access is denied"

    the IT department has recently block the use of pendrive and there are few secured computers where they are re-opened on the special permission of CEO.

    can you help...

  • +
    0 Votes
    seanferd

    You may have set it to 'read-only' somewhere.

    +
    0 Votes
    mr_t_wright

    It wasn't set to read only. I am thinking the drive letter changed, but even so, it wouldn't make scene for none of the flash drives that i put it to work. I put two in, and they both say "access denied"

    +
    0 Votes
    Jacky Howe

    Open a Command Prompt by pressing the WinKey + r and then typing <b>cmd</b> in the run box. At the command prompt type the (drive letter): and press Enter.

    drive letter is the drive letter that you are connecting to.

    type dir /ah and press Enter.

    This will display a list of the Hidden files on the Drive. Check whether the following file is there Autorun.inf and also look for suspicious .exe files.

    If the file is there

    type notepad autorun.inf and press Enter.

    Save the file to another location with an extension .txt as this will contain the executable file that is being invoked.

    Type attrib -h -r -s (drive letter):\autorun.inf and press Enter.

    Type del (drive letter):\autorun.inf


    To remove the files from the Registry and the Locations that they are invoked from follow these instructions.

    Tip! The executable file will be named in the file that you previously saved with Notepad.


    Press the WinKey + r and type in <b>msconfig</b> and press Enter. Click on the startup Tab.

    Check the list to find the file that you are looking for, expand the <u>Location</u> column to see where it is loading from in the registry.

    Press the WinKey + r and type in <b>regedt32</b> and click OK. Browse to the key listed in the <u>Location</u> column for Msconfig.

    Delete the key on the right hand side only, that specifically matches that startup file.

    Note the <b>Command</b> folder in msconfig. Browse to the folder, and delete the .exe file.

    :::::eXample:::::

    The Startup TAB of Msconfig will show you the directory where pop.exe loads from:

    <b>Command</b> c:\Windows\system32\pop.exe

    and

    <u>Location</u> will guide you to it's location in the Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    With the registry editor open find the Run key in the left window. On the right hand pane you'll see each file that is in the Run key, pop.exe will be there. Right click and Delete the entry for pop.exe.

    Browse to the c:\Windows\system32 folder, and select the pop.exe file, hold down the Shift Key and press the Del Key.

    Repeat these steps for each item that you want to remove.

    +
    0 Votes
    mjabadilla07

    hi, I got the same problem and got a question cant i just directly select on the file i want to erase and just Shift + del it right away? bec. some of my friends tells me its the easiest way but i have my doubts I'd really appreciate if you clear these things thats bugging my mind right now

    tc God bless

    +
    0 Votes
    Jacky Howe

    the file attributes before deleting the file. That's why it is suggested to use attrib. Also check the root of all of your drive letters for the autorun.

    +
    0 Votes
    mr_t_wright

    No malicious files, the autorun is there. I am still having this annoying problem

    +
    0 Votes
    Jacky Howe

    autorun file. What is it opening?

    * has the drive got a switch to enable write protection.

    EdiT: * afterthought

    +
    0 Votes
    vadrenaline

    Hello dear sir,

    I am viren, my office uses the LAN with cyberoam client and all the computers run a win xp service pack 2, quick heal security (which is password protected and password is not known to me)

    problem: the IT department of the office has disabled all the pendrives in the office, that is, when pendrive is inserted it loads its drives and in my computer f:\ removable disc appears, on clicking it "access is denied" appears.

    I have tried following methods without any use:

    1. installing drivers fro the pendrive
    2. tweaking the registery values of usbstor -->start , it was already set to 3.
    3. creating registery entry for write protect
    4. device manager usb storage is already enabled
    5. tried to access it through command prompt and start-->run, same message "access is denied"

    the IT department has recently block the use of pendrive and there are few secured computers where they are re-opened on the special permission of CEO.

    can you help...

    +
    0 Votes

    your IT department put those security features there for a reason; we can not help you bypass their security

    +
    0 Votes
    Jacky Howe

    Open a Command Prompt by pressing the WinKey + r and then typing <b>cmd</b> in the run box. At the command prompt type the (drive letter): and press Enter.

    drive letter is the drive letter that you are connecting to.

    type dir /ah and press Enter.

    This will display a list of the Hidden files on the Drive. Check whether the following file is there Autorun.inf and also look for suspicious .exe files.

    If the file is there

    type notepad autorun.inf and press Enter.

    Save the file to another location with an extension .txt as this will contain the executable file that is being invoked.

    Type attrib -h -r -s (drive letter):\autorun.inf and press Enter.

    Type del (drive letter):\autorun.inf


    To remove the files from the Registry and the Locations that they are invoked from follow these instructions.

    Tip! The executable file will be named in the file that you previously saved with Notepad.


    Press the WinKey + r and type in <b>msconfig</b> and press Enter. Click on the startup Tab.

    Check the list to find the file that you are looking for, expand the <u>Location</u> column to see where it is loading from in the registry.

    Press the WinKey + r and type in <b>regedt32</b> and click OK. Browse to the key listed in the <u>Location</u> column for Msconfig.

    Delete the key on the right hand side only, that specifically matches that startup file.

    Note the <b>Command</b> folder in msconfig. Browse to the folder, and delete the .exe file.

    :::::eXample:::::

    The Startup TAB of Msconfig will show you the directory where pop.exe loads from:

    <b>Command</b> c:\Windows\system32\pop.exe

    and

    <u>Location</u> will guide you to it's location in the Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    With the registry editor open find the Run key in the left window. On the right hand pane you'll see each file that is in the Run key, pop.exe will be there. Right click and Delete the entry for pop.exe.

    Browse to the c:\Windows\system32 folder, and select the pop.exe file, hold down the Shift Key and press the Del Key.

    Repeat these steps for each item that you want to remove.

    +
    0 Votes
    vadrenaline

    Hello dear sir,

    I am viren, my office uses the LAN with cyberoam client and all the computers run a win xp service pack 2, quick heal security (which is password protected and password is not known to me)

    problem: the IT department of the office has disabled all the pendrives in the office, that is, when pendrive is inserted it loads its drives and in my computer f:\ removable disc appears, on clicking it "access is denied" appears.

    I have tried following methods without any use:

    1. installing drivers fro the pendrive
    2. tweaking the registery values of usbstor -->start , it was already set to 3.
    3. creating registery entry for write protect
    4. device manager usb storage is already enabled
    5. tried to access it through command prompt and start-->run, same message "access is denied"

    the IT department has recently block the use of pendrive and there are few secured computers where they are re-opened on the special permission of CEO.

    can you help...