Questions

Access MS Exchange through VPN

+
0 Votes
Locked

Access MS Exchange through VPN

thuckstep
At the office I'm using a Linksys WRV54G router and connecting to it with Linksys VPN Client on the remote client computer. I can get a VPN connection with no problem, but I cannot get the remote client to connect to the Exchanage server. One clue might be that I have to identify the host server by it's IP address, not it's host name. Any ideas what is going on here?
  • +
    0 Votes
    georgeou

    If you don't have WINS or a manual LMHOSTS file on the remote machine, it won't work. You can put the ip address of the exchange server and its proper name in to the LMHOSTS file and the HOSTS file.

    Exchange in pre-native mode needs WINS or LMHOSTS to work. Exchange 2000 or 2003 in native mode only requires DNS or a HOSTS file to work properly.

    +
    0 Votes
    thuckstep

    I'll look into your suggestions. I'm using Exchange 2003 integrated into SBS 2003. This used to work until I had to update the firmware on my router at the office, then Exchange via VPN quit working right after that.

    +
    0 Votes
    georgeou

    Ah I know what your problem is, it's an old problem I've had many dealings with. I'll bet if you hit IPCONFIG /all you'll see that your DNS now points to 192.168.x.x or something. That will override your VPN DNS/WINS servers and it's quite frustrating. Easiest way to fix that is to turn off the DNS server in your router or manually point your DNS on the client machine to the external DNS server your ISP gives you. That will prevent the external DNS from overriding your VPN DNS servers.

    +
    0 Votes
    CG IT

    he's using Small Business Server 2003 which is a AD domain based network. The problem he's having is that probably when he upgraded the firmware of his router, it reset it to default values. The forwarding of PPTP over 1723 would then disabled on the router. So PPTP over 1723 is being discarded at the router for remote access.

    +
    0 Votes
    georgeou

    This is a very common problem with newer router firmwares that offer DNS services that trump the order of private DNS servers behind VPN services.

    +
    0 Votes
    avi

    I think I am having the same issue... As I don't want to turn off DNS on the server... How do I change the settings on the client machine to point to the external DNS as you have suggested?

    +
    0 Votes
    Dumphrey

    1) remote site and local lan are on different subnets. If both networks use the 192.168.1.x/24 network, it will confuse the bugger out of dns.
    2) VPN client is set to import ip and dns info on connection, or to use the dhcp/dns services of the network connecting to.
    3) To manually set dns for a local client, open a cmd window and type ipconfig /all. Note the dns server ip address. Open network connections, and get the properties for your adapter. get properties for the tcp/ip component. Check the manually assign dns server, and put in the ip noted earlier.

    +
    0 Votes
    wrigley.jenson

    Has anyone gotten anywhere on this? I've found 1332352 forum topics regarding Outlook not being able to connect to Exchange over VPN, but it seems that when someone finds out what's wrong, they don't post their solution on any of them. :)

    Anyone able to kill this gremlin? If so, please post your solution.

    Cheers.

  • +
    0 Votes
    georgeou

    If you don't have WINS or a manual LMHOSTS file on the remote machine, it won't work. You can put the ip address of the exchange server and its proper name in to the LMHOSTS file and the HOSTS file.

    Exchange in pre-native mode needs WINS or LMHOSTS to work. Exchange 2000 or 2003 in native mode only requires DNS or a HOSTS file to work properly.

    +
    0 Votes
    thuckstep

    I'll look into your suggestions. I'm using Exchange 2003 integrated into SBS 2003. This used to work until I had to update the firmware on my router at the office, then Exchange via VPN quit working right after that.

    +
    0 Votes
    georgeou

    Ah I know what your problem is, it's an old problem I've had many dealings with. I'll bet if you hit IPCONFIG /all you'll see that your DNS now points to 192.168.x.x or something. That will override your VPN DNS/WINS servers and it's quite frustrating. Easiest way to fix that is to turn off the DNS server in your router or manually point your DNS on the client machine to the external DNS server your ISP gives you. That will prevent the external DNS from overriding your VPN DNS servers.

    +
    0 Votes
    CG IT

    he's using Small Business Server 2003 which is a AD domain based network. The problem he's having is that probably when he upgraded the firmware of his router, it reset it to default values. The forwarding of PPTP over 1723 would then disabled on the router. So PPTP over 1723 is being discarded at the router for remote access.

    +
    0 Votes
    georgeou

    This is a very common problem with newer router firmwares that offer DNS services that trump the order of private DNS servers behind VPN services.

    +
    0 Votes
    avi

    I think I am having the same issue... As I don't want to turn off DNS on the server... How do I change the settings on the client machine to point to the external DNS as you have suggested?

    +
    0 Votes
    Dumphrey

    1) remote site and local lan are on different subnets. If both networks use the 192.168.1.x/24 network, it will confuse the bugger out of dns.
    2) VPN client is set to import ip and dns info on connection, or to use the dhcp/dns services of the network connecting to.
    3) To manually set dns for a local client, open a cmd window and type ipconfig /all. Note the dns server ip address. Open network connections, and get the properties for your adapter. get properties for the tcp/ip component. Check the manually assign dns server, and put in the ip noted earlier.

    +
    0 Votes
    wrigley.jenson

    Has anyone gotten anywhere on this? I've found 1332352 forum topics regarding Outlook not being able to connect to Exchange over VPN, but it seems that when someone finds out what's wrong, they don't post their solution on any of them. :)

    Anyone able to kill this gremlin? If so, please post your solution.

    Cheers.