Questions

Accessing the setting of my router.

Tags:
+
0 Votes
Locked

Accessing the setting of my router.

salkohan
I have a TZ170 SonicWall router. Installed on a network with Windows NT as OS.
Bymistake I unchecked the rule that said
http and https managment.
Now I can not access my router, by typing my IP address into address bar of my browser.
How can I get into my router again and check that rule back on again?
Thank you.
  • +
    0 Votes
    OH Smeg

    On the back/bottom of the router that you need to use a unbent paper clip to push that you can push in and return the router to Factory Defaults which will then allow you to reset it to what you need.

    Col

    +
    0 Votes
    salkohan

    If I do this then I will lose all the setting , rules and port forwarding that we have created before?

    +
    0 Votes
    OH Smeg

    Yes that is correct you will return the router to the Factory Settings.

    if you can not access it that is your only alternative.

    Col

    +
    1 Votes
    ChrisHowe

    Connect to console port and re-enable https using the command line. Best to leave http disabled. Perhaps you can also ssh into the router.

    [no] web-management https enable
    [no] web-management http enable

    For security leave http turned off.

    +
    0 Votes
    salkohan

    ok, I got the Special cable that I needed to connect the server computer to the router through the console port. Then I lunched the Windows HyperTerminal program to access the CLI.
    According to Sonicwall instuctions I should see the login , password and the model number of router, but the page is blank and I can not type anything. The Hyperterminal program stats shows connected.
    Do you know what is the problem?
    Since there is a Hub that all the computers and the router are connected to that, is it the problem?
    Should I connect the server directly to the router, and then use the special cable to connect the console port to the server?
    Thank you,

    +
    0 Votes
    ChrisHowe

    The console setting for Hyperterminal should be 115200 bits per second (9600 for TZ170), 8 data bits, no parity, 1 stop bit, and no flow control. I think your device is TZ170 so you would use 9600 bits/second. Not sure about Hyperterminal, I use Putty and you have to tell it to connect via serial port.

    Yes, connect directly to the router via the special serial cable. I don't understand how you managed to connect via a hub (switch?). Connect directly from a computer serial port to router console port. If you have no serial port use a usb -> serial adaptor between computer and console cable.

    Personally I would use:
    web-management https enable
    no web-management http enable

    This is because http is not secure. Otherwise enable both and set it however you want when you have browser access again. Pressing the disable button will have sent the [no] options to the router and locked you out.

    Good luck, let us know how you get on.

    +
    0 Votes
    salkohan

    Well, I have done everything that you have mentioned, but still I get a blank page on the HyperTerminal page.
    I don't know what is wrong.
    The HyperTerminal program says connected.
    Is there any other setting that I have to change or to check?

    +
    0 Votes
    ChrisHowe

    Can you confirm the RJ45 end of supplied cable is connected to port marked console and the DB-9 end to the serial port on computer, press "return" and no prompt?

    It seems that the cable is only supplied with systems running OS-Enhanced and there is some doubt as to the operation of console port with OS-standard. If all the above fails you could try to SSH from hyper terminal over the LAN to the IP usually used for HTTPS if port 22 is not blocked. As I said, not familiar with hyperterminal but if this does not do SSH, putty does and it's free. I think that I would try the usual IP first but also try 192.168.168.168 - even as a last ditch try telnetting in.

    Failing this suggest contacting SonicWall. Best of luck - would be interested to know how you get on - get a terminal prompt and all will be well.

  • +
    0 Votes
    OH Smeg

    On the back/bottom of the router that you need to use a unbent paper clip to push that you can push in and return the router to Factory Defaults which will then allow you to reset it to what you need.

    Col

    +
    0 Votes
    salkohan

    If I do this then I will lose all the setting , rules and port forwarding that we have created before?

    +
    0 Votes
    OH Smeg

    Yes that is correct you will return the router to the Factory Settings.

    if you can not access it that is your only alternative.

    Col

    +
    1 Votes
    ChrisHowe

    Connect to console port and re-enable https using the command line. Best to leave http disabled. Perhaps you can also ssh into the router.

    [no] web-management https enable
    [no] web-management http enable

    For security leave http turned off.

    +
    0 Votes
    salkohan

    ok, I got the Special cable that I needed to connect the server computer to the router through the console port. Then I lunched the Windows HyperTerminal program to access the CLI.
    According to Sonicwall instuctions I should see the login , password and the model number of router, but the page is blank and I can not type anything. The Hyperterminal program stats shows connected.
    Do you know what is the problem?
    Since there is a Hub that all the computers and the router are connected to that, is it the problem?
    Should I connect the server directly to the router, and then use the special cable to connect the console port to the server?
    Thank you,

    +
    0 Votes
    ChrisHowe

    The console setting for Hyperterminal should be 115200 bits per second (9600 for TZ170), 8 data bits, no parity, 1 stop bit, and no flow control. I think your device is TZ170 so you would use 9600 bits/second. Not sure about Hyperterminal, I use Putty and you have to tell it to connect via serial port.

    Yes, connect directly to the router via the special serial cable. I don't understand how you managed to connect via a hub (switch?). Connect directly from a computer serial port to router console port. If you have no serial port use a usb -> serial adaptor between computer and console cable.

    Personally I would use:
    web-management https enable
    no web-management http enable

    This is because http is not secure. Otherwise enable both and set it however you want when you have browser access again. Pressing the disable button will have sent the [no] options to the router and locked you out.

    Good luck, let us know how you get on.

    +
    0 Votes
    salkohan

    Well, I have done everything that you have mentioned, but still I get a blank page on the HyperTerminal page.
    I don't know what is wrong.
    The HyperTerminal program says connected.
    Is there any other setting that I have to change or to check?

    +
    0 Votes
    ChrisHowe

    Can you confirm the RJ45 end of supplied cable is connected to port marked console and the DB-9 end to the serial port on computer, press "return" and no prompt?

    It seems that the cable is only supplied with systems running OS-Enhanced and there is some doubt as to the operation of console port with OS-standard. If all the above fails you could try to SSH from hyper terminal over the LAN to the IP usually used for HTTPS if port 22 is not blocked. As I said, not familiar with hyperterminal but if this does not do SSH, putty does and it's free. I think that I would try the usual IP first but also try 192.168.168.168 - even as a last ditch try telnetting in.

    Failing this suggest contacting SonicWall. Best of luck - would be interested to know how you get on - get a terminal prompt and all will be well.