Questions

BIOS not recognising SATA Hard Drive

Tags:
+
0 Votes
Locked

BIOS not recognising SATA Hard Drive

Vonkanaitor
When i started my PC the other day i received the error 'DISK BOOT FAILURE , INSERT SYSTEM DISK AND PRESS ENTER' in the BIOS. The 160g SATA disk was quite old so i bought a new 1 TB HDD. I installed it and i am 100% sure i did it correctly however , it was not 'recognised' either.

My previous HDD has been working for years without any RAID configurations and i am suprised how it stopped working so suddenly.

Motherboard: http://www.abit.com.tw/page/en/motherboard/motherboard_detail.php?pMODEL_NAME=A-N68SV&fMTYPE=Socket+AM2 + NVIDIA GeForce 9600GT and a Non-Brand 4.1 Sound Card

My old hard disk was a MAXTOR , i dont know any details like the model number because i did not buy it.
  • +
    0 Votes
    robo_dev

    The PC power supply must provide both 12V (to spin the motor) and 5V to power the electronics.

    Perhaps the SATA power connector is faulty, or the power supply has an issue, such that it's not providing adequate power for the drives.

    When power is applied, you should hear the hard drive spin-up and reset. If it's dead silent, then it's your power supply and/or the sata power connector.

    If there is a SATA CD-ROM drive, and it's working, try borrowing it's power and/or data cable as a test.

    +
    0 Votes
    OH Smeg

    Is how old is the M'Board here? If it has a few years on it it's possible that the BIOS Battery has gone flat and lost a setting that is required to allow the system to boot off a SATA Drive.

    All Desktop Computers that I've ever dealt with use a CR2032 Coin Battery which is easy to replace and cures a lot of the problems with older M'Boards.

    If that's the problem here you'll need to unplug the system when you replace the Battery as if it falls onto the M'Board it's going to cause a short circuit with a Powered ATX Power Supply. You'll also need to enter the BIOS on the first Boot after replacing the Battery and set the BIOS to it's Defaults and enter the current Date & Time then save the changes as you exit the BIOS. Depending on the M'Board & BIOS Version involved there may be some other changes you need to make as well.

    Col

    +
    0 Votes
    Vonkanaitor

    I went into the Bios and selected Load Optimized settings and now everything is fine!

    +
    0 Votes
    Lazarus439

    I've encountered a number of BIOS that allow/require each SATA channel to be enabled/disabled. I've learned that a disable SATA channel is just that - disabled - and won't see a darn thing. I'd guess your reset of the BIOS parameters turned the channel back on.

    +
    0 Votes
    graham

    Hi,
    Just had the same problem.
    I found out the hard drive had not been formatted. Once formatted it worked ok.

    Worth a try!!

  • +
    0 Votes
    robo_dev

    The PC power supply must provide both 12V (to spin the motor) and 5V to power the electronics.

    Perhaps the SATA power connector is faulty, or the power supply has an issue, such that it's not providing adequate power for the drives.

    When power is applied, you should hear the hard drive spin-up and reset. If it's dead silent, then it's your power supply and/or the sata power connector.

    If there is a SATA CD-ROM drive, and it's working, try borrowing it's power and/or data cable as a test.

    +
    0 Votes
    OH Smeg

    Is how old is the M'Board here? If it has a few years on it it's possible that the BIOS Battery has gone flat and lost a setting that is required to allow the system to boot off a SATA Drive.

    All Desktop Computers that I've ever dealt with use a CR2032 Coin Battery which is easy to replace and cures a lot of the problems with older M'Boards.

    If that's the problem here you'll need to unplug the system when you replace the Battery as if it falls onto the M'Board it's going to cause a short circuit with a Powered ATX Power Supply. You'll also need to enter the BIOS on the first Boot after replacing the Battery and set the BIOS to it's Defaults and enter the current Date & Time then save the changes as you exit the BIOS. Depending on the M'Board & BIOS Version involved there may be some other changes you need to make as well.

    Col

    +
    0 Votes
    Vonkanaitor

    I went into the Bios and selected Load Optimized settings and now everything is fine!

    +
    0 Votes
    Lazarus439

    I've encountered a number of BIOS that allow/require each SATA channel to be enabled/disabled. I've learned that a disable SATA channel is just that - disabled - and won't see a darn thing. I'd guess your reset of the BIOS parameters turned the channel back on.

    +
    0 Votes
    graham

    Hi,
    Just had the same problem.
    I found out the hard drive had not been formatted. Once formatted it worked ok.

    Worth a try!!