Questions

Boot troubles from new SATA drive with Windows XP

+
0 Votes
Locked

Boot troubles from new SATA drive with Windows XP

rob
I thought I had succesfully installed a new SATA drive (Seagate 80 gig, 3.5 inch) in my Laptop. The installation went well, SATA drivers installed from a floppy after selecting F6, and Windows XP home version seemed to happily install. I installed all my other software with no troubles as well. Now if I boot the splashscreen hangs for several minutes and then the system just can not boot. If I leave the windows installation CD in the drive and boot the system starts a new installation which I abandon and on reboot I can boot with no problem from my SATA drive. Rebooting also works fine from the SATA drive. Only a boot from power off seems to require the ritual of the aborted Windows installation. My BIOS boot order is set to Hard drive first with native SATA enabled. Help!
  • +
    0 Votes
    DownRightTired

    had the same problem w/ a computer i built using an old HD. Drove me absolutely crazy for hours. Realized I had the jumper in the slave position. Checked that?

    +
    0 Votes
    rob

    I verified the jumper settings, but they are in the master configuration and there are no other drives. It turns out I had a virus and removing my disk partitions followed by reinstalling Windows fixed it. Perhaps if basements were not allowed in suburban homes the people that write these stupid virus codes would have no place to congregate and would instead see sunlight, learn to breath fresh air, make a few social contacts and stop this sad pathetic hobby of theirs.

    I am grateful for your suggestion, it certainly could have explained the problem.

    +
    0 Votes
    the_webninja

    Try Checking for Updated Motherboard Drivers and check the Website related to your Motherboard for issues related to Sata Drives.
    That would be my first step.
    Also sometimes the Sata Drive is Automatically considered the Boot Drive by the Motherboard, even if you have an IDE Harddrive set to master, it will still try to boot from the Sata First.
    This may be what is causing the Computer to Hang.

    It sounds to me, like you installed XP on the Sata Drive already. And now it won't Boot Properly.
    This sounds like a Corrupted Registry which can also be caused by a Virus embedded in Track Zero.
    Some Viruses actually Move Track Zero to a Different Location which screws everything up. Cause then the Virus cannot even be removed with a Format.

    I can't tell you if this is a Virus Problem or not, I can only tell you that you should Check it with a Recovery Disk.
    Even if the Hardrive is New, if you used a Floppy to Boot, or if you used your Old Hard Drive to Copy Data to this Drive you could have easily infected the new Hard Drive with the Virus.

    One thing is for sure, if the Drive is being detected but you still can't boot from it, then Something is wrong with your Registry Files or Track Zero, something is Corrupted Somewhere.
    Try letting Windows Re-install everything.
    To be on the Safe side, I would even Delete the Partition, then re Create a Partition to kind of do a Low Level Format of the Hard Drive.
    If windows Xp can go through the Install procedures then everything should work fine.
    If you get to the Point where it tries to install the Drivers then it loses the CD, so you cannot read Data from the CD anymore, this is the Symptoms of the MIB Virus one of the most Famous Viruses of 1996

    Check the Mcafee Website for info about this Virus.

    I forgot how to Scan a NTSF Disk, I am not sure if Scan Disk will work on an NTSF Disk or not. I think I need to go take some Gingko, or something.
    But find out how you can Scan your NTSF disk and Do it. It might have Errors on it somewhere that would corrupt the data.

    Your Data is Screw up for one reason or another, either because of a Virus, Because of a Messed up Registry, or because of Disk Errors. You need to find out which one it is.

    I hope this helps,

    the_webninja@yahoo.com

    +
    0 Votes
    rob

    Thank you, thank you, thank you.
    I removed all partitions and reinstalled Windows XP (as well as the SATA drivers through F6 and floppy). Problem solved. You were correct in suspecting a virus. If there is ever anything I can do for you (kidney donation for transplant, etc.) let me know!

    Thank you again.

  • +
    0 Votes
    DownRightTired

    had the same problem w/ a computer i built using an old HD. Drove me absolutely crazy for hours. Realized I had the jumper in the slave position. Checked that?

    +
    0 Votes
    rob

    I verified the jumper settings, but they are in the master configuration and there are no other drives. It turns out I had a virus and removing my disk partitions followed by reinstalling Windows fixed it. Perhaps if basements were not allowed in suburban homes the people that write these stupid virus codes would have no place to congregate and would instead see sunlight, learn to breath fresh air, make a few social contacts and stop this sad pathetic hobby of theirs.

    I am grateful for your suggestion, it certainly could have explained the problem.

    +
    0 Votes
    the_webninja

    Try Checking for Updated Motherboard Drivers and check the Website related to your Motherboard for issues related to Sata Drives.
    That would be my first step.
    Also sometimes the Sata Drive is Automatically considered the Boot Drive by the Motherboard, even if you have an IDE Harddrive set to master, it will still try to boot from the Sata First.
    This may be what is causing the Computer to Hang.

    It sounds to me, like you installed XP on the Sata Drive already. And now it won't Boot Properly.
    This sounds like a Corrupted Registry which can also be caused by a Virus embedded in Track Zero.
    Some Viruses actually Move Track Zero to a Different Location which screws everything up. Cause then the Virus cannot even be removed with a Format.

    I can't tell you if this is a Virus Problem or not, I can only tell you that you should Check it with a Recovery Disk.
    Even if the Hardrive is New, if you used a Floppy to Boot, or if you used your Old Hard Drive to Copy Data to this Drive you could have easily infected the new Hard Drive with the Virus.

    One thing is for sure, if the Drive is being detected but you still can't boot from it, then Something is wrong with your Registry Files or Track Zero, something is Corrupted Somewhere.
    Try letting Windows Re-install everything.
    To be on the Safe side, I would even Delete the Partition, then re Create a Partition to kind of do a Low Level Format of the Hard Drive.
    If windows Xp can go through the Install procedures then everything should work fine.
    If you get to the Point where it tries to install the Drivers then it loses the CD, so you cannot read Data from the CD anymore, this is the Symptoms of the MIB Virus one of the most Famous Viruses of 1996

    Check the Mcafee Website for info about this Virus.

    I forgot how to Scan a NTSF Disk, I am not sure if Scan Disk will work on an NTSF Disk or not. I think I need to go take some Gingko, or something.
    But find out how you can Scan your NTSF disk and Do it. It might have Errors on it somewhere that would corrupt the data.

    Your Data is Screw up for one reason or another, either because of a Virus, Because of a Messed up Registry, or because of Disk Errors. You need to find out which one it is.

    I hope this helps,

    the_webninja@yahoo.com

    +
    0 Votes
    rob

    Thank you, thank you, thank you.
    I removed all partitions and reinstalled Windows XP (as well as the SATA drivers through F6 and floppy). Problem solved. You were correct in suspecting a virus. If there is ever anything I can do for you (kidney donation for transplant, etc.) let me know!

    Thank you again.