Questions

Brain Teaser !!! ]:)

+
0 Votes
Locked

Brain Teaser !!! ]:)

ThumbsUp2
I?m tired of reading all of the password/hacking requests (and bored), so I thought I?d throw a little brain teaser at you, just to see if anyone is awake. I?ll try to keep it simple, but THIS IS A QUIZ!!!!!!

System:
Windows XP Pro ? SP2 fully patched
Dual monitor set up, left and right

Work Environment:
In this particular dual monitor setup, the left monitor is #1 and the right is #2. You have #2 application moved over and displayed on the right monitor (maximized) and #1 application being displayed on the left (maximized). Everything works fine and you use it on a daily basis this way. Every time you start these applications, they display exactly where you left them (i.e.: #1 app displays on #1 monitor and #2 app displays on #2 monitor).

Scenario:
The BOSS notifies you on Monday morning after you?ve started working for the day that he?s sending you and your computer to HQ to work from there for a few days. They want the computer to go too because they want to install some specialty software on it while you?re there. You?re told to leave the monitors where they are. After all, HQ has an extra monitor to use when you get there. So, you shut down, unplug everything and take just the PC with you, load up and get on the road.

Problem:
When you arrive at HQ and get everything plugged in using just ONE monitor, you boot up and begin to go to work. However, you discover now that you can?t SEE the application that used to open up on the 2nd monitor (right) because you forgot to move it back to the left monitor before you shut down and hit the road. The application starts because you can see it in your taskbar and task manager. You just can?t see the application window. It?s being displayed on a non-existent monitor (i.e.: the computer thinks the monitor SHOULD still be there).

Teaser:
We know we can fix the problem by shutting down, plugging in a 2nd monitor temporarily while at HQ, move the application window to the left screen, shut down again and unplug the 2nd monitor. There is another way to resolve the situation without having to do all of this shutting down and borrowing another monitor.

What is the quick and easy solution?

]:) ]:) ]:) ]:)
  • +
    0 Votes
    Travler92

    Right click on the desktop, select graphics options / Output to - monitor

    +
    0 Votes
    ThumbsUp2

    However, none of the 3 computers that I just checked have "graphics options" on the right click. It must be a feature unique to your setup. Can you be more specific? Perhaps a solution that works for all dual monitor setups?

    +
    0 Votes
    simphiwe.mngadi

    Two monitors must be connected before you can use that feature.

    This should do the trick: on the display properties, under settings for monitor #1 tick "Use this device as the primary monitor" and OK.

    +
    0 Votes
    ThumbsUp2

    Left monitor is already set as default (primary) when two monitors are plugged in. When 2nd monitor is disconnected, the port on the card is still active and port that left monitor was plugged into is still default, but application still opens as if 2nd monitor was still connected.

    Read on.. you're close.

    +
    0 Votes
    mjd420nova

    From the task bar, right click and CLOSE.

    +
    0 Votes
    ThumbsUp2

    Closing the application isn't the problem. When they restart it, it's hidden again.

    Try again.

    +
    0 Votes
    Churdoo

    Make the app active / Alt-spacebar / R / Alt-spacebar / M / then Left or right arrow till you can see part of the app, depending on whether the other monitor was on the left or right / Enter. When the app is in partial view, you can grab the title bar with the mouse and move it where you want it.

    What do I win? ACME password hacking kit?

    +
    0 Votes
    The Scummy One

    but I didnt get the Alt-spacebar / R part.

    Does that make a Window active? I use alt-tab myself.

    +
    0 Votes
    Churdoo

    The R is to Restore to windowed mode cuz if the App is either minimized or maximized, the Move will not do anything. If the app is already in windowed mode, the R does nothing.

    +
    0 Votes
    ThumbsUp2

    Sorry, I didn't see the /R part when I posted that it didn't work.

    Yeah, that works once you get the window un-maximized. I'll come back in a while and give thumbs! :)

    But, there is another way. Do you know it?

    +
    0 Votes
    Churdoo

    Can't think of another way

    +
    0 Votes
    CG IT

    you temporarily change from using 2 monitors to 1 in the graphics card utility. you can also just boot up in safe mode which will not load up video drivers.

    +
    0 Votes
    ThumbsUp2

    Can you be more specific about the "temporarily change from using 2 monitors to 1 in the graphics card utility"?

    +
    0 Votes
    CG IT

    not all utilities are created the same. lol

    but I've done this with dual monitor and quad monitor systems where your trying to fix something and you only have 1 monitor.

    Profiles often work well... one for dual monitor and one for single monitor. much like hardware profiles for laptops.

    NVidia control panel has a a nifty little dual monitor setup program. It will show all displays available and allow you to choose a primary and secondary. and also to just use 1 monitor.

    +
    0 Votes
    ThumbsUp2

    Tis true... not all card utilities are created equal. I suppose I should have supplied one further detail to make it easier.

    Let's say the particular card being used in this scenario is a PNY GeForce FX5200 (Nvidia), PCI w/256MB DDR. Nice little cards for work environments.

    But, the quick and easy solution to the problem is actually built into Windows. The card doesn't matter.

    +
    0 Votes

    Ok

    The Scummy One

    r. click on the desktop, select properties, go to settings, and uncheck the extended desktop.

    no thumb needed here. Churdoo has the best answer...

    +
    0 Votes
    scott_heath

    The funny thing is, this happens to people with ONLY ONE MONITOR!! I can't tell you how many times over the years someone has mananged to move and application to the "netherworld" outside the viewable area. Then they freak out and think their app is screwed up. I've even seen other techs who thought the app wasn't open when it just needed to be moved back into the viewable area.

    Good question though! I love a thought provoker!

    +
    0 Votes
    Jacky Howe

    Right mouse click on desktop select properties, settings, left click on 2 and untick Extend my Windows desktop onto this monitor.

    +
    0 Votes
    ThumbsUp2

    You got it on the first try! Congratulations!

    So often we look for the "mechanical" solution with profiles or disabling the hardware functions or anything else we can think of.... that we actually overlook the obvious. That little sucker (check box) is hidden in plain sight, right under our nose and we forget that it's even there.

    If you disable the desktop on "other" monitors, it is restored to the single monitor and your applications will appear only there. Once you restore the 2nd monitor and extend your desktop to it... Windows remembers where you put the application window.

    <edited to add last paragraph>

    +
    0 Votes
    Jacky Howe

    The way I have my monitors setup I only have to turn off the second one and it auto adjusts for me. I should have had this setup years ago.

    +
    0 Votes
    ThumbsUp2

    Is the auto adjust on turning off the monitor an add-on or something for your card? I haven't seen this feature before. Does it work if the application was maximized in the 2nd monitor?

    +
    0 Votes
    Jacky Howe

    VGA-PCIE. Just run an adaptor for the PCIE to VGA. Works a charm.
    Edit
    The only catch is if I set up shortcuts on the second monitor and forget to turn it on they get transferred to the other desktop. What a mess. Lucky that I only use them while I am on a project.

    +
    0 Votes
    ThumbsUp2

    Not only does it move the icons you've placed on the 2nd monitor's desktop, it places them over the TOP of other icons on the 1st desktop. So you have to go searching for them, peaking under others and move them around anyway. Yeah, it's a mess. But, once you get used to what it's doing... it's not too tough to figure it out.

    +
    0 Votes
    Jacky Howe

    getting caught out with a couple of my games. If I forget to disable the second monitor the curser goes right off the screen. I gets a bit hard to move the troops around. And yes if I have an Application start on the second screen it swaps over when I disable the monitor.

    +
    0 Votes
    ThumbsUp2

    Since you got the quiz on the first try, you get to go next..... so, what is YOUR brain teaser?

    +
    0 Votes
    TonytheTiger

    right-clicking on the task bar button, select "move", and use your arrow key to move the hidden window to the current screen?

    (BTW, my setup is just like that except I use monitor 2 (the one on the right) as my main monitor.)

    +
    0 Votes
    rahouseholder

    I do it this same way. Had a dual monitor setup with a laptop in a docking station. On occasion it would think there was still a second monitor when I took the laptop home...

    +
    0 Votes
    ThumbsUp2

    With the main on the right, don't you have to move the mouse to the right edge of the right screen so it will appear on the left side of the left monitor? That get's really confusing!

    +
    0 Votes
    Nodisalsi

    Select <u>R</u>estore
    Right click again and select <u>M</u>ove
    You may now use cursor keys to slide the application into the left of the desktop.
    When done, maximise.

    +
    0 Votes
    OldER Mycroft

    It'll eventually begin to encroach into the existing single screen. Then you can drag the open window across, minimize, and return to normal resolution.

    +
    0 Votes
    ThumbsUp2

    (1) A maximized window will auto-size itself to whatever screen resolution you have. So, even decreasing to 640x480, the window stays nailed to the area designated as the right monitor.

    (2) A maximized window can't be dragged, although there are ways to get around this problem.

    +
    0 Votes
    retro77

    1.) Right click on the application in the toolbar and select move, then hit one of the arrow keys [on the keyboard] once and then use the mouse to move the application to monitor #1.

    2.) Go into display properties and disable the monitor #2, moving all application to monitor #1.

    +
    0 Votes
    alxcsby

    It would seem like if you changed your display properties you could make it default. Failing that, I'd do the Alt+Tab to change to controlling that window, then press ShiftAltSpacebar+M and use the arrows to move it around. Dunno if it'd work or not.
    ---
    Darn, Churnoo already nailed my ideas.

  • +
    0 Votes
    Travler92

    Right click on the desktop, select graphics options / Output to - monitor

    +
    0 Votes
    ThumbsUp2

    However, none of the 3 computers that I just checked have "graphics options" on the right click. It must be a feature unique to your setup. Can you be more specific? Perhaps a solution that works for all dual monitor setups?

    +
    0 Votes
    simphiwe.mngadi

    Two monitors must be connected before you can use that feature.

    This should do the trick: on the display properties, under settings for monitor #1 tick "Use this device as the primary monitor" and OK.

    +
    0 Votes
    ThumbsUp2

    Left monitor is already set as default (primary) when two monitors are plugged in. When 2nd monitor is disconnected, the port on the card is still active and port that left monitor was plugged into is still default, but application still opens as if 2nd monitor was still connected.

    Read on.. you're close.

    +
    0 Votes
    mjd420nova

    From the task bar, right click and CLOSE.

    +
    0 Votes
    ThumbsUp2

    Closing the application isn't the problem. When they restart it, it's hidden again.

    Try again.

    +
    0 Votes
    Churdoo

    Make the app active / Alt-spacebar / R / Alt-spacebar / M / then Left or right arrow till you can see part of the app, depending on whether the other monitor was on the left or right / Enter. When the app is in partial view, you can grab the title bar with the mouse and move it where you want it.

    What do I win? ACME password hacking kit?

    +
    0 Votes
    The Scummy One

    but I didnt get the Alt-spacebar / R part.

    Does that make a Window active? I use alt-tab myself.

    +
    0 Votes
    Churdoo

    The R is to Restore to windowed mode cuz if the App is either minimized or maximized, the Move will not do anything. If the app is already in windowed mode, the R does nothing.

    +
    0 Votes
    ThumbsUp2

    Sorry, I didn't see the /R part when I posted that it didn't work.

    Yeah, that works once you get the window un-maximized. I'll come back in a while and give thumbs! :)

    But, there is another way. Do you know it?

    +
    0 Votes
    Churdoo

    Can't think of another way

    +
    0 Votes
    CG IT

    you temporarily change from using 2 monitors to 1 in the graphics card utility. you can also just boot up in safe mode which will not load up video drivers.

    +
    0 Votes
    ThumbsUp2

    Can you be more specific about the "temporarily change from using 2 monitors to 1 in the graphics card utility"?

    +
    0 Votes
    CG IT

    not all utilities are created the same. lol

    but I've done this with dual monitor and quad monitor systems where your trying to fix something and you only have 1 monitor.

    Profiles often work well... one for dual monitor and one for single monitor. much like hardware profiles for laptops.

    NVidia control panel has a a nifty little dual monitor setup program. It will show all displays available and allow you to choose a primary and secondary. and also to just use 1 monitor.

    +
    0 Votes
    ThumbsUp2

    Tis true... not all card utilities are created equal. I suppose I should have supplied one further detail to make it easier.

    Let's say the particular card being used in this scenario is a PNY GeForce FX5200 (Nvidia), PCI w/256MB DDR. Nice little cards for work environments.

    But, the quick and easy solution to the problem is actually built into Windows. The card doesn't matter.

    +
    0 Votes

    Ok

    The Scummy One

    r. click on the desktop, select properties, go to settings, and uncheck the extended desktop.

    no thumb needed here. Churdoo has the best answer...

    +
    0 Votes
    scott_heath

    The funny thing is, this happens to people with ONLY ONE MONITOR!! I can't tell you how many times over the years someone has mananged to move and application to the "netherworld" outside the viewable area. Then they freak out and think their app is screwed up. I've even seen other techs who thought the app wasn't open when it just needed to be moved back into the viewable area.

    Good question though! I love a thought provoker!

    +
    0 Votes
    Jacky Howe

    Right mouse click on desktop select properties, settings, left click on 2 and untick Extend my Windows desktop onto this monitor.

    +
    0 Votes
    ThumbsUp2

    You got it on the first try! Congratulations!

    So often we look for the "mechanical" solution with profiles or disabling the hardware functions or anything else we can think of.... that we actually overlook the obvious. That little sucker (check box) is hidden in plain sight, right under our nose and we forget that it's even there.

    If you disable the desktop on "other" monitors, it is restored to the single monitor and your applications will appear only there. Once you restore the 2nd monitor and extend your desktop to it... Windows remembers where you put the application window.

    <edited to add last paragraph>

    +
    0 Votes
    Jacky Howe

    The way I have my monitors setup I only have to turn off the second one and it auto adjusts for me. I should have had this setup years ago.

    +
    0 Votes
    ThumbsUp2

    Is the auto adjust on turning off the monitor an add-on or something for your card? I haven't seen this feature before. Does it work if the application was maximized in the 2nd monitor?

    +
    0 Votes
    Jacky Howe

    VGA-PCIE. Just run an adaptor for the PCIE to VGA. Works a charm.
    Edit
    The only catch is if I set up shortcuts on the second monitor and forget to turn it on they get transferred to the other desktop. What a mess. Lucky that I only use them while I am on a project.

    +
    0 Votes
    ThumbsUp2

    Not only does it move the icons you've placed on the 2nd monitor's desktop, it places them over the TOP of other icons on the 1st desktop. So you have to go searching for them, peaking under others and move them around anyway. Yeah, it's a mess. But, once you get used to what it's doing... it's not too tough to figure it out.

    +
    0 Votes
    Jacky Howe

    getting caught out with a couple of my games. If I forget to disable the second monitor the curser goes right off the screen. I gets a bit hard to move the troops around. And yes if I have an Application start on the second screen it swaps over when I disable the monitor.

    +
    0 Votes
    ThumbsUp2

    Since you got the quiz on the first try, you get to go next..... so, what is YOUR brain teaser?

    +
    0 Votes
    TonytheTiger

    right-clicking on the task bar button, select "move", and use your arrow key to move the hidden window to the current screen?

    (BTW, my setup is just like that except I use monitor 2 (the one on the right) as my main monitor.)

    +
    0 Votes
    rahouseholder

    I do it this same way. Had a dual monitor setup with a laptop in a docking station. On occasion it would think there was still a second monitor when I took the laptop home...

    +
    0 Votes
    ThumbsUp2

    With the main on the right, don't you have to move the mouse to the right edge of the right screen so it will appear on the left side of the left monitor? That get's really confusing!

    +
    0 Votes
    Nodisalsi

    Select <u>R</u>estore
    Right click again and select <u>M</u>ove
    You may now use cursor keys to slide the application into the left of the desktop.
    When done, maximise.

    +
    0 Votes
    OldER Mycroft

    It'll eventually begin to encroach into the existing single screen. Then you can drag the open window across, minimize, and return to normal resolution.

    +
    0 Votes
    ThumbsUp2

    (1) A maximized window will auto-size itself to whatever screen resolution you have. So, even decreasing to 640x480, the window stays nailed to the area designated as the right monitor.

    (2) A maximized window can't be dragged, although there are ways to get around this problem.

    +
    0 Votes
    retro77

    1.) Right click on the application in the toolbar and select move, then hit one of the arrow keys [on the keyboard] once and then use the mouse to move the application to monitor #1.

    2.) Go into display properties and disable the monitor #2, moving all application to monitor #1.

    +
    0 Votes
    alxcsby

    It would seem like if you changed your display properties you could make it default. Failing that, I'd do the Alt+Tab to change to controlling that window, then press ShiftAltSpacebar+M and use the arrows to move it around. Dunno if it'd work or not.
    ---
    Darn, Churnoo already nailed my ideas.