Questions

Cannot connect to Windows 2K3 server using Remote Desktop

Tags:
+
0 Votes
Locked

Cannot connect to Windows 2K3 server using Remote Desktop

Diego
I am unable to connect to my Windows 2003 SBS Standard Server using Remote Desktop from a Windows XP client on the domain. I made sure RD is enabled on the server by going to the Remote tab of the System Properties Control panel and making sure allow remote desktop is checked off, I also went to the Terminal Service connections MMC Snap-in and made sure the connection was enabled in there too. Whenever i try to connect to the server from a client PC on the domain, i get this error " The client cannot connect to the remote computer, it may be busy or not accepting anymore connections". I can ping the Server with either it's IP address or Computer name. Also, any Client PC can connect via RD to any other Client PC, even the Server can connect to any Client PC. ANy suggestions on what may be preventing acces to the server via Remote Desktop? Thanks
  • +
    0 Votes

    Did

    Jacky Howe

    you configure routing and remote access?
    Admin tools Routing and Remote Access.

    +
    0 Votes

    No

    Diego

    I don't believe that is the case, we are not using this server for vpn or NAT, i don't see any other options in Routing and Remote Access that would pertain to terminal services, is there something more specific you were refering to?

    +
    0 Votes
    gechurch

    That's a good thought. SBS is really finnicky about the wizards, and sometimes things that seem unrelated don't work. I thought you were on the right track, but have just tested with an SBS 2003 box I have recently set up here. I haven't run the RRAS wizard yet, and I can RDP to it.

    +
    0 Votes
    Jacky Howe

    Remote Access, Remote Desktop what is the difference? You are still trying to achieve the same thing. This is a file server.

    I must admit that i didn't try to connect remotely to my FS before enabling Routing & Remote Access. My reading of setting up RAS enabled the internal and external connections to the FS.

    Go to the Remote tab of the System Properties Control panel Select Remote Users. Is there a list of users?

    Is the user account that you are using a member of Mobile Users, Remote Desktop Users?

    The other thing to look at is your Firewall.

    +
    0 Votes

    yes

    Diego

    There is a list of remote user and they are all administrators on the domain. There has to be something else wrong because I wouldn't be getting that error message when i attempt an RD connection. There is no software firewall on the server but we do have a symantec gateway security firewall/router. but combed through it and haven't seen anything that would cause a problem, it's even setup to foward port 3389 to the server so we can use an RD connection externally to access the server. And the fact that any client can RD any other client on the LAN as well as the server to any client leads me to believe that the problem lies in the server.

    +
    0 Votes
    ngruloos

    Hi Diego,
    this may be a license issue. To confirm this, please try using the console mode of your remote connection by running the command "mstsc /console".
    If you can get it, then I would suggest that you upgrade your licensing, you can get more info at http://support.microsoft.com/kb/823313.

    +
    0 Votes
    gechurch

    Good idea, but it doesn't apply to SBS. SBS lets you have two remote desktop connections out of the box (and that's a hard limit - you can't buy terminal services CALs for SBS).

    +
    0 Votes
    JMIRTC

    I may be wrong but......

    I am sure by default Win 2K3 will only accept 2 Remote connections

    Check the "Users" Tab in "Task Manager" to ensure that there are no allocated but Disconnected Users

    I had a Similar problem when an external user just disconnecting from the Server without Logging off first.

    J

    +
    0 Votes
    ngruloos

    Hello,
    yes, a maximum of 2 users/sessions can use Terminal Server/Remote Desktop. If you want to extend this value, you need CALS as mentioned in my previous reply.
    By using the console mode ("msdtc/console"), you won't have this restriction but you can only have 1 console session at a time.
    Best regards,
    Nico.

    +
    0 Votes
    Diego

    That much i DO know, I explained in my original post that i had enabled RD there already.

    +
    0 Votes
    michael

    I spent 2 hours trying to get it to work on a server I was sure I had enabled it on only to find I had missed it out!

    My other thought is to make sure your account is in the remote users group or you have got windows firewall enabled and haven't set the terminal services exception or your calling PCs firewall is snuffing out the return packets.

    Try turning logging on in the firewall or use MS Network monitor to look to see if the packets are actually reaching the system.

    +
    0 Votes
    TechPro34yrs.

    Go to the control panel and open the firewall icon. Under exceptions make sure the File and printer sharing are checked and also make sure remote access is checked too.
    This should open you up to remote access.

    +
    0 Votes
    ngruloos

    It cannot be a firewall issue because some users can access (I guess two).

    +
    0 Votes
    Jacky Howe

    didn't realise it had been closed.

    +
    0 Votes
    severanj

    If you are running ISA Server there is a policy that could be denying access to just the ISA server...

    +
    0 Votes
    enda_walsh

    I made some changes to the network card (adapter teaming) these had to be confirmed in the terminal services configurator in administrative tools of the machine your trying to connect to. Otherwise you wont be able to make any terminal connections to this machine.

    +
    1 Votes
    phil

    This may not help you directly since you say that other machines can still gain access to the server but it may help others who are reading this thread.

    We have a server which had been accepting RD connections happily until it was restarted via a RD connection. The server refused to allow any RD connections until it was restarted at its own console.

    +
    0 Votes
    dan.elder

    This is the first time I'd ever seen this, but this is exactly what just happened to one of my servers. I don't know if this makes a difference, but this one wasn't on a domain. I ran some system updates via rdc, rebooted, then couldn't reconnect via rdc. Rebooted from the console per your suggestion and now able to connect via RDC without a problem

    +
    0 Votes
    rainbow_networks

    We had the same problem on 2 servers and your advice solved it.

    Thanks.

    +
    0 Votes
    shravankoolin

    go to

    start-Programs-Administaror tools-service-IPsec(stop service,make ths service as manulal bcoz default itis automatic and start the service and reboot the server.)

  • +
    0 Votes

    Did

    Jacky Howe

    you configure routing and remote access?
    Admin tools Routing and Remote Access.

    +
    0 Votes

    No

    Diego

    I don't believe that is the case, we are not using this server for vpn or NAT, i don't see any other options in Routing and Remote Access that would pertain to terminal services, is there something more specific you were refering to?

    +
    0 Votes
    gechurch

    That's a good thought. SBS is really finnicky about the wizards, and sometimes things that seem unrelated don't work. I thought you were on the right track, but have just tested with an SBS 2003 box I have recently set up here. I haven't run the RRAS wizard yet, and I can RDP to it.

    +
    0 Votes
    Jacky Howe

    Remote Access, Remote Desktop what is the difference? You are still trying to achieve the same thing. This is a file server.

    I must admit that i didn't try to connect remotely to my FS before enabling Routing & Remote Access. My reading of setting up RAS enabled the internal and external connections to the FS.

    Go to the Remote tab of the System Properties Control panel Select Remote Users. Is there a list of users?

    Is the user account that you are using a member of Mobile Users, Remote Desktop Users?

    The other thing to look at is your Firewall.

    +
    0 Votes

    yes

    Diego

    There is a list of remote user and they are all administrators on the domain. There has to be something else wrong because I wouldn't be getting that error message when i attempt an RD connection. There is no software firewall on the server but we do have a symantec gateway security firewall/router. but combed through it and haven't seen anything that would cause a problem, it's even setup to foward port 3389 to the server so we can use an RD connection externally to access the server. And the fact that any client can RD any other client on the LAN as well as the server to any client leads me to believe that the problem lies in the server.

    +
    0 Votes
    ngruloos

    Hi Diego,
    this may be a license issue. To confirm this, please try using the console mode of your remote connection by running the command "mstsc /console".
    If you can get it, then I would suggest that you upgrade your licensing, you can get more info at http://support.microsoft.com/kb/823313.

    +
    0 Votes
    gechurch

    Good idea, but it doesn't apply to SBS. SBS lets you have two remote desktop connections out of the box (and that's a hard limit - you can't buy terminal services CALs for SBS).

    +
    0 Votes
    JMIRTC

    I may be wrong but......

    I am sure by default Win 2K3 will only accept 2 Remote connections

    Check the "Users" Tab in "Task Manager" to ensure that there are no allocated but Disconnected Users

    I had a Similar problem when an external user just disconnecting from the Server without Logging off first.

    J

    +
    0 Votes
    ngruloos

    Hello,
    yes, a maximum of 2 users/sessions can use Terminal Server/Remote Desktop. If you want to extend this value, you need CALS as mentioned in my previous reply.
    By using the console mode ("msdtc/console"), you won't have this restriction but you can only have 1 console session at a time.
    Best regards,
    Nico.

    +
    0 Votes
    Diego

    That much i DO know, I explained in my original post that i had enabled RD there already.

    +
    0 Votes
    michael

    I spent 2 hours trying to get it to work on a server I was sure I had enabled it on only to find I had missed it out!

    My other thought is to make sure your account is in the remote users group or you have got windows firewall enabled and haven't set the terminal services exception or your calling PCs firewall is snuffing out the return packets.

    Try turning logging on in the firewall or use MS Network monitor to look to see if the packets are actually reaching the system.

    +
    0 Votes
    TechPro34yrs.

    Go to the control panel and open the firewall icon. Under exceptions make sure the File and printer sharing are checked and also make sure remote access is checked too.
    This should open you up to remote access.

    +
    0 Votes
    ngruloos

    It cannot be a firewall issue because some users can access (I guess two).

    +
    0 Votes
    Jacky Howe

    didn't realise it had been closed.

    +
    0 Votes
    severanj

    If you are running ISA Server there is a policy that could be denying access to just the ISA server...

    +
    0 Votes
    enda_walsh

    I made some changes to the network card (adapter teaming) these had to be confirmed in the terminal services configurator in administrative tools of the machine your trying to connect to. Otherwise you wont be able to make any terminal connections to this machine.

    +
    1 Votes
    phil

    This may not help you directly since you say that other machines can still gain access to the server but it may help others who are reading this thread.

    We have a server which had been accepting RD connections happily until it was restarted via a RD connection. The server refused to allow any RD connections until it was restarted at its own console.

    +
    0 Votes
    dan.elder

    This is the first time I'd ever seen this, but this is exactly what just happened to one of my servers. I don't know if this makes a difference, but this one wasn't on a domain. I ran some system updates via rdc, rebooted, then couldn't reconnect via rdc. Rebooted from the console per your suggestion and now able to connect via RDC without a problem

    +
    0 Votes
    rainbow_networks

    We had the same problem on 2 servers and your advice solved it.

    Thanks.

    +
    0 Votes
    shravankoolin

    go to

    start-Programs-Administaror tools-service-IPsec(stop service,make ths service as manulal bcoz default itis automatic and start the service and reboot the server.)