Questions

Can't boot off of cloned hard drive

+
0 Votes
Locked

Can't boot off of cloned hard drive

rorbot
OS xp pro sp3, all drives are SATA

I cloned my dying C drive to a new one I just bought using norton ghost v14. However, removing the old drive and trying to boot off of the newly cloned drive won't let me get past the blue log in screen. My computer just sits there with no error message just an annoying windows xp logo. For some reason when i reconnected my old HD and had both connected at the same time i was able to get to the desktop.

I've been reading around and some people are suggesting that this is a windows security measure that doesn't allow you to run windows off a drive with a different serial #.

Just wanted to confirm if this was the case and if anyone had any suggestions?

any help would be great thanks.
  • +
    0 Votes
    Jacky Howe

    it's probably a glitch try this.
    <br><br>
    Boot the system using the Windows XP CD-ROM. In the first screen when the Setup begins, read the instructions press "R" (in the first screen) enter the Recovery Console.
    <br><br>
    1: C:\WINDOWS
    <br><br>
    Which Windows Installation would you like to log on to
    (To cancel, press ENTER)?
    After you enter the number for the appropriate Windows installation, Windows will then prompt you to enter the Administrator account password.
    <br><br>
    Note If you use an incorrect password three times, the Windows Recovery Console closes. Also, if the Security Accounts Manager (SAM) database is missing or damaged, you cannot use the Windows Recovery Console because you cannot have correct authentication. After you enter your password and the Windows Recovery Console starts, type exit to restart the computer.
    <br><br>
    Type the following command and press Enter.
    <br><br>
    CD SYSTEM32
    (If that does not work, try CHDIR SYSTEM32)
    At the prompt type in
    <b>COPY USERINIT.EXE WSAUPDATER.EXE</b>
    <br><br>
    Quit Recovery Console by typing EXIT and restart Windows.
    <br><br>
    You'll be able to login successfully as you've created the wsaupdater.exe file (now, a copy of userinit.exe)
    <br><br>
    <b>"WARNING MODIFYING REGISTRY INFORMATION IS DANGEROUS"</b>
    Backup the Key before making changes.
    <br><br>
    Now, change the USERINIT value in the registry
    Click Start, Run and type <b>Regedt32</b> and press Enter.
    <br><br>
    Navigate to:
    <br><br>
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon
    <br><br>
    In the right pane you will see that the value of the Userinit key is incorrectly set to <b>"wsaupdater.exe,"</b>
    <br><br>

    In the right-pane, change the value of Userinit to C:\WINDOWS\system32\<b>userinit.exe,</b>
    <br><br>
    Type the above value exactly as given, including the comma. Also, change the path to userinit.exe appropriately if Windows is installed in a different drive.
    <br><br>
    Close Registry Editor and restart Windows.
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.
    </i>

    +
    0 Votes
    rorbot

    first, thanks for your quick reply.

    I went into windows repair and I noticed a weird pattern. rebooting with just the cloned drive i get 1: C:\WINDOWS only at the recovery console. But when i reboot and go into the recovery console with both drives connected (cloned + old) I get both 1: C:\WINDOWS and 2: F:\WINDOWS.

    The odd thing is "My Computer" shows my old drive mapped to C: and the new one mapped to I:. It seems to be all mixed up. I don't have a F:/WINDOWS directory my F drive is just one of my storage drives.

    (is it possible for my computer to set the old drive as C and the new one as I, but when in the booting area windows thinks the new one is C and the old one is F?
    madness...)

    so that confused me as to which one to pick. I tried doing it on the F:/WINDOWS directory but it didn't seem to change anything.


    the registry edit seemed promising I saw that userinit was still on C:\WINDOWS\system32\userinit.exe, so I changed it to I:\WINDOWS\system32\userinit.exe, but that didn't change anything either I still needed the old drive for the log-in screen to show me my profile so I could sign in.

    I can log in and edit my cloned drive's properties (as long as I have the old drive connected too) so im not sure the windows repair part is necessary, however the registry might be the solution. changing the path to userinit.exe really made sense just don't know why it didn't work.

    it's as if the log in part of the boot sequence is looking for the files on the old drive because of path in the registry is still set to the old drive's mapping since its a clone copy. I think I need to edit some stuff so it looks for the stuff on the new drive instead of the old one.

    +
    0 Votes
    Jacky Howe

    Insert your XP CD and when you see ?Press any key to boot from CD? press a key. Now wait for the XP installer to finish loading up and you will be presented with the option to press R to Repair.
    <br><br>
    Press R.
    The next screen will ask you which Windows? installation you would like to log on to. Normally the following will be listed:
    <br><br>
    1: C:\WINDOWS
    <br><br>
    Press 1, then Enter to continue.
    <br><br>
    You may now be asked for the Administrator password. If you know this type it and press Enter. If you don't know the Administrators password it may be blank. Just press Enter or type your username and password.
    <br><br>
    At the command prompt type:
    <br><br>
    fixmbr and press Enter
    <br><br>
    fixboot and press Enter
    <br><br>
    bootcfg /rebuild and press Enter
    <br><br>
    Wait until you are returned to the Recovery Console.
    <br>
    Once you are back to the Recovery Console remove the XP CD and restart your PC.
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.
    </i>

    +
    0 Votes
    rorbot

    thanks for all your help.

    after i did the bootcfg /rebuild

    i got prompted with

    enter load identifier:
    enter OS load options:

    I think this created another boot option everytime i boot my computer i have 2 options to pick from both didn't work unless i had the old drive in.

    I think im just going to go ahead and reformat it

    thanks for all your help

    +
    0 Votes
    robo_dev

    Many times I've had problems booting ghosted drives.

    The most typical cause of the problem are when the PC vendor (Dell, Compaq) has a hidden Diagnostics or Recovery partition on the hard drive. If you ghost the Windows partition to a blank drive, but not those other partitions, then the new drive is NOT the same, with respect to where to look for the boot sector. Typically a Compaq laptop will just sit there with a flashing __ at the upper left.

    Some Dell PCs, for example, have three hidden partitions, so it aint easy!!

    The solution depends on the manufacturer, for Dell, it's kinda complicated.... www.goodells.net/dellrestore/fixes.htm

    As I recall for Compaq, you would have to do their disk-prep utils to setup the correct diag partitions, the ghost to it.

    +
    0 Votes
    rorbot

    and i'm using Western Digital drives. Each drive just has one big partition. my the WD will have some info i'll check

    +
    0 Votes
    robo_dev

    On one PC, it would not boot because the cloned drive was a larger capacity, and the bios version had 'issues' with drives over 140GB. A bios update fixed that one....

    Typically there there bios settings to toy with regarding SATA... (LArge versus AUTO, SATA1 versus SATA2)

    Are you ghosting from SATA to SATA...(PATA to SATA tends to have problems).

    Sorry if you posted this info already....did ANYTHING else change? (SATA controller, MOBO, etc).

    +
    0 Votes
    The Scummy One

    the logon screen.
    This does not sound like a boot issue, but a Repair issue for Windows.

    However, if you want to re-try the clone, I have had less problems with Linux and the dd command than with Ghost.
    With dd, it clones the entire drive bit by bit, to make an exact copy. You can set by partition, or do the entire drive.
    Afterwards, use a partition extender to get the newly available disk space.

    +
    0 Votes
    Dumphrey

    on the DD command. Ghost went down hill fast after version 2003...

    So can you get to the recover console at all from the new hard disk? FIXMBR and fixboot and chkdsk are 3 command to try if you can get in. You may want to erase the disk and try a new clone (last resort), you may have some corruption in the data. Also would not hurt to run chkdsk on the cloned drive to verify partition information. Also, verify that the bootable flag is enabled on the cloned disk. It SHOULD have enabled that on the clone, but ya never know. Can you specify what drivers to use for the sata disks in Ghost 14?
    Clonezilla is a GPL ghost-like product that can do bit copy of a disk. This means its slower then partition copy tools like ghost, but more reliable. http://clonezilla.org/
    Try using a different tool to create the clone and compare.

    +
    0 Votes
    rorbot

    i tried fixmbr fixboot chkdsk all that stuff and bootcfg /rebuild but it still required the old drive for me to get passed the log on screen and use my new drive as the new system drive (how weird is that?)

    (btw anyone know how to delete the new bootcfg i created now its always asking me to pick one everytime i boot up)

    I'm going to try your suggestions and use a different program cause a lot of people have had problems with norton ghost.

    thanks all

    +
    0 Votes
    Jacky Howe

    Page 174 of the user manual
    <br><br>
    Copy MBR<br>
    This option copies the master boot record from the source drive to the destination drive. Select this option if you are copying the C:\ drive to a new, empty hard drive. You should not select this option if you want to copy a drive to another space on the same hard drive as a backup. You should also ot select this option if you want to copy the drive to a hard drive that has existing partitions that you do not want to replace.
    <br><br>
    Destination partition type<br>

    Click Primary partition to make the destination (new) drive a primary partition. Click Logical partition to make the destination (new) drive a logical partition inside an extended partition.
    <br><br>
    Drive letter<br>
    Select the drive letter you want assigned to the partition from the Drive letter drop-down list

    <br><br>
    ftp://ftp.symantec.com/public/english_us_canada/products/ghost/14/manuals/ngh_14_user_guide.pdf
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.
    </i>

    +
    0 Votes
    rorbot

    thanks for your help guys. All your answers made sense but I really think there is something quirky going on with my system. I've tried everything you guys suggested but nothing worked. I've already formatted the time spent reinstalling stuff is much less than the time it would take me to figure this out. Your comments were helpful and i'm sure anyone with a similar problem will find a fix here.

    thanks again. cool site

    +
    0 Votes
    Jacky Howe

    in your first post you had concerns about the health of the old drive. It would probably be better to clone it to an Image and then restore that Image to the new drive. But that would mean that you would need another drive to hold the image. Catch 22.

    +
    0 Votes
    DAKSPORT99

    Does the drive have master / slave settings, set to Master

  • +
    0 Votes
    Jacky Howe

    it's probably a glitch try this.
    <br><br>
    Boot the system using the Windows XP CD-ROM. In the first screen when the Setup begins, read the instructions press "R" (in the first screen) enter the Recovery Console.
    <br><br>
    1: C:\WINDOWS
    <br><br>
    Which Windows Installation would you like to log on to
    (To cancel, press ENTER)?
    After you enter the number for the appropriate Windows installation, Windows will then prompt you to enter the Administrator account password.
    <br><br>
    Note If you use an incorrect password three times, the Windows Recovery Console closes. Also, if the Security Accounts Manager (SAM) database is missing or damaged, you cannot use the Windows Recovery Console because you cannot have correct authentication. After you enter your password and the Windows Recovery Console starts, type exit to restart the computer.
    <br><br>
    Type the following command and press Enter.
    <br><br>
    CD SYSTEM32
    (If that does not work, try CHDIR SYSTEM32)
    At the prompt type in
    <b>COPY USERINIT.EXE WSAUPDATER.EXE</b>
    <br><br>
    Quit Recovery Console by typing EXIT and restart Windows.
    <br><br>
    You'll be able to login successfully as you've created the wsaupdater.exe file (now, a copy of userinit.exe)
    <br><br>
    <b>"WARNING MODIFYING REGISTRY INFORMATION IS DANGEROUS"</b>
    Backup the Key before making changes.
    <br><br>
    Now, change the USERINIT value in the registry
    Click Start, Run and type <b>Regedt32</b> and press Enter.
    <br><br>
    Navigate to:
    <br><br>
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon
    <br><br>
    In the right pane you will see that the value of the Userinit key is incorrectly set to <b>"wsaupdater.exe,"</b>
    <br><br>

    In the right-pane, change the value of Userinit to C:\WINDOWS\system32\<b>userinit.exe,</b>
    <br><br>
    Type the above value exactly as given, including the comma. Also, change the path to userinit.exe appropriately if Windows is installed in a different drive.
    <br><br>
    Close Registry Editor and restart Windows.
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.
    </i>

    +
    0 Votes
    rorbot

    first, thanks for your quick reply.

    I went into windows repair and I noticed a weird pattern. rebooting with just the cloned drive i get 1: C:\WINDOWS only at the recovery console. But when i reboot and go into the recovery console with both drives connected (cloned + old) I get both 1: C:\WINDOWS and 2: F:\WINDOWS.

    The odd thing is "My Computer" shows my old drive mapped to C: and the new one mapped to I:. It seems to be all mixed up. I don't have a F:/WINDOWS directory my F drive is just one of my storage drives.

    (is it possible for my computer to set the old drive as C and the new one as I, but when in the booting area windows thinks the new one is C and the old one is F?
    madness...)

    so that confused me as to which one to pick. I tried doing it on the F:/WINDOWS directory but it didn't seem to change anything.


    the registry edit seemed promising I saw that userinit was still on C:\WINDOWS\system32\userinit.exe, so I changed it to I:\WINDOWS\system32\userinit.exe, but that didn't change anything either I still needed the old drive for the log-in screen to show me my profile so I could sign in.

    I can log in and edit my cloned drive's properties (as long as I have the old drive connected too) so im not sure the windows repair part is necessary, however the registry might be the solution. changing the path to userinit.exe really made sense just don't know why it didn't work.

    it's as if the log in part of the boot sequence is looking for the files on the old drive because of path in the registry is still set to the old drive's mapping since its a clone copy. I think I need to edit some stuff so it looks for the stuff on the new drive instead of the old one.

    +
    0 Votes
    Jacky Howe

    Insert your XP CD and when you see ?Press any key to boot from CD? press a key. Now wait for the XP installer to finish loading up and you will be presented with the option to press R to Repair.
    <br><br>
    Press R.
    The next screen will ask you which Windows? installation you would like to log on to. Normally the following will be listed:
    <br><br>
    1: C:\WINDOWS
    <br><br>
    Press 1, then Enter to continue.
    <br><br>
    You may now be asked for the Administrator password. If you know this type it and press Enter. If you don't know the Administrators password it may be blank. Just press Enter or type your username and password.
    <br><br>
    At the command prompt type:
    <br><br>
    fixmbr and press Enter
    <br><br>
    fixboot and press Enter
    <br><br>
    bootcfg /rebuild and press Enter
    <br><br>
    Wait until you are returned to the Recovery Console.
    <br>
    Once you are back to the Recovery Console remove the XP CD and restart your PC.
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.
    </i>

    +
    0 Votes
    rorbot

    thanks for all your help.

    after i did the bootcfg /rebuild

    i got prompted with

    enter load identifier:
    enter OS load options:

    I think this created another boot option everytime i boot my computer i have 2 options to pick from both didn't work unless i had the old drive in.

    I think im just going to go ahead and reformat it

    thanks for all your help

    +
    0 Votes
    robo_dev

    Many times I've had problems booting ghosted drives.

    The most typical cause of the problem are when the PC vendor (Dell, Compaq) has a hidden Diagnostics or Recovery partition on the hard drive. If you ghost the Windows partition to a blank drive, but not those other partitions, then the new drive is NOT the same, with respect to where to look for the boot sector. Typically a Compaq laptop will just sit there with a flashing __ at the upper left.

    Some Dell PCs, for example, have three hidden partitions, so it aint easy!!

    The solution depends on the manufacturer, for Dell, it's kinda complicated.... www.goodells.net/dellrestore/fixes.htm

    As I recall for Compaq, you would have to do their disk-prep utils to setup the correct diag partitions, the ghost to it.

    +
    0 Votes
    rorbot

    and i'm using Western Digital drives. Each drive just has one big partition. my the WD will have some info i'll check

    +
    0 Votes
    robo_dev

    On one PC, it would not boot because the cloned drive was a larger capacity, and the bios version had 'issues' with drives over 140GB. A bios update fixed that one....

    Typically there there bios settings to toy with regarding SATA... (LArge versus AUTO, SATA1 versus SATA2)

    Are you ghosting from SATA to SATA...(PATA to SATA tends to have problems).

    Sorry if you posted this info already....did ANYTHING else change? (SATA controller, MOBO, etc).

    +
    0 Votes
    The Scummy One

    the logon screen.
    This does not sound like a boot issue, but a Repair issue for Windows.

    However, if you want to re-try the clone, I have had less problems with Linux and the dd command than with Ghost.
    With dd, it clones the entire drive bit by bit, to make an exact copy. You can set by partition, or do the entire drive.
    Afterwards, use a partition extender to get the newly available disk space.

    +
    0 Votes
    Dumphrey

    on the DD command. Ghost went down hill fast after version 2003...

    So can you get to the recover console at all from the new hard disk? FIXMBR and fixboot and chkdsk are 3 command to try if you can get in. You may want to erase the disk and try a new clone (last resort), you may have some corruption in the data. Also would not hurt to run chkdsk on the cloned drive to verify partition information. Also, verify that the bootable flag is enabled on the cloned disk. It SHOULD have enabled that on the clone, but ya never know. Can you specify what drivers to use for the sata disks in Ghost 14?
    Clonezilla is a GPL ghost-like product that can do bit copy of a disk. This means its slower then partition copy tools like ghost, but more reliable. http://clonezilla.org/
    Try using a different tool to create the clone and compare.

    +
    0 Votes
    rorbot

    i tried fixmbr fixboot chkdsk all that stuff and bootcfg /rebuild but it still required the old drive for me to get passed the log on screen and use my new drive as the new system drive (how weird is that?)

    (btw anyone know how to delete the new bootcfg i created now its always asking me to pick one everytime i boot up)

    I'm going to try your suggestions and use a different program cause a lot of people have had problems with norton ghost.

    thanks all

    +
    0 Votes
    Jacky Howe

    Page 174 of the user manual
    <br><br>
    Copy MBR<br>
    This option copies the master boot record from the source drive to the destination drive. Select this option if you are copying the C:\ drive to a new, empty hard drive. You should not select this option if you want to copy a drive to another space on the same hard drive as a backup. You should also ot select this option if you want to copy the drive to a hard drive that has existing partitions that you do not want to replace.
    <br><br>
    Destination partition type<br>

    Click Primary partition to make the destination (new) drive a primary partition. Click Logical partition to make the destination (new) drive a logical partition inside an extended partition.
    <br><br>
    Drive letter<br>
    Select the drive letter you want assigned to the partition from the Drive letter drop-down list

    <br><br>
    ftp://ftp.symantec.com/public/english_us_canada/products/ghost/14/manuals/ngh_14_user_guide.pdf
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.
    </i>

    +
    0 Votes
    rorbot

    thanks for your help guys. All your answers made sense but I really think there is something quirky going on with my system. I've tried everything you guys suggested but nothing worked. I've already formatted the time spent reinstalling stuff is much less than the time it would take me to figure this out. Your comments were helpful and i'm sure anyone with a similar problem will find a fix here.

    thanks again. cool site

    +
    0 Votes
    Jacky Howe

    in your first post you had concerns about the health of the old drive. It would probably be better to clone it to an Image and then restore that Image to the new drive. But that would mean that you would need another drive to hold the image. Catch 22.

    +
    0 Votes
    DAKSPORT99

    Does the drive have master / slave settings, set to Master