Questions

CAN'T CURE XP RESTART PROBLEM

+
0 Votes
Locked

CAN'T CURE XP RESTART PROBLEM

mickambrose
I have been trying to cure the well-documented XP restart problem for many months, with no success.
The only original hardware left unchanged is the motherboard and the two hard drives.
I have re-formatted both drives and installed XP Home (English) on drive 'C' and XP Home (French) on drive 'D'. Before I installed any programmes I checked the shutdown,and I still had the same problem. Everything operates as it should, the PC powers down, turns off, then immediately powers back up again.
Even if I use the power off button the same thing occurs. The only time I can successfully switch off is if I have a BSOD, when the power off button works correctly, so the problem must be Windows associated, but what?
I have run out of ideas....
  • +
    0 Votes
    kaptandrews

    the BIOS power management.

    +
    0 Votes
    mickambrose

    I have already tried every combination possible, to no avail, but thanks for the suggestion.
    Mick

    +
    0 Votes
    CaptBilly1Eye

    Try disconnecting all USB devices other than the mouse and keyboard. Connect those two devices to primary USB ports. Also disconnect LAN connections (network, external modem). See if that resolves the situation.

    If not, boot to Safe Mode (not Safe Mode with Networking), delete the contents of the C:\Documents and Settings\[Your User Profile]\Local Settings\Temp folder. Then try to shut down. If that resolves the issue then it is most likely related to a driver or service loading during normal boot that is not fully closing at shutdown.

    One user I know gave up trying to pinpoint the issue for a while and instead he added Safe Mode as an option to the boot menu. Then he would Restart, select Safe Mode in the list by hitting the down arrow once and the Enter key and lastly he would perform a shut-down after it booted to Safe Mode.
    Just in case you need a temporary work-around like that, here are the steps: http://tinyurl.com/gomxy .

    It may be that an error is occurring during Shutdown and that is sending the system into a Restart cycle.

    If you haven't changed any of the system failure settings, you should be able to see the error by looking in the Event Log. But a better long-term solution is to turn off the automatic reboot so you can actually see the error when it happens?chances are it will tell you enough about itself to let you troubleshoot further. To change the recovery settings to disable automatic rebooting:

    Right-click My Computer, and then click Properties. Click the Advanced tab. Under Startup and Recovery, click Settings to open the Startup and Recovery dialog box. Clear the Automatically restart check box, and click OK the necessary number of times. Restart your computer for the settings to take effect.

    Now when you go to shut down and a fatal error occurs, you'll at least see it and it won't cause an automatic reboot. You still have to sort out what's causing the problem


    There is also a Registry key and value you can check.
    ***Warning: Performing manual changes to the Windows Registry incorrectly can make Windows inoperable. It is always advised to perform a Registry backup and setting an XP Restore point prior to making changes to the Registry.***
    That being said, go to Start - Run - regedit.
    With the Registry open, find this key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon].

    Create a new string value, or modify the existing value, called PowerdownAfterShutdown
    and set it to "1" to power off the computer at shutdown, or "0" to reboot. Restart
    Windows for the change to take effect.


    Please let me know if this helps.

    +
    0 Votes
    mickambrose

    CaptBilly1eye........
    When I formatted both drives and installed XP English and XP French, I removed all cards possible, and installed no programmes, but the problem was still there.
    Automatic restart is clear, PAS is set to 1.
    Sorry!
    Mick

    +
    0 Votes
    Michael O'Brien

    Hi Mick,

    Sounds like a hardware problem to me, are you able to check how hot your CPU is running ?

    Second thing you could do is Remove all RAM chips and put one in and startup and see if the problem occurs (do the same for the rest of the ram chips).

    Is this a OEM Pc or a custom built pc ?

    +
    0 Votes
    mickambrose

    CPU runs around 60?.
    Changed all RAM last week as part of an upgrade.
    The PC started life as an OEM, but is now nearer to being a custom built (by me)!

    Mick

    +
    0 Votes
    CaptBilly1Eye

    On a system with an Intel board that had the same situation, 'down-grading' the BIOS to a previous version corrected the issue.
    It was found in that situation that the most current BIOS update caused the auto-restart.
    Check with the MoBo's manufacturer web site for instructions and previous BIOS releases.

    In still another situation, with a different MoBo, updating to the most recent BIOS update solved it.

    Make sure that in the BIOS it is set to not Wake on LAN and also to remain off after a power outage.

    Perhaps if you answer the questions I posed in my previous post, I or someone else may be able to be of further help. That is, does the situation occur when you boot to Safe Mode (not Safe Mode with Networking), Is the registry line present and correct, is there anything in the Event log?

    Other info that would be helpful is what make and model of board? Is onboard LAN enabled? Does the same situation occur with only one drive connected? Are the drives SATA or IDE? Both NTFS? RAID? UPS?

    Unfortunately there is no set fix. The resolution will be different depending on each system's configuration and it is often extremely difficult to pinpoint the exact cause. Have you checked with technical support for that MoBo?
    That would be the most logical source based on all the things you've tried.


    Good Luck.


    [It is greatly appreciated if you tag all useful responses as 'Helpful' by opening those posts and clicking the 'Mark Helpful' button at the bottom. That way, people with a similar situation in the future will be able to quickly see what ultimately helped. Thanks.]

    +
    0 Votes
    mickambrose

    Motherboard - Microstar MS7093 Ver 1.0
    BIOS - Phoenix Technologies, version 6.00 PG
    Power supply - Tagan TG420-U01 (420W)
    2x200GB SATA drives, both NTFS, One loaded with WinXP Home (English), the second with WinXP Home (Frnech).

    This situation started some months ago whilst on the existing BIOS. A Bios upgrade made no difference.
    Deleting Temp folder in safe mode then turning off makes no difference.
    Automatic restart is off, but there is never anything in the Event Log.
    PowerDown value is set to 1.
    Wake on LAN is off.

    Mick

    +
    0 Votes
    mickambrose

    I don't know what technically comes under the heading of "Restart" in Windows, but I have a few further observations that may or may not shed a little more light on the problem....

    If you request Windows to do a restart, the power is never turned off in the process.

    Normally, when you request Windows to Switch Off, it runs through its' processes and then does exactly that, removing power from the system.

    When I request a Switch Off, the computer definitely switches off (with an audible thump from my Altec sound system), and the display lights on the front go out, BUT, a split second later, the PC turns back on...

    One other observation. Although I have the power button set to "Instant Off", it doesn't. It still waits the 4 or 5 seconds before switching off, but then I still get the (Restart?).

    Mick

    +
    0 Votes
    wchaster

    Well I would tend to think this is a BIOS issue too, but since you indicate that you have updated the BIOS then that may not be it, unless you used the wrong BIOS.

    After reading all the post to your problem one thing came to mind. You have indicated that this started as an OEM PC and now you have replaced most of the parts. In troubleshooting this problem it also sound like to have spent numorous hours and have had the assistance of many. What do you think the cost of all this troubleshooting has cost you?
    Maybe the cure to your problem is to replace the MoBo.

    +
    0 Votes
    mickambrose

    The BIOS is correct for the MB. The cost doesn't really come into the equation as such because everything has been an upgrade for my own purposes.
    If I thought changing the MB was the answer to the problem I would do it, but I need convincing by "one who knows" before I go through the hassle involved.

    Mick

    +
    0 Votes
    sgt_shultz

    i am coming late to this party, did you already post the bsod error? and peek in the event logs for more clues? does it do this in safe mode?

    +
    0 Votes
    mickambrose

    This was an unrelated problem caused by supposedly matched pair of Ram modules that weren't!
    I just happened to notice that after a BSOD the power-off button worked correctly.

    Mick

    +
    0 Votes
    mickambrose

    ........forgot to add that the problem is the same if I try to shutdown from Safe Mode.

    Mick

    +
    0 Votes
    rosamundwo

    Locate CDRALW2K.SYS
    Rename it to another name

    I have the same problem and i solved mine.


    CDRALW2K.SYS. Correspondent Larry Blumette identified the CDRALW2K.SYS file (version 1.0.0.1048) as the Roxio file causing his shutdown problems and error conditions. When he deleted or renamed this one file, his problems went away. (Of course, you lose your CD functionality that way, too.)

    Source: http://www.aumha.org/win5/a/shtdwnxp.php

    +
    0 Votes
    scoreychris

    try start control panel, power options,and change your settings to (home/office)this worked fine for me in xp scoreychris

  • +
    0 Votes
    kaptandrews

    the BIOS power management.

    +
    0 Votes
    mickambrose

    I have already tried every combination possible, to no avail, but thanks for the suggestion.
    Mick

    +
    0 Votes
    CaptBilly1Eye

    Try disconnecting all USB devices other than the mouse and keyboard. Connect those two devices to primary USB ports. Also disconnect LAN connections (network, external modem). See if that resolves the situation.

    If not, boot to Safe Mode (not Safe Mode with Networking), delete the contents of the C:\Documents and Settings\[Your User Profile]\Local Settings\Temp folder. Then try to shut down. If that resolves the issue then it is most likely related to a driver or service loading during normal boot that is not fully closing at shutdown.

    One user I know gave up trying to pinpoint the issue for a while and instead he added Safe Mode as an option to the boot menu. Then he would Restart, select Safe Mode in the list by hitting the down arrow once and the Enter key and lastly he would perform a shut-down after it booted to Safe Mode.
    Just in case you need a temporary work-around like that, here are the steps: http://tinyurl.com/gomxy .

    It may be that an error is occurring during Shutdown and that is sending the system into a Restart cycle.

    If you haven't changed any of the system failure settings, you should be able to see the error by looking in the Event Log. But a better long-term solution is to turn off the automatic reboot so you can actually see the error when it happens?chances are it will tell you enough about itself to let you troubleshoot further. To change the recovery settings to disable automatic rebooting:

    Right-click My Computer, and then click Properties. Click the Advanced tab. Under Startup and Recovery, click Settings to open the Startup and Recovery dialog box. Clear the Automatically restart check box, and click OK the necessary number of times. Restart your computer for the settings to take effect.

    Now when you go to shut down and a fatal error occurs, you'll at least see it and it won't cause an automatic reboot. You still have to sort out what's causing the problem


    There is also a Registry key and value you can check.
    ***Warning: Performing manual changes to the Windows Registry incorrectly can make Windows inoperable. It is always advised to perform a Registry backup and setting an XP Restore point prior to making changes to the Registry.***
    That being said, go to Start - Run - regedit.
    With the Registry open, find this key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon].

    Create a new string value, or modify the existing value, called PowerdownAfterShutdown
    and set it to "1" to power off the computer at shutdown, or "0" to reboot. Restart
    Windows for the change to take effect.


    Please let me know if this helps.

    +
    0 Votes
    mickambrose

    CaptBilly1eye........
    When I formatted both drives and installed XP English and XP French, I removed all cards possible, and installed no programmes, but the problem was still there.
    Automatic restart is clear, PAS is set to 1.
    Sorry!
    Mick

    +
    0 Votes
    Michael O'Brien

    Hi Mick,

    Sounds like a hardware problem to me, are you able to check how hot your CPU is running ?

    Second thing you could do is Remove all RAM chips and put one in and startup and see if the problem occurs (do the same for the rest of the ram chips).

    Is this a OEM Pc or a custom built pc ?

    +
    0 Votes
    mickambrose

    CPU runs around 60?.
    Changed all RAM last week as part of an upgrade.
    The PC started life as an OEM, but is now nearer to being a custom built (by me)!

    Mick

    +
    0 Votes
    CaptBilly1Eye

    On a system with an Intel board that had the same situation, 'down-grading' the BIOS to a previous version corrected the issue.
    It was found in that situation that the most current BIOS update caused the auto-restart.
    Check with the MoBo's manufacturer web site for instructions and previous BIOS releases.

    In still another situation, with a different MoBo, updating to the most recent BIOS update solved it.

    Make sure that in the BIOS it is set to not Wake on LAN and also to remain off after a power outage.

    Perhaps if you answer the questions I posed in my previous post, I or someone else may be able to be of further help. That is, does the situation occur when you boot to Safe Mode (not Safe Mode with Networking), Is the registry line present and correct, is there anything in the Event log?

    Other info that would be helpful is what make and model of board? Is onboard LAN enabled? Does the same situation occur with only one drive connected? Are the drives SATA or IDE? Both NTFS? RAID? UPS?

    Unfortunately there is no set fix. The resolution will be different depending on each system's configuration and it is often extremely difficult to pinpoint the exact cause. Have you checked with technical support for that MoBo?
    That would be the most logical source based on all the things you've tried.


    Good Luck.


    [It is greatly appreciated if you tag all useful responses as 'Helpful' by opening those posts and clicking the 'Mark Helpful' button at the bottom. That way, people with a similar situation in the future will be able to quickly see what ultimately helped. Thanks.]

    +
    0 Votes
    mickambrose

    Motherboard - Microstar MS7093 Ver 1.0
    BIOS - Phoenix Technologies, version 6.00 PG
    Power supply - Tagan TG420-U01 (420W)
    2x200GB SATA drives, both NTFS, One loaded with WinXP Home (English), the second with WinXP Home (Frnech).

    This situation started some months ago whilst on the existing BIOS. A Bios upgrade made no difference.
    Deleting Temp folder in safe mode then turning off makes no difference.
    Automatic restart is off, but there is never anything in the Event Log.
    PowerDown value is set to 1.
    Wake on LAN is off.

    Mick

    +
    0 Votes
    mickambrose

    I don't know what technically comes under the heading of "Restart" in Windows, but I have a few further observations that may or may not shed a little more light on the problem....

    If you request Windows to do a restart, the power is never turned off in the process.

    Normally, when you request Windows to Switch Off, it runs through its' processes and then does exactly that, removing power from the system.

    When I request a Switch Off, the computer definitely switches off (with an audible thump from my Altec sound system), and the display lights on the front go out, BUT, a split second later, the PC turns back on...

    One other observation. Although I have the power button set to "Instant Off", it doesn't. It still waits the 4 or 5 seconds before switching off, but then I still get the (Restart?).

    Mick

    +
    0 Votes
    wchaster

    Well I would tend to think this is a BIOS issue too, but since you indicate that you have updated the BIOS then that may not be it, unless you used the wrong BIOS.

    After reading all the post to your problem one thing came to mind. You have indicated that this started as an OEM PC and now you have replaced most of the parts. In troubleshooting this problem it also sound like to have spent numorous hours and have had the assistance of many. What do you think the cost of all this troubleshooting has cost you?
    Maybe the cure to your problem is to replace the MoBo.

    +
    0 Votes
    mickambrose

    The BIOS is correct for the MB. The cost doesn't really come into the equation as such because everything has been an upgrade for my own purposes.
    If I thought changing the MB was the answer to the problem I would do it, but I need convincing by "one who knows" before I go through the hassle involved.

    Mick

    +
    0 Votes
    sgt_shultz

    i am coming late to this party, did you already post the bsod error? and peek in the event logs for more clues? does it do this in safe mode?

    +
    0 Votes
    mickambrose

    This was an unrelated problem caused by supposedly matched pair of Ram modules that weren't!
    I just happened to notice that after a BSOD the power-off button worked correctly.

    Mick

    +
    0 Votes
    mickambrose

    ........forgot to add that the problem is the same if I try to shutdown from Safe Mode.

    Mick

    +
    0 Votes
    rosamundwo

    Locate CDRALW2K.SYS
    Rename it to another name

    I have the same problem and i solved mine.


    CDRALW2K.SYS. Correspondent Larry Blumette identified the CDRALW2K.SYS file (version 1.0.0.1048) as the Roxio file causing his shutdown problems and error conditions. When he deleted or renamed this one file, his problems went away. (Of course, you lose your CD functionality that way, too.)

    Source: http://www.aumha.org/win5/a/shtdwnxp.php

    +
    0 Votes
    scoreychris

    try start control panel, power options,and change your settings to (home/office)this worked fine for me in xp scoreychris