Questions

Can't do a "Save As" to a network drive using Word 2007

+
0 Votes
Locked

Can't do a "Save As" to a network drive using Word 2007

jbonin
I am getting close to the end of my rope. I am running Vista Business and Office 2007. When I open a document in Word it opens fine. When I try to do a "Save As" (a .doc file not the new format) to a network drive, I get an error "There has been a network or file permission error. The network connection may be lost." and the file is not written. I can copy and paste files to and from the network drive using Windows Explorer and (surprisingly) I can open a network file with Word and do a "Save As" to a local drive without any problems. I have tried the above with Windows XP Pro and Office 2007 and the same error occurs.

I have looked at the various Microsoft web sites for any help but I have not found anything that will help me correct the problem.

Any ideas?
Clarifications Clarifications
+
0 Votes
nicks
Collapse -

Thanks for the fix. We had some very unusual circumstances. Some PCs with Office 2007 could save to network drives. Those with problems could save to certain servers but not others. Unchecking the Network dirves box in CA did the trick.

+
0 Votes
akuhlmann
Collapse -

thanks so much for the fix! this problem has been vexing me for a week! i appreciate everyone's time to share what's worked for them.

+
0 Votes
support
Collapse -

If you use CA Anti Virus, it is this that is casuing the problem. It's only started since beggining of July. The only way to get round it until CA fix the bug, is to make the user profile a member of domain administrators - NOT exactely ideal!

+
0 Votes
ben.rattigan
Collapse -

I have just received an email from CA regarding this issue, they state they now have a fix for it. They have made me raise a support ticket for it. Just waiting now.

+
0 Votes
ben.rattigan
Collapse -

Start the CA Etrust Agent
Goto ETrust Antivirus option
Goto Realtime Options
Then click the Advanced Tab
Uncheck Protect Network Drives
Apply the changes

I have tried this and it works

+
0 Votes
florinrobete
Collapse -

That worked for me.
Thank you.

+
0 Votes
jamesisin
Collapse -

If I disable realtime scanning on the local machine this does allow saves from Office. Clearly it relates to eTrust, but this is a bad solution.

I am not able to use the Apply button after unchecking the Protect Network Drives checkbox.

Also, my machine which is perfectly able to save Office files to network drives does have that box checked.

So, there is clearly more to this than the above solution suggests.

+
0 Votes
ben.rattigan
Collapse -

To use the Apply button after unchecking the Protect Network Drives I found that sometimes I get an error and have to go back and re-apply it a couple of times before it successfully saves, I noticed this with most machines we have.

This error only occurs with Office 2007, the Office 2003 and other apps save fine. The erro only occurs when saving back to a server and not a p2p share.

I have a network of 70 clients and doing this has resolved the problem, granted its not ideal because there is a fault in someones code somewhere but it's not an option that needs switching on if the realtime scanner is running on your servers as well.

+
0 Votes
jamesisin
Collapse -

After we installed the latest version of eTrust we were able to uncheck the Protect Network Drives checkbox through the server's console.

+
0 Votes
lewko98
Collapse -

Thank you very much for posting this. This issue was causing a very important client much grief, and I has spent much time working on the issue, and with trouble shooting with MS.
Thanks again.