Questions

Can't load intra sites before re-enabling LAN connection

Tags:
+
0 Votes
Locked

Can't load intra sites before re-enabling LAN connection

mkoskenk
Interesting situation; we have bunch of Sharepoint intra sites hosted on local server within our domain. Usually after client computer restart these sites can't be accessed and IE throws the Page cannot be displayed error. Going into network connections, disabling and enabling the LAN connection does the trick, connection repair won't suffice.

The intra sites don't reside in the Domain Controller. Both servers running DC and Windows Sharepoint Services are Windows Server 2003's. Ideas, anyone? A possible DNS issue?

Cheers,
Mikko
  • +
    0 Votes
    devtrends.com

    Before you clear out the issue after a reboot...

    1. Try access the site using the IP address of the server.

    2. Try pinging the netbios name of your SharePoint server. Does it resolve? Does it auto update the host name to be the FQDN?

    3. Ping and / or access the SharePoint Site using the fully qualified name, such as mysharepoint.mydomain.local


    Some random thoughts without really knowing the situation: SharePoint server is properly joined to the domain (computer object exists?)? Check your WINS, DNS server records for this host. Does the site work from your servers? Different subnet / different VLAN?

    +
    0 Votes
    CG IT

    Sounds like something isn't closing the connection to the site once they close the browser....

    +
    0 Votes
    mkoskenk

    Had to put this aside for a while but now I've got some time to take another look into this.

    @devtrends:
    1) I cannot access the site with the server's IP address, the site collection has been given host header sitename.domain.net

    2) When pinging the netbios name the IP address of the server is resolved, host name is not updated to FQDN

    3) Same situation than with 1)

    My colleague found out that doing
    ipconfig /release and
    ipconfig /renew

    from command prompt also resolves the Page cannot be displayed error.

    Before running the commands I tried to ping the sharepoint site - result: Could not find the host. After releasing and renewing the IP I could ping the site again.

    @ CG IT:
    We've set up the sharepoint sites ourselves, but there has been no actual development work nor coding, save few Sharepoint Designer desgined workflows.

    Ideas?

    +
    0 Votes
    mkoskenk

    Sorry, missed the random thoughts;

    "SharePoint server is properly joined to the domain (computer object exists?)? Check your WINS, DNS server records for this host. Does the site work from your servers? Different subnet / different VLAN?"

    -Server is properly joined, I can access it with remote desktop no probs even when I cannot access the sharepoint site hosted on the server.

    -Can't access the site from other servers either

    -Server's on same subnet and VLAN as majority of other computers

    Additional thought, we use the same server to run our FTP services that we use for the sharepoint sites concerned. Anything I should be aware of here?

    +
    0 Votes
    mkoskenk

    Any luck on this? It's no biggie, but still a nuisance nevertheless :)

    +
    0 Votes
    mkoskenk

    I'm starting to think more and more that this is a some kind of DNS issue.. Again, I'm facing the situation; I reloaded the intranet site that I had open and was working on earlier this morning and I only get the "Internet Explorer cannot display the webpage" error. When trying to access the site with Firefox, I get the error message

    Server not found

    Firefox can't find the server at site.address.net

    I tested the connectivity with IE and Firefox from a virtual PC running on the same computer I get the error message on - no probs.

    There are also some shared folders on the server that is hosting the inaccessible website and I can browse those folders with Windows Explorer.

    Any ideas how to fix this issue? It's getting more and more annoying by day...

    Cheers,
    Mikko

  • +
    0 Votes
    devtrends.com

    Before you clear out the issue after a reboot...

    1. Try access the site using the IP address of the server.

    2. Try pinging the netbios name of your SharePoint server. Does it resolve? Does it auto update the host name to be the FQDN?

    3. Ping and / or access the SharePoint Site using the fully qualified name, such as mysharepoint.mydomain.local


    Some random thoughts without really knowing the situation: SharePoint server is properly joined to the domain (computer object exists?)? Check your WINS, DNS server records for this host. Does the site work from your servers? Different subnet / different VLAN?

    +
    0 Votes
    CG IT

    Sounds like something isn't closing the connection to the site once they close the browser....

    +
    0 Votes
    mkoskenk

    Had to put this aside for a while but now I've got some time to take another look into this.

    @devtrends:
    1) I cannot access the site with the server's IP address, the site collection has been given host header sitename.domain.net

    2) When pinging the netbios name the IP address of the server is resolved, host name is not updated to FQDN

    3) Same situation than with 1)

    My colleague found out that doing
    ipconfig /release and
    ipconfig /renew

    from command prompt also resolves the Page cannot be displayed error.

    Before running the commands I tried to ping the sharepoint site - result: Could not find the host. After releasing and renewing the IP I could ping the site again.

    @ CG IT:
    We've set up the sharepoint sites ourselves, but there has been no actual development work nor coding, save few Sharepoint Designer desgined workflows.

    Ideas?

    +
    0 Votes
    mkoskenk

    Sorry, missed the random thoughts;

    "SharePoint server is properly joined to the domain (computer object exists?)? Check your WINS, DNS server records for this host. Does the site work from your servers? Different subnet / different VLAN?"

    -Server is properly joined, I can access it with remote desktop no probs even when I cannot access the sharepoint site hosted on the server.

    -Can't access the site from other servers either

    -Server's on same subnet and VLAN as majority of other computers

    Additional thought, we use the same server to run our FTP services that we use for the sharepoint sites concerned. Anything I should be aware of here?

    +
    0 Votes
    mkoskenk

    Any luck on this? It's no biggie, but still a nuisance nevertheless :)

    +
    0 Votes
    mkoskenk

    I'm starting to think more and more that this is a some kind of DNS issue.. Again, I'm facing the situation; I reloaded the intranet site that I had open and was working on earlier this morning and I only get the "Internet Explorer cannot display the webpage" error. When trying to access the site with Firefox, I get the error message

    Server not found

    Firefox can't find the server at site.address.net

    I tested the connectivity with IE and Firefox from a virtual PC running on the same computer I get the error message on - no probs.

    There are also some shared folders on the server that is hosting the inaccessible website and I can browse those folders with Windows Explorer.

    Any ideas how to fix this issue? It's getting more and more annoying by day...

    Cheers,
    Mikko