Questions

Can't remove additional mailbox(es) from Outlook

Tags:
+
0 Votes
Locked

Can't remove additional mailbox(es) from Outlook

anthony.sartini
The problem I am experiencing lately is that when I add additional mailboxes to my Outlook, I can't seem to remove them.

The scenario is as follows:

1. Open Outlook
2. Click Tools -> Email Accounts -> Change -> More Settings -> Advanced -> Add..
3. Select the mailbox I want to add (e.g. Mailbox - xxxx)
4. The mailbox now shows up in Outlook and I can access the mails fine

My Outlook screen now shows the following in the left hand pane:

Mailbox - Anthony (my main inbox)
Mailbox - xxxx (the newly added inbox)

Here's where the problem occurs. Normally, I can simply retrace my steps as above and remove "Mailbox - xxxx" no problem, however lately when I go to remove the mailbox using this method it doesn't show up in the list at all!! The mailbox is still visible and accessible in my main Outlook screen but I just can't remove it.
Right clicking on it and selecting "Close Mailbox - xxxx" gives me the following message... "This group of folders is associated with an e-mail account. To remove it, on the Tools menu, click E-mail accounts, select View or change e-mail accounts, click Next, and then click Remove". This is exactly what I have been trying to do, but as I just mentioned, the mailbox doesn't show up in the list hence I can't remove it.

Has anyone experienced this/have any advice as to how I can remove the mailbox??

Thanks in advance.
  • +
    0 Votes
    techlexx

    After Following the above steps and failing I removed the full access permission for the from the mailboxes on the exchange server, recreated the profile but STILL FAILED. What solved it for me is that i went back through the process of adding a mailbox (added the same mailbox i want to remove) when i close out and went back to add another mailbox the list was refreshed and all the mailboxes are now shown. I remove them all and Walllah!!! Fixed...............

    +
    1 Votes
    pjp

    Open the registry editor, and go to

    HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\Default

    Look through each of the folders below that to find which ones is causing the particular mailbox to be opened, then delete that whole folder

    +
    0 Votes
    anthony.sartini

    Thanks for your reply. I expanded the above registry hive and there were several entries in here. I deleted pretty much all of them (bar the ones that were valid and I wanted to keep), but the mailboxes still remained in Outlook.

    I have resolved the issue in a roundabout way by just recreating my Outlook profile which has removed them all.

    Thanks for the information anyway, i'm sure it will come in handy at some stage no doubt.

    +
    0 Votes
    TheOnlyRick

    I had a mailbox listed in the folder list, but wasn't removable 'cos it wasn't listed under 'Email accounts'.

    Deleting the reg ref worked a treat. Cheers!

    I think deleting and recreating Outlook profiles should be an (admittedly painful) annual task for all geeks with different accounts, rules and syncronisations going on.

    Outlook kludges up very easily, and is normally the first thing that I (and users at work) will complain about if their 'PC is being slow'.

    +
    0 Votes
    oz_cast

    what if you do the following.
    close out of Outlook.
    click on START then you should see outlook, Right click on it and go to properties. Select Data Files and delete that other email box from there or move the outlook.pst for the other email account to a different folder. close that out and see that worked.

    +
    0 Votes
    anthony.sartini

    Since I recreated my Outlook account yesterday the mailboxes, and actual problem, has gone away. Everything is back to normal now so I can't really recreate the issue exactly as it was to test your solution.

    However that option does look like it could/would have solved my problem. I'll keep it in mind if the problem ever arises again.

    Thanks for the reply... I have marked your post as helpful.


    EDIT: sorry I just looked at this again and I don't think it would have worked since the mailboxes are actually stored on our Exchange Server and not locally on my pc. Hence they wouldn't show up in the Data Files list.

    +
    0 Votes
    tom.johnson

    Once in your in the registry at your profile at HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\"Your outlook Profile", click on each sub-folder and open the 001f3001 keys to determine which folders are associated with each additional mailbox, and delete the entire sub folder.

    +
    0 Votes
    ismgr

    I had exactly the problem described here using Outlook 2000 with an old (5.5) version of Exchange Server. I scrolled through the sub folders in HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\ until I saw the entry with the name of the mailbox I was trying to remove. I deleted that subfolder (with Outlook closed) and reopened Outlook and the mailbox was gone.

    +
    0 Votes
    s.moffett

    You actually want to remove it in the same manner in which you added it.

    1. Open Outlook
    2. Click Tools -> Email Accounts -> Change -> More Settings -> Advanced
    3. Select the mailbox to be removed (e.g. Mailbox - xxxx) -> Click Remove

    This will remove the listing for you when it is an Exchange related account.

    +
    0 Votes
    ThumbsUp2

    He said, they mailbox does not appear on the list. Hence, he can't select it and click remove!

    +
    0 Votes
    anthony.sartini

    ...as ThumbsUp2 pointed out, I wasn't able to remove them using that procedure as the mailboxes were not showing in the list.

    +
    0 Votes
    s.moffett

    Sorry about that, I had read the post [no need to yell ThumbsUp2 an honest mistake] but missed the line where you said you had tried to retrace your steps and thought you had just tried to remove it by performing the close mailbox - xxxx.

    +
    1 Votes
    andre.chaput

    Look in HKCU\software\Microsoft\Windows NT\Windows Messaging Subsystem\Profiles and find the profile name you are working on.

    Once there, parse the different keys and look for for a REG_SZ string 001e300a with a value of EMSMDB.DLL (In my case).

    At the same time, you will not see the entry 001e660b that usually contains the user common name.

    Remove the 001e300a PARENT key with all his entries.

    Open Outlook and the undesire mailbox will be gone.

    +
    0 Votes

    ZA

    Kenone

    Posted a duplicate of a 2 year ood fix too!

    +
    0 Votes
    muthuvelraja

    I am using outlook 2010, None of these solutions are working for me, Still I am getting others profile

    +
    3 Votes
    techie65

    1. Right Click on the Mailbox you wish to remove
    2. Select properties
    3. Click on the 'Advanced' button on the General Tab
    4. Select the Advanced Tab
    5. Highlight the Mailbox you wish to remove if more than one in the list
    6. Click on 'Remove'

    +
    1 Votes
    AzDayton

    Thanks Techie65. Your tip led me to the same thing in Outlook 2010 on an Exchange server, though getting there was a different path:
    1. Right click the Mailbox you wish to remove (or your Mailbox).
    2. Select DATA FILE PROPERTIES.
    3. In the GENERAL tab, click the ADVANCED... button.
    4. In the MICROSOFT EXCHANGE dialog, click the ADVANCED tab.
    5. In the "Open these additional mailboxes" list, select the one you want to get rid of, and click the REMOVE button.
    6. Click OK... OK... OK... OK... until there are no more OK's to click! :-)

    +
    0 Votes
    scottkh

    I have several other user's mailboxes in my Outlook. Followed techie65's method to remove these mailboxes. As soon as I open my Outlook, all of these mailboxes came back. Did the registry hack, same thing. Recreated the profile, same thing. Where else I can find the settings?

    +
    0 Votes
    Reginald937

    Same situation, deleted the reg profile and outlook profile, mailboxes still there, and none of them are listed in 'Open these additional mailboxes'.

    might have to recreate the entire user profile!

    +
    5 Votes
    Reginald937

    After Following the above steps and failing I removed the full access permission for the effected user from the mailboxes on the exchange server, recreated the outlook profile and no more additional mailboxes.

    +
    0 Votes
    martinwtaylor

    That did it - remove the Full Access permission from Exchange 2010 server, open Outlook and attempt to open the mailbox. Outlook sees the lack of permissions and removes it. Then the permission can be reinstated in Exchange.

    Many thanks!

    +
    0 Votes
    RomanoP

    Only your solution worked, Tried everything that's been noted above and nothing worked. MANY thanks.

    +
    0 Votes
    techlexx

    After Following the above steps and failing I removed the full access permission for the from the mailboxes on the exchange server, recreated the profile but STILL FAILED. What solved it for me is that i went back through the process of adding a mailbox (added the same mailbox i want to remove) when i close out and went back to add another mailbox the list was refreshed and all the mailboxes are now shown. I remove them all and Walllah!!! Fixed...............

    +
    0 Votes
    s.moffett

    You actually want to remove it in the same manner in which you added it.

    1. Open Outlook
    2. Click Tools -> Email Accounts -> Change -> More Settings -> Advanced
    3. Select the mailbox to be removed (e.g. Mailbox - xxxx) -> Click Remove

    This will remove the listing for you when it is an Exchange related account.

    +
    1 Votes
    andre.chaput

    Look in HKCU\software\Microsoft\Windows NT\Windows Messaging Subsystem\Profiles and find the profile name you are working on.

    Once there, parse the different keys and look for for a REG_SZ string 001e300a with a value of EMSMDB.DLL (In my case).

    At the same time, you will not see the entry 001e660b that usually contains the user common name.

    Remove the 001e300a PARENT key with all his entries.

    Open Outlook and the undesire mailbox will be gone.

    +
    3 Votes
    techie65

    1. Right Click on the Mailbox you wish to remove
    2. Select properties
    3. Click on the 'Advanced' button on the General Tab
    4. Select the Advanced Tab
    5. Highlight the Mailbox you wish to remove if more than one in the list
    6. Click on 'Remove'

    +
    1 Votes
    AzDayton

    Thanks Techie65. Your tip led me to the same thing in Outlook 2010 on an Exchange server, though getting there was a different path:
    1. Right click the Mailbox you wish to remove (or your Mailbox).
    2. Select DATA FILE PROPERTIES.
    3. In the GENERAL tab, click the ADVANCED... button.
    4. In the MICROSOFT EXCHANGE dialog, click the ADVANCED tab.
    5. In the "Open these additional mailboxes" list, select the one you want to get rid of, and click the REMOVE button.
    6. Click OK... OK... OK... OK... until there are no more OK's to click! :-)

    +
    0 Votes
    Reginald937

    Same situation, deleted the reg profile and outlook profile, mailboxes still there, and none of them are listed in 'Open these additional mailboxes'.

    might have to recreate the entire user profile!

    +
    5 Votes
    Reginald937

    After Following the above steps and failing I removed the full access permission for the effected user from the mailboxes on the exchange server, recreated the outlook profile and no more additional mailboxes.

  • +
    0 Votes
    techlexx

    After Following the above steps and failing I removed the full access permission for the from the mailboxes on the exchange server, recreated the profile but STILL FAILED. What solved it for me is that i went back through the process of adding a mailbox (added the same mailbox i want to remove) when i close out and went back to add another mailbox the list was refreshed and all the mailboxes are now shown. I remove them all and Walllah!!! Fixed...............

    +
    1 Votes
    pjp

    Open the registry editor, and go to

    HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\Default

    Look through each of the folders below that to find which ones is causing the particular mailbox to be opened, then delete that whole folder

    +
    0 Votes
    anthony.sartini

    Thanks for your reply. I expanded the above registry hive and there were several entries in here. I deleted pretty much all of them (bar the ones that were valid and I wanted to keep), but the mailboxes still remained in Outlook.

    I have resolved the issue in a roundabout way by just recreating my Outlook profile which has removed them all.

    Thanks for the information anyway, i'm sure it will come in handy at some stage no doubt.

    +
    0 Votes
    TheOnlyRick

    I had a mailbox listed in the folder list, but wasn't removable 'cos it wasn't listed under 'Email accounts'.

    Deleting the reg ref worked a treat. Cheers!

    I think deleting and recreating Outlook profiles should be an (admittedly painful) annual task for all geeks with different accounts, rules and syncronisations going on.

    Outlook kludges up very easily, and is normally the first thing that I (and users at work) will complain about if their 'PC is being slow'.

    +
    0 Votes
    oz_cast

    what if you do the following.
    close out of Outlook.
    click on START then you should see outlook, Right click on it and go to properties. Select Data Files and delete that other email box from there or move the outlook.pst for the other email account to a different folder. close that out and see that worked.

    +
    0 Votes
    anthony.sartini

    Since I recreated my Outlook account yesterday the mailboxes, and actual problem, has gone away. Everything is back to normal now so I can't really recreate the issue exactly as it was to test your solution.

    However that option does look like it could/would have solved my problem. I'll keep it in mind if the problem ever arises again.

    Thanks for the reply... I have marked your post as helpful.


    EDIT: sorry I just looked at this again and I don't think it would have worked since the mailboxes are actually stored on our Exchange Server and not locally on my pc. Hence they wouldn't show up in the Data Files list.

    +
    0 Votes
    tom.johnson

    Once in your in the registry at your profile at HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\"Your outlook Profile", click on each sub-folder and open the 001f3001 keys to determine which folders are associated with each additional mailbox, and delete the entire sub folder.

    +
    0 Votes
    ismgr

    I had exactly the problem described here using Outlook 2000 with an old (5.5) version of Exchange Server. I scrolled through the sub folders in HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\ until I saw the entry with the name of the mailbox I was trying to remove. I deleted that subfolder (with Outlook closed) and reopened Outlook and the mailbox was gone.

    +
    0 Votes
    s.moffett

    You actually want to remove it in the same manner in which you added it.

    1. Open Outlook
    2. Click Tools -> Email Accounts -> Change -> More Settings -> Advanced
    3. Select the mailbox to be removed (e.g. Mailbox - xxxx) -> Click Remove

    This will remove the listing for you when it is an Exchange related account.

    +
    0 Votes
    ThumbsUp2

    He said, they mailbox does not appear on the list. Hence, he can't select it and click remove!

    +
    0 Votes
    anthony.sartini

    ...as ThumbsUp2 pointed out, I wasn't able to remove them using that procedure as the mailboxes were not showing in the list.

    +
    0 Votes
    s.moffett

    Sorry about that, I had read the post [no need to yell ThumbsUp2 an honest mistake] but missed the line where you said you had tried to retrace your steps and thought you had just tried to remove it by performing the close mailbox - xxxx.

    +
    1 Votes
    andre.chaput

    Look in HKCU\software\Microsoft\Windows NT\Windows Messaging Subsystem\Profiles and find the profile name you are working on.

    Once there, parse the different keys and look for for a REG_SZ string 001e300a with a value of EMSMDB.DLL (In my case).

    At the same time, you will not see the entry 001e660b that usually contains the user common name.

    Remove the 001e300a PARENT key with all his entries.

    Open Outlook and the undesire mailbox will be gone.

    +
    0 Votes

    ZA

    Kenone

    Posted a duplicate of a 2 year ood fix too!

    +
    0 Votes
    muthuvelraja

    I am using outlook 2010, None of these solutions are working for me, Still I am getting others profile

    +
    3 Votes
    techie65

    1. Right Click on the Mailbox you wish to remove
    2. Select properties
    3. Click on the 'Advanced' button on the General Tab
    4. Select the Advanced Tab
    5. Highlight the Mailbox you wish to remove if more than one in the list
    6. Click on 'Remove'

    +
    1 Votes
    AzDayton

    Thanks Techie65. Your tip led me to the same thing in Outlook 2010 on an Exchange server, though getting there was a different path:
    1. Right click the Mailbox you wish to remove (or your Mailbox).
    2. Select DATA FILE PROPERTIES.
    3. In the GENERAL tab, click the ADVANCED... button.
    4. In the MICROSOFT EXCHANGE dialog, click the ADVANCED tab.
    5. In the "Open these additional mailboxes" list, select the one you want to get rid of, and click the REMOVE button.
    6. Click OK... OK... OK... OK... until there are no more OK's to click! :-)

    +
    0 Votes
    scottkh

    I have several other user's mailboxes in my Outlook. Followed techie65's method to remove these mailboxes. As soon as I open my Outlook, all of these mailboxes came back. Did the registry hack, same thing. Recreated the profile, same thing. Where else I can find the settings?

    +
    0 Votes
    Reginald937

    Same situation, deleted the reg profile and outlook profile, mailboxes still there, and none of them are listed in 'Open these additional mailboxes'.

    might have to recreate the entire user profile!

    +
    5 Votes
    Reginald937

    After Following the above steps and failing I removed the full access permission for the effected user from the mailboxes on the exchange server, recreated the outlook profile and no more additional mailboxes.

    +
    0 Votes
    martinwtaylor

    That did it - remove the Full Access permission from Exchange 2010 server, open Outlook and attempt to open the mailbox. Outlook sees the lack of permissions and removes it. Then the permission can be reinstated in Exchange.

    Many thanks!

    +
    0 Votes
    RomanoP

    Only your solution worked, Tried everything that's been noted above and nothing worked. MANY thanks.

    +
    0 Votes
    techlexx

    After Following the above steps and failing I removed the full access permission for the from the mailboxes on the exchange server, recreated the profile but STILL FAILED. What solved it for me is that i went back through the process of adding a mailbox (added the same mailbox i want to remove) when i close out and went back to add another mailbox the list was refreshed and all the mailboxes are now shown. I remove them all and Walllah!!! Fixed...............

    +
    0 Votes
    s.moffett

    You actually want to remove it in the same manner in which you added it.

    1. Open Outlook
    2. Click Tools -> Email Accounts -> Change -> More Settings -> Advanced
    3. Select the mailbox to be removed (e.g. Mailbox - xxxx) -> Click Remove

    This will remove the listing for you when it is an Exchange related account.

    +
    1 Votes
    andre.chaput

    Look in HKCU\software\Microsoft\Windows NT\Windows Messaging Subsystem\Profiles and find the profile name you are working on.

    Once there, parse the different keys and look for for a REG_SZ string 001e300a with a value of EMSMDB.DLL (In my case).

    At the same time, you will not see the entry 001e660b that usually contains the user common name.

    Remove the 001e300a PARENT key with all his entries.

    Open Outlook and the undesire mailbox will be gone.

    +
    3 Votes
    techie65

    1. Right Click on the Mailbox you wish to remove
    2. Select properties
    3. Click on the 'Advanced' button on the General Tab
    4. Select the Advanced Tab
    5. Highlight the Mailbox you wish to remove if more than one in the list
    6. Click on 'Remove'

    +
    1 Votes
    AzDayton

    Thanks Techie65. Your tip led me to the same thing in Outlook 2010 on an Exchange server, though getting there was a different path:
    1. Right click the Mailbox you wish to remove (or your Mailbox).
    2. Select DATA FILE PROPERTIES.
    3. In the GENERAL tab, click the ADVANCED... button.
    4. In the MICROSOFT EXCHANGE dialog, click the ADVANCED tab.
    5. In the "Open these additional mailboxes" list, select the one you want to get rid of, and click the REMOVE button.
    6. Click OK... OK... OK... OK... until there are no more OK's to click! :-)

    +
    0 Votes
    Reginald937

    Same situation, deleted the reg profile and outlook profile, mailboxes still there, and none of them are listed in 'Open these additional mailboxes'.

    might have to recreate the entire user profile!

    +
    5 Votes
    Reginald937

    After Following the above steps and failing I removed the full access permission for the effected user from the mailboxes on the exchange server, recreated the outlook profile and no more additional mailboxes.