Cent OS 5.7/5.8 foriegn webhost. VPN FTP.

0 Votes

Cent OS 5.7/5.8 foriegn webhost. VPN FTP.

I recently rented server space in Amsterdam. I was given a choice between Cent OS and Fedora. I ran with Cent OS. The version installed in a VM was 5.7. Before anything, I upgraded to 5.8. The host downgraded the OS to 5.7 within three day. Ok, lesson learned - their security/snoop ware does not function in a different build.

At any rate, I have been attempting to accomplish a few things: install a private VPN, get iptables to properly work, and get Joomla CMS to connect with the FTP server.

One thing at a time, but they appear to be connected:
Joomla. I receive updates through FTP. I can FTP in and out of the VM from a secure shell, but I am unable to connect Joomla to the FTP server. I have been through the configuration files until my sight is blurry. No luck. SO I installed a CentOS VM under Virtual box on a personal computer. Same problem.

Going through the hosts configuration files and attempting to add a DNS server for natting for VPN I am finding that 1. Apache has no rules, but if I run an automated pentest, it must because only those ports associated with a webserver, ssh, and ftp respond. When I attempt to add a rule set ie: /sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE, I am told there is no nat module installed
(netstat -M -e
netstat: no support for `ip_masquerade' on this system.). I dig through /proc/net and there is no Masq module in either the server or local VM. How can this be corrected - Iptables is installed. I am also informed that masquerading is not available on the server, but it does function in the local VM.

Does anyone have any idea what I should do next, how I should proceed in order to accomplish my needs?

The host is happy to up sell me to Plesk, but when I downloaded a trial version, it would not install unless I down graded several services and SQL.