Questions

Cisco 1721 ATT DSL Configuration HELP

Tags:
+
0 Votes
Locked

Cisco 1721 ATT DSL Configuration HELP

beast99
I am trying to learn Cisco so I bought a Cisco 1721 with a ADSL WIC and trying to configure to work with my ATT DSL Internet connection. All my interfaces shows UP, but I still cannot connect to the Internet. Can someone please help. Thank you in advance.

=====


Cisco_1721>
Cisco_1721>
Cisco_1721>
Cisco_1721>
Cisco_1721>en
Cisco_1721#sho run
Building configuration...

Current configuration : 1547 bytes
!
! No configuration change since last restart
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco_1721
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool HUYHO.NET
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
domain-name HUYHO.NET
dns-server 68.94.156.1 68.94.157.1
!
ip cef
!
!
bridge irb
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
bridge-group 1
pvc 0/35
encapsulation aal5snap
!
!
interface FastEthernet0
ip address 192.168.1.254 255.255.255.0
ip nat inside
speed auto
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxxxx
ppp chap password 0 xxxx
ppp pap sent-username xxxx password 0 xxxxx
ppp ipcp dns request accept
!
interface BVI1
mac-address 000d.ed1b.6478
ip address dhcp client-id FastEthernet0
ip nat outside
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
login
!
end

==============
Cisco_1721#sho ip int brief
Interface IP-Address OK? Method Status Prot
ocol
ATM0 unassigned YES NVRAM up up

BVI1 unassigned YES DHCP up up

Dialer1 unassigned YES NVRAM up up

FastEthernet0 192.168.1.254 YES NVRAM up up

Serial0 unassigned YES NVRAM administratively down dow

========

Thank You
Michael
  • +
    0 Votes
    NetMan1958

    Can you ping any websites ? Try pinging yahoo by the URL (www.yahoo.com) and by the IP Address (67.195.160.76) and post back with the results.

    +
    0 Votes
    beast99

    Hello,
    Thank you. I did try to ping both www.yahoo.com and 67.195.160.76 with NO success. When I try to ping www.yahoo.com, I get an error, unable to find host. When I try to ping the IP, I get an error Request TIme Out.

    I have a crossover cable from the Cisco 1721 straight to the PC at this time.

    Thank You
    Michael

    +
    0 Votes
    beast99

    One more thing. I got the ATT External DNS server (in my config above) just from doing a search in Yahoo. I did not call ATT to get this info. Not sure if this could be the problem?

    Thank You
    Michael

    +
    0 Votes
    NetMan1958

    Take a look at this document and reconfigure your router in a similar way.
    http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml
    You shouldn't need bridging or the BVI interface. Also since your IOS version is 12.3 I don't think you will need the VPDN part of the configuration shown in the document. If you are not sure about the DNS server IPs, you can try using the OpenDNS servers (208.67.222.222
    208.67.220.220) . If you still have problems, post back with the updated config.

    +
    0 Votes
    seanferd

    See your old gateway or contact AT&T for the proper information - you may just have something wrong.

    Maybe some Cisco hints here:
    http://www.cisco.com/en/US/tech/tk175/tk15/technologies_q_and_a_item09186a0080093bff.shtml

    +
    0 Votes
    robo_dev

    Sample ATT Cisco Config:

    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username [Enter username here without brackets] password [Enter password here without brackets]
    ppp ipcp dns request
    ppp ipcp address accept

    +
    0 Votes
    beast99

    I did add in the DHCP accepted (please see below). I did verify my authentication with ATT as well and they are correct. They are also using CHAP. This maybe a dumb question since I am newbie with Cisco. Below under Interface Dialer1, I have (ppp pap sent-username xxxxx password 0 xxxxx) even though ATT is using CHAP, could this be a problem?

    All my interfaces does still show all UP and I still not able to connect to the internet with my PC. Currently I am using a crossover cable to connect my PC directly to the Cisco 1721 router. Below is my complete config. Please help, thank you.

    ===
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Cisco_1721
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 4096 debugging
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool HUYHO.NET
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    domain-name HUYHO.NET
    dns-server 68.94.156.1 68.94.157.1
    !
    ip cef
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    bridge-group 1
    pvc 0/35
    encapsulation aal5snap

    interface FastEthernet0
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    speed auto
    !
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxxx
    ppp chap password 0 xxxx
    ppp pap sent-username xxxxx password 0 xxxxx
    ppp ipcp dns request accept
    ppp ipcp address accept

    nterface BVI1
    mac-address 000d.ed1b.6478
    ip address dhcp client-id FastEthernet0
    ip nat outside
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    line aux 0
    line vty 0 4
    login

    ==========

    Cisco_1721#sho ip int breif
    ^
    % Invalid input detected at '^' marker.

    Cisco_1721#sho ip int brief
    Interface IP-Address OK? Method Status Prot
    ocol
    ATM0 unassigned YES NVRAM up up

    BVI1 unassigned YES DHCP up up

    Dialer1 unassigned YES NVRAM up up

    FastEthernet0 192.168.1.254 YES NVRAM up up

    Serial0 unassigned YES NVRAM administratively down dow

    ==============

    Thank You
    Michael

    +
    0 Votes
    NetMan1958

    You have interface ATM0 as a member of bridge-group 1. What is the purpose for that? Based on the output from your "sho ip int brief" you are not getting an IP Address from AT&T. Did you check out the article that I posted above:
    http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml
    ?

    +
    0 Votes
    beast99

    Hello,
    When I had removed bridge-group 1 under my ATM0 Interface, the BVI1 interface keeps going down then up, down then up, down then up. It never stay UP. Below is my sho Int BVI1.

    BVI1 is down, line protocol is down
    Hardware is BVI, address is 000d.ed1b.6478 (bia 000d.ed1b.6478)
    Internet address will be negotiated using DHCP
    MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output never, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/0 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    26 packets output, 16068 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out

    Please help.

    Thank You
    Michael

    +
    0 Votes
    NetMan1958

    Configure your interfaces as shown below:

    interface FastEthernet0
    ip address 192.168.1.254 255.255.255.0
    ip tcp adjust-mss 1452
    ip nat inside
    speed auto
    !
    interface atm0
    no shut
    no ip address
    bundle-enable
    dsl operating-mode auto
    !
    interface atm0.1 point-to-point
    no ip address
    no ip directed-broadcast
    no atm ilmi-keepalive
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    interface dialer1
    ip address negotiated
    mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp authentication chap pap callin
    ppp chap hostname <username>
    ppp chap password <password>
    ppp pap sent-username <username> password <password>
    !
    Then remove interface BVI1 and remove "bridge irb" and "bridge 1 protocol ieee" and "bridge 1 route ip". Then give it a go.

    +
    0 Votes
    beast99

    Hello,
    I did remove interface BVI1 and remove "bridge irb" and remove "bridge 1 protocol iee" and also remove "bridge 1 route. I also added ATM0.1 point-to-point but for some reason, I could not add pppoe-client dial-pool-number 1 under ATM0.1 point-to-point but was able to add pvc 0/35

    All my interfaces shows up including ATM0 and ATM0.1 point-to-point, but for some reason ATM0 and ATM0.1 point-to-point is NOT pulling an IP address. I can ping the gateway fine and the PC that is connected directly to the router (with crossover cable) is getting an IP address (192.168.x.x)

    Please advice. Thank you all for your help.

    Thank You
    Michael

    +
    0 Votes
    beast99

    Hello,
    I did remove interface BVI1 and remove "bridge irb" and remove "bridge 1 protocol iee" and also remove "bridge 1 route. I also added ATM0.1 point-to-point but for some reason, I could not add pppoe-client dial-pool-number 1 under ATM0.1 point-to-point but was able to add pvc 0/35

    All my interfaces shows up including ATM0 and ATM0.1 point-to-point, but for some reason ATM0 and ATM0.1 point-to-point is NOT pulling an IP address. I can ping the gateway fine and the PC that is connected directly to the router (with crossover cable) is getting an IP address (192.168.x.x)

    Please advice. Thank you all for your help.

    Thank You
    Michael .

    +
    0 Votes
    NetMan1958

    If you go into interface config for ATM0.1 and type "ppoe?" and press ENTER , what is the output?

  • +
    0 Votes
    NetMan1958

    Can you ping any websites ? Try pinging yahoo by the URL (www.yahoo.com) and by the IP Address (67.195.160.76) and post back with the results.

    +
    0 Votes
    beast99

    Hello,
    Thank you. I did try to ping both www.yahoo.com and 67.195.160.76 with NO success. When I try to ping www.yahoo.com, I get an error, unable to find host. When I try to ping the IP, I get an error Request TIme Out.

    I have a crossover cable from the Cisco 1721 straight to the PC at this time.

    Thank You
    Michael

    +
    0 Votes
    beast99

    One more thing. I got the ATT External DNS server (in my config above) just from doing a search in Yahoo. I did not call ATT to get this info. Not sure if this could be the problem?

    Thank You
    Michael

    +
    0 Votes
    NetMan1958

    Take a look at this document and reconfigure your router in a similar way.
    http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml
    You shouldn't need bridging or the BVI interface. Also since your IOS version is 12.3 I don't think you will need the VPDN part of the configuration shown in the document. If you are not sure about the DNS server IPs, you can try using the OpenDNS servers (208.67.222.222
    208.67.220.220) . If you still have problems, post back with the updated config.

    +
    0 Votes
    seanferd

    See your old gateway or contact AT&T for the proper information - you may just have something wrong.

    Maybe some Cisco hints here:
    http://www.cisco.com/en/US/tech/tk175/tk15/technologies_q_and_a_item09186a0080093bff.shtml

    +
    0 Votes
    robo_dev

    Sample ATT Cisco Config:

    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username [Enter username here without brackets] password [Enter password here without brackets]
    ppp ipcp dns request
    ppp ipcp address accept

    +
    0 Votes
    beast99

    I did add in the DHCP accepted (please see below). I did verify my authentication with ATT as well and they are correct. They are also using CHAP. This maybe a dumb question since I am newbie with Cisco. Below under Interface Dialer1, I have (ppp pap sent-username xxxxx password 0 xxxxx) even though ATT is using CHAP, could this be a problem?

    All my interfaces does still show all UP and I still not able to connect to the internet with my PC. Currently I am using a crossover cable to connect my PC directly to the Cisco 1721 router. Below is my complete config. Please help, thank you.

    ===
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Cisco_1721
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 4096 debugging
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool HUYHO.NET
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    domain-name HUYHO.NET
    dns-server 68.94.156.1 68.94.157.1
    !
    ip cef
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    bridge-group 1
    pvc 0/35
    encapsulation aal5snap

    interface FastEthernet0
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    speed auto
    !
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxxx
    ppp chap password 0 xxxx
    ppp pap sent-username xxxxx password 0 xxxxx
    ppp ipcp dns request accept
    ppp ipcp address accept

    nterface BVI1
    mac-address 000d.ed1b.6478
    ip address dhcp client-id FastEthernet0
    ip nat outside
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    line aux 0
    line vty 0 4
    login

    ==========

    Cisco_1721#sho ip int breif
    ^
    % Invalid input detected at '^' marker.

    Cisco_1721#sho ip int brief
    Interface IP-Address OK? Method Status Prot
    ocol
    ATM0 unassigned YES NVRAM up up

    BVI1 unassigned YES DHCP up up

    Dialer1 unassigned YES NVRAM up up

    FastEthernet0 192.168.1.254 YES NVRAM up up

    Serial0 unassigned YES NVRAM administratively down dow

    ==============

    Thank You
    Michael

    +
    0 Votes
    NetMan1958

    You have interface ATM0 as a member of bridge-group 1. What is the purpose for that? Based on the output from your "sho ip int brief" you are not getting an IP Address from AT&T. Did you check out the article that I posted above:
    http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml
    ?

    +
    0 Votes
    beast99

    Hello,
    When I had removed bridge-group 1 under my ATM0 Interface, the BVI1 interface keeps going down then up, down then up, down then up. It never stay UP. Below is my sho Int BVI1.

    BVI1 is down, line protocol is down
    Hardware is BVI, address is 000d.ed1b.6478 (bia 000d.ed1b.6478)
    Internet address will be negotiated using DHCP
    MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output never, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/0 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    26 packets output, 16068 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out

    Please help.

    Thank You
    Michael

    +
    0 Votes
    NetMan1958

    Configure your interfaces as shown below:

    interface FastEthernet0
    ip address 192.168.1.254 255.255.255.0
    ip tcp adjust-mss 1452
    ip nat inside
    speed auto
    !
    interface atm0
    no shut
    no ip address
    bundle-enable
    dsl operating-mode auto
    !
    interface atm0.1 point-to-point
    no ip address
    no ip directed-broadcast
    no atm ilmi-keepalive
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    interface dialer1
    ip address negotiated
    mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp authentication chap pap callin
    ppp chap hostname <username>
    ppp chap password <password>
    ppp pap sent-username <username> password <password>
    !
    Then remove interface BVI1 and remove "bridge irb" and "bridge 1 protocol ieee" and "bridge 1 route ip". Then give it a go.

    +
    0 Votes
    beast99

    Hello,
    I did remove interface BVI1 and remove "bridge irb" and remove "bridge 1 protocol iee" and also remove "bridge 1 route. I also added ATM0.1 point-to-point but for some reason, I could not add pppoe-client dial-pool-number 1 under ATM0.1 point-to-point but was able to add pvc 0/35

    All my interfaces shows up including ATM0 and ATM0.1 point-to-point, but for some reason ATM0 and ATM0.1 point-to-point is NOT pulling an IP address. I can ping the gateway fine and the PC that is connected directly to the router (with crossover cable) is getting an IP address (192.168.x.x)

    Please advice. Thank you all for your help.

    Thank You
    Michael

    +
    0 Votes
    beast99

    Hello,
    I did remove interface BVI1 and remove "bridge irb" and remove "bridge 1 protocol iee" and also remove "bridge 1 route. I also added ATM0.1 point-to-point but for some reason, I could not add pppoe-client dial-pool-number 1 under ATM0.1 point-to-point but was able to add pvc 0/35

    All my interfaces shows up including ATM0 and ATM0.1 point-to-point, but for some reason ATM0 and ATM0.1 point-to-point is NOT pulling an IP address. I can ping the gateway fine and the PC that is connected directly to the router (with crossover cable) is getting an IP address (192.168.x.x)

    Please advice. Thank you all for your help.

    Thank You
    Michael .

    +
    0 Votes
    NetMan1958

    If you go into interface config for ATM0.1 and type "ppoe?" and press ENTER , what is the output?