Questions

Cisco 851: Basic Setup Help

Tags:
+
0 Votes
Locked

Cisco 851: Basic Setup Help

elliott9
I am setting up a Cisco 851 and having some trouble with basic connectivity. I have a standard cable modem from my ISP and a d-link router connected to it (d-link IP is 192.168.0.1). From the d-link router I have this PC and my 851, later I plan on putting the 851 directly to the cable modem but I want to wait until it is fully setup. From the 851 I have 1 PC connected to one of the 4 ethernet ports that are sectioned off for my LAN.

I am able to get the 851 to pull the IP 192.168.0.6 from the d-link router. I can use the console cable to log into the 851 and from there I can sucessfully ping to the d-link router (192.168.0.1) and to google's IP. yay!

The 851 would not let me assign 1 of the 4 LAN interfaces an IP address of their own so I threw all 4 of them into a vlan (i think). I gave the vlan the IP 192.168.100.1 and then statically assigned the PC an IP of 192.168.100.30 with the gateway 192.168.100.1 (i will mess with DHCP later). Now I can sucessfully ping from the PC to the 851 (192.168.100.1 and 192.168.0.6). yay!

The problem is I cannot use the PC to ping the d-link router (192.168.0.1) which obviousely means I cannot ping out to the internet. Any assistance you can provide would be greatly appreciated. Here is a copy of my running config:


Building configuration...

Current configuration : 1754 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname LM-router
!
boot-start-marker
boot-end-marker
!
enable secret 5 --[OMITTED]--
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address dhcp
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24
54.0
station-role root
!
interface Vlan1
ip address 192.168.100.1 255.255.255.0
no ip route-cache cef
no ip route-cache
!
router rip
version 2
redistribute connected
redistribute static
network 192.168.100.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
no ip http server
no ip http secure-server
!
!
control-plane
!
banner motd ^C

Lord Mueller's Personal Router/Network

^C
!
line con 0
password 7 --[OMITTED]--
login
no modem enable
line aux 0
password 7 --[OMITTED]--
line vty 0 4
password 7 --[OMITTED]--
login
!
scheduler max-task-time 5000
ntp server 51.88.99.1
end
  • +
    0 Votes
    r6rider04

    I am dealing with the same issue. Did you ever get this resolved. If so could you please post your solution.

    +
    0 Votes

    RIP

    elliott9

    My problem was my d-link router was not running RIP so it did not know about the network my Cisco was advertising. Since my dlink doesnt allow for static routes I had to just connect my cisco directly to my modem and it works great.

  • +
    0 Votes
    r6rider04

    I am dealing with the same issue. Did you ever get this resolved. If so could you please post your solution.

    +
    0 Votes

    RIP

    elliott9

    My problem was my d-link router was not running RIP so it did not know about the network my Cisco was advertising. Since my dlink doesnt allow for static routes I had to just connect my cisco directly to my modem and it works great.