Questions

Cisco 851 config

+
0 Votes
Locked

Cisco 851 config

michael
Hi I need help in changing this config to include a /28 subnet.
The situation is my provider has given me 16 addresses that need full visability to the internet. The servers will sit behind the router with one of the 16 addresses acting as fire walls etc.
The basic config I have is

no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname <Company_name>
en
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
resource policy
!
no ip dhcp use vrf connected
!
ip dhcp pool Default-Pool
import all
network <Local Network> 255.255.255.0
default-router <IP_Address_Of_Router>
domain-name <Company_Name>.local
ip dhcp excluded-address <IP_Address_Of_Router>
ip dhcp excluded-address <IP_Address_Of_Server>
!
!
ip cef
!
!
!
!
!
!
bridge irb
!
!
!
!
interface ATM0
no shutdown
no ip address
load-interval 30
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface Dot11Radio0
no ip address
ip route-cache flow
no shutdown
!
encryption mode ciphers tkip
!
ssid <SSID>
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii <WPA Key>
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
no cdp enable

bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
description Chassis serial number <Device Serial Number>
no ip address
bridge-group 1
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname <User Name>
ppp chap password <Password>
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
interface BVI1
description $ES_LAN$$FW_INSIDE$
ip address <IP_Address_Of_Router> 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!
ip http server
ip http secure-server
ip nat inside source list NAT interface Dialer0 overload
!
ip access-list extended NAT
permit ip <Local Network> 0.0.0.255 any
!
dialer-list 1 protocol ip permit
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end