Questions

CISCO 851 dhcp on the wan problems

+
0 Votes
Locked

CISCO 851 dhcp on the wan problems

markb
Hey guys,

I have a brand new 851 router and for the life of me I have been unable to get it to pickup a DHCP address on its WAN port. I have read several other posts and tried solutions like cloning mac addresses. but nothing works.

Here are some specs on the router followed by a simple config.
Cisco 851 running IOS 12.4(15)T8 SDM 2.5
Connecting to a comcast cable modem the has 4 public IP's

Here is the running config
Any help is greatly appreciated
Thanks Mark

851-1#sh run
Building configuration...

Current configuration : 4784 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 851-1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2197830918
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2197830918
revocation-check none
rsakeypair TP-self-signed-2197830918
!
!
crypto pki certificate chain TP-self-signed-2197830918
certificate self-signed 01
3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32313937 38333039 3138301E 170D3032 30333031 30343431
30385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31393738
33303931 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100C406 DE27B30C 2C65E1BC 54954151 9ABFFB4C 9954EEF1 39C93404 21BB134F
D12D610F 8BBD03A4 DDA27CF5 DF57605A 1A5C7BA2 C210ED00 0FB22423 6A102A4D
A96E1809 6AA1AA65 93D0AAB5 2820D759 123C3D23 2FA4AA86 A6DCEC96 AC579F69
489BF854 E95F1FE3 FCE8F534 A24D9BC9 23A6D307 DAD05514 D5242A92 78DEE4A6
1D190203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
301F0603 551D2304 18301680 14B3169A 7BC07B2E 5495EAB7 0B9852B1 1B93BF28
8A301D06 03551D0E 04160414 B3169A7B C07B2E54 95EAB70B 9852B11B 93BF288A
300D0609 2A864886 F70D0101 04050003 81810069 20818097 AB187372 2BBDF1C7
A45508EF C5704C51 D1F06BB1 FBE4B97C E1F7FBDB 63D8061D F842C369 353ADD7A
C6D9A8AF 83901EB0 A6196018 95BDAE2B 693123B1 CF6EC27F FD070C2B A50C0909
16EE54A7 0D6DB30C DF39EA53 313B056D A395A49D DF7DE06A 1B56175C 90E0C81F
5836EA31 C139359F CBCA25B8 7ED8427E CF16F5
quit
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
import all
network 10.10.10.0 255.255.255.248
default-router 10.10.10.1
lease 0 2
!
!
ip cef
no ip domain lookup
ip domain name yourdomain.com
!
!
!
username admin privilege 15 secret 5 $1$IPqL$rOPNXXY2Mo2cGD8yVcIvB/
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address dhcp client-id FastEthernet4
ip broadcast-address 0.0.0.0
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.10.10.1 255.255.255.248
ip broadcast-address 10.10.10.0
ip tcp adjust-mss 1452
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
no cdp run