Questions

Cisco 851w slow download speeds

+
0 Votes
Locked

Cisco 851w slow download speeds

joebloggs1010101
Hi, I've got a Cisco 851w, its working fine other than it will only download at 5Mb when I've got a 15Mb line into the house, the old router works fine and I get 1.5 MB/s but the Cisco router just sits at about 300K when downloading large files anyone seen this before. I tried changing the mtu and the port is set to full duplex but no luck.
Here is the config

Current configuration : 1381 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CW851
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1 192.168.10.100
ip dhcp excluded-address 192.168.10.120 192.168.10.254
!
ip dhcp pool LAN_Netowrk
import all
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 4.2.2.2
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1460
speed 100
full-duplex
no cdp enable
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
54.0
station-role root
!
interface Vlan1
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
banner motd ^CThis router is password protected^C
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end
  • +
    0 Votes
    joebloggs1010101

    Hi, figured it out last night, the WAN port was manually configured to 100Mbs and Full duplex as suggested by Cisco but this is what was causing the issue, once I set the speed and duplex on the port back to auto the issue was resolved.
    There was no reports from the router of speed mismatch which is why I didn't think it might be that.
    Hope this helps anyone else that might be having simular problems

  • +
    0 Votes
    joebloggs1010101

    Hi, figured it out last night, the WAN port was manually configured to 100Mbs and Full duplex as suggested by Cisco but this is what was causing the issue, once I set the speed and duplex on the port back to auto the issue was resolved.
    There was no reports from the router of speed mismatch which is why I didn't think it might be that.
    Hope this helps anyone else that might be having simular problems