Questions

Cisco ASA and Pop3 problem

Tags:
+
0 Votes
Locked

Cisco ASA and Pop3 problem

clint
Hi , I have recently installed a new cisco asa 5505 device into my clients network . They were running ISA server which I un-installed . Everything on the SBS 2003 network is working fine, the users can browse the internet , smtp mail is going out , except the pop3 connector is not downloading the email for exchange . It connects fine then just times out . If I telnet to the pop3 server at the ISP on port 110 I can connect and get my username and password authorised , so I know it's not port 110 being blocked .
If I take the ASA 5505 out and just put a normal linksys router in its place , the mail downloads .
Do any of you cisco experts know what this could be ?
Am I missing something silly here ?

Here is my config , I know I have opened alot , but I was just trying to get it to work.


ptech5505# sh run
: Saved
:
ASA Version 7.2(3)
!
hostname ptech5505
domain-name painttechnics.co.za
enable password Hb/n0BUweASnKqkt encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.20.250 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group iburst
ip address pppoe setroute
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 50
no ip address
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd Hb/n0BUweASnKqkt encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name painttechnics.co.za
access-list internet_in extended permit tcp any any eq www
access-list internet_in extended permit tcp any any eq https
access-list internet_in extended permit icmp any any
access-list internet_in extended permit tcp any any eq ftp
access-list internet_in extended permit tcp any any eq smtp
access-list internet_in extended permit tcp any any eq pop3
access-list internet_in extended permit tcp any any eq echo
access-list internet_in extended permit ip any any
access-list outbound extended permit tcp any any eq echo
access-list outbound extended permit ip any any
access-list outbound extended permit icmp any any
access-list outbound extended permit tcp any any eq pop3
access-list outbound extended permit tcp any any eq smtp
access-list painttech_splitTunnelAcl standard permit 192.168.20.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 10.1.1.0 255.255.255.240
access-list outside_access_in remark pop3 download
access-list outside_access_in extended permit tcp any eq pop3 192.168.20.0 255.255.255.0 eq pop3
pager lines 24
logging asdm informational
mtu inside 1352
mtu outside 1352
mtu dmz 1352
ip local pool remote 10.1.1.1-10.1.1.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any echo-reply inside
icmp permit any inside
icmp permit any echo-reply outside
icmp permit any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outbound in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 196.2.100.1 1
route outside 0.0.0.0 0.0.0.0 196.2.112.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal 20
telnet 192.168.20.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
vpdn group iburst request dialout pppoe
vpdn group iburst localname ptechnics@wbs.co.za
vpdn group iburst ppp authentication pap
vpdn username ptechnics@wbs.co.za password *********
dhcpd auto_config outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp