Questions

Cisco - inter-vlan routing with layer 2 catalyst 2950 and cisco 2801 router

+
0 Votes
Locked

Cisco - inter-vlan routing with layer 2 catalyst 2950 and cisco 2801 router

yaron.kadem
Hi all please help,
I'm trying to implement Inter-Vlan routing (router-on-a-stick) between two private networks using a layer 2 catalyst 2950 switch running ISO 12.3 and a Cisco 2801 router running ISO 12.4 (IPBASE) but with no success till now.

My configuration is pretty simple and I went through at least two configuration examples on Cisco.com and another site called cisco-tips.com.

my problem, at least as it seems to be is that the two ports on the 2950 that connect the two private networks are stuck (solid-amber) for some reason I can't figure out.

My router's and switch's configurations are exactly as in this article http://www.cisco-tips.com/cisco-router-on-a-stick-with-switch/ except one thing, when I configured the trunk interface on the 2950 I couldn't enter the following command (switchport mode trunk - there is no such command) but I have been told that this command isn't necessary.

TIA
  • +
    0 Votes
    CG IT

    did you configure subinterfaces on your 2801?

    Note: from the router on a stick example:

    Now, in order for the two hosts to communicate between them, they must set as default gateway the IP address of the corresponding router subinterface address (e.g for host in VLAN 10 the gateway must be 10.10.10.2 and for host in VLAN 20 the gateway must be 20.20.20.2).


    Next: from the example:(config)# interface FastEthernet1/0/1
    (config-if)# description trunk-to-router-on-a-stick
    (config-if)# switchport trunk encapsulation dot1q
    (config-if)# switchport mode trunk
    (config-if)# exit

    Note: what's probably happening is that the switchports are in dynamic mode so you can't make a dynamic port a trunk port.

    so you have the following imput:
    config# int fastethernet 0/X/X [the port you wish to make a trunk port]
    config-int# switchport mode access
    config-int# switchport trunk encapsulation dot1q
    config-int# switchport mode trunk
    ctl+Z
    config#sh run

    check your config using the sh run to list each port and how they are configured.

    notice these switch interfaces commands from the example:

    (config)# interface FastEthernet1/0/3

    typically the command is interface fastethernet 1/0 which then puts in in config mode for that interface. the additional /3 is the subinterface.

    +
    0 Votes
    yaron.kadem

    it seems that my only problem was that the 2950's port led was stuck on solid-amber which means that the port was running on high utilization, anyway I'm using now another port and it works just fine.

    thanks again

    +
    0 Votes
    NetMan1958

    Run the following commands on your 2950 and post the output back here:
    "show interface faxx"
    where xx is the interface. For example fa0/1.
    Do this for the interfaces that connect to the 2 vlans and for the interface that connects to the router. Also, go ahead and post the output from "show interface trunk".

    +
    0 Votes
    yaron.kadem

    b#sh interfaces trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/24 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/24 1-4094

    Port Vlans allowed and active in management domain
    Fa0/24 1-2,10,17,20

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/24 1-2,10,17,20
    b#


    b#sh int Fa0/24 (trunk to router)
    FastEthernet0/24 is up, line protocol is up (connected)
    Hardware is Fast Ethernet, address is 000d.2908.0b58 (bia 000d.2908.0b58)
    Description: trunk to 2801
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 100Mb/s, media type is 100BaseTX
    input flow-control is unsupported output flow-control is unsupported
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:33, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 7000 bits/sec, 9 packets/sec
    41034 packets input, 3091158 bytes, 0 no buffer
    Received 34338 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 1223 multicast, 0 pause input
    0 input packets with dribble condition detected
    599493 packets output, 59236405 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    b#

    ---------------------

    b#sh int Fa0/23
    FastEthernet0/23 is up, line protocol is up (connected)
    Hardware is Fast Ethernet, address is 000d.2908.0b57 (bia 000d.2908.0b57
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Auto-duplex, Auto-speed, media type is 100BaseTX
    input flow-control is unsupported output flow-control is unsupported
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 16:06:57, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    101 packets input, 8156 bytes, 0 no buffer
    Received 62 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    10732 packets output, 838979 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    b#
    b#
    b#
    b#sh run int Fa0/23
    Building configuration...

    Current configuration : 109 bytes
    !
    interface FastEthernet0/23
    switchport access vlan 10
    switchport mode access
    spanning-tree portfast
    end

    +
    0 Votes
    canjunior

    switchport trunk encapsulation dot1q
    Then you can
    switchport mode trunk

  • +
    0 Votes
    CG IT

    did you configure subinterfaces on your 2801?

    Note: from the router on a stick example:

    Now, in order for the two hosts to communicate between them, they must set as default gateway the IP address of the corresponding router subinterface address (e.g for host in VLAN 10 the gateway must be 10.10.10.2 and for host in VLAN 20 the gateway must be 20.20.20.2).


    Next: from the example:(config)# interface FastEthernet1/0/1
    (config-if)# description trunk-to-router-on-a-stick
    (config-if)# switchport trunk encapsulation dot1q
    (config-if)# switchport mode trunk
    (config-if)# exit

    Note: what's probably happening is that the switchports are in dynamic mode so you can't make a dynamic port a trunk port.

    so you have the following imput:
    config# int fastethernet 0/X/X [the port you wish to make a trunk port]
    config-int# switchport mode access
    config-int# switchport trunk encapsulation dot1q
    config-int# switchport mode trunk
    ctl+Z
    config#sh run

    check your config using the sh run to list each port and how they are configured.

    notice these switch interfaces commands from the example:

    (config)# interface FastEthernet1/0/3

    typically the command is interface fastethernet 1/0 which then puts in in config mode for that interface. the additional /3 is the subinterface.

    +
    0 Votes
    yaron.kadem

    it seems that my only problem was that the 2950's port led was stuck on solid-amber which means that the port was running on high utilization, anyway I'm using now another port and it works just fine.

    thanks again

    +
    0 Votes
    NetMan1958

    Run the following commands on your 2950 and post the output back here:
    "show interface faxx"
    where xx is the interface. For example fa0/1.
    Do this for the interfaces that connect to the 2 vlans and for the interface that connects to the router. Also, go ahead and post the output from "show interface trunk".

    +
    0 Votes
    yaron.kadem

    b#sh interfaces trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/24 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/24 1-4094

    Port Vlans allowed and active in management domain
    Fa0/24 1-2,10,17,20

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/24 1-2,10,17,20
    b#


    b#sh int Fa0/24 (trunk to router)
    FastEthernet0/24 is up, line protocol is up (connected)
    Hardware is Fast Ethernet, address is 000d.2908.0b58 (bia 000d.2908.0b58)
    Description: trunk to 2801
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 100Mb/s, media type is 100BaseTX
    input flow-control is unsupported output flow-control is unsupported
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:33, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 7000 bits/sec, 9 packets/sec
    41034 packets input, 3091158 bytes, 0 no buffer
    Received 34338 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 1223 multicast, 0 pause input
    0 input packets with dribble condition detected
    599493 packets output, 59236405 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    b#

    ---------------------

    b#sh int Fa0/23
    FastEthernet0/23 is up, line protocol is up (connected)
    Hardware is Fast Ethernet, address is 000d.2908.0b57 (bia 000d.2908.0b57
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Auto-duplex, Auto-speed, media type is 100BaseTX
    input flow-control is unsupported output flow-control is unsupported
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 16:06:57, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    101 packets input, 8156 bytes, 0 no buffer
    Received 62 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    10732 packets output, 838979 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    b#
    b#
    b#
    b#sh run int Fa0/23
    Building configuration...

    Current configuration : 109 bytes
    !
    interface FastEthernet0/23
    switchport access vlan 10
    switchport mode access
    spanning-tree portfast
    end

    +
    0 Votes
    canjunior

    switchport trunk encapsulation dot1q
    Then you can
    switchport mode trunk