Questions

Cisco router configuration

Tags:
+
0 Votes
Locked

Cisco router configuration

xavier_talla
Please, from the simulation software I want to set an IP address for local host computers. Which command do I use for that on the CLI? This question also applies on setting the clock rate. For the clock rate I used: #clock rate 64000; the CLI is taking it but the result is still "not done". Please help
  • +
    0 Votes
    mohitgoyal1981

    Hi xavier,

    As you are using simulator you need not to provide clock rate as it is only prvided to DTE/DCE end of the serial cable...
    if i understand correct you want to provide IP addess to E0 interface of the router so that it can communicate with router...

    if it is then you can try this:

    router#config t
    Router(config-terminal)#int e0
    Router(config-if)#ip address 192.168.1.3 255.255.255.0 {ip address your desired Ip with netmask)


    HOpe this would solve your issue...

    Cheers

    +
    0 Votes
    xavier_talla

    Thanks for your information Mo,
    I have done all the above and it was correct. What I mean is giving a local host (one or two hosts on a network) an IP address. Directly on the blue screen I can right click on a host and configure (Name, IP address, subnet mask, Gateway), but what I want to know is how to give a host an IP address from the CLI (command line interface). There is a check weither you got the configuration or not. I have gotten all but not the host address and setting the clock.
    To give a host a name I know: "ip host <name> <ip address>" but this is not what I want.This only associates a host ip address to a name.
    Thanks again

    +
    0 Votes
    NetMan1958

    It sounds like you are wanting to configure DHCP on the router. Try this:
    ip dhcp pool mypool
    network 192.168.100.0 255.255.255.0
    default-router 192.168.100.1
    domain-name domain.com
    dns-server XX.XX.XX.XX XX.XX.XX.XX

    replace the X's with the ip addresses of your DNS servers.

  • +
    0 Votes
    mohitgoyal1981

    Hi xavier,

    As you are using simulator you need not to provide clock rate as it is only prvided to DTE/DCE end of the serial cable...
    if i understand correct you want to provide IP addess to E0 interface of the router so that it can communicate with router...

    if it is then you can try this:

    router#config t
    Router(config-terminal)#int e0
    Router(config-if)#ip address 192.168.1.3 255.255.255.0 {ip address your desired Ip with netmask)


    HOpe this would solve your issue...

    Cheers

    +
    0 Votes
    xavier_talla

    Thanks for your information Mo,
    I have done all the above and it was correct. What I mean is giving a local host (one or two hosts on a network) an IP address. Directly on the blue screen I can right click on a host and configure (Name, IP address, subnet mask, Gateway), but what I want to know is how to give a host an IP address from the CLI (command line interface). There is a check weither you got the configuration or not. I have gotten all but not the host address and setting the clock.
    To give a host a name I know: "ip host <name> <ip address>" but this is not what I want.This only associates a host ip address to a name.
    Thanks again

    +
    0 Votes
    NetMan1958

    It sounds like you are wanting to configure DHCP on the router. Try this:
    ip dhcp pool mypool
    network 192.168.100.0 255.255.255.0
    default-router 192.168.100.1
    domain-name domain.com
    dns-server XX.XX.XX.XX XX.XX.XX.XX

    replace the X's with the ip addresses of your DNS servers.