Questions

Cisco-to-HP VTP setup

+
0 Votes
Locked

Cisco-to-HP VTP setup

fedja_del
We have a primary Cisco switch running with multiple VLANs. We now want to hang a HP switch off our Cisco switch. I am struggling with VTP a bit, in particular with HP switch. Can someone please take me though this setup.

Below is a config of Cisco port which we would like to set up as a trunk for HP:

interface FastEthernet3/0/21
description HP DEV Switch
switchport access vlan 5
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 30.00
storm-control action shutdown
storm-control action trap

This is our VLAN config which we would like to replicate on HP:

interface Vlan1
no ip address
ip helper-address 10.2.14.1
!
interface Vlan2
description Office VLAN
ip address 10.2.14.129 255.255.255.128
ip helper-address 10.1.176.253
ip helper-address 10.1.176.91
ip helper-address 10.3.180.91
!
interface Vlan3
description Guest VLAN
ip address 10.2.14.65 255.255.255.192
ip helper-address 10.1.176.253
ip helper-address 10.1.176.91
ip helper-address 10.3.180.91
!
interface Vlan4
description wLAN
ip address 10.2.14.33 255.255.255.224
ip helper-address 10.1.176.253
ip helper-address 10.1.176.91
ip helper-address 10.3.180.91
!
interface Vlan5
ip address 10.2.14.2 255.255.255.224
ip helper-address 10.1.176.253
ip helper-address 10.1.176.91
ip helper-address 10.3.180.91
!


And finally, this is HP config

hostname "dev-sw-001"
snmp-server contact "Fedja Delalic"
snmp-server location "DEV - Corporate Office"
time timezone 600
time daylight-time-rule Southern-Hemisphere
cdp run
interface 1
no lacp
exit
interface 15
no lacp
exit
interface 16
no lacp
exit
interface 43
speed-duplex 100-full
exit
interface 48
name "port channel to Corp BLDG"
no lacp
exit
trunk 48 Trk2 LACP
trunk 15-16 Trk1 LACP
ip default-gateway 10.2.14.1
sntp server 128.250.36.2 2
timesync sntp
sntp unicast
sntp 100
snmp-server community "******" Operator
snmp-server host 10.1.176.202 "******"
vlan 1
name "DEFAULT_VLAN"
untagged 1-14,17-47,Trk1-Trk2
ip address 10.2.14.8 255.255.255.224
exit
vlan 2
name "********"
exit
aaa authentication telnet login tacacs local
aaa authentication telnet enable tacacs local
aaa authentication ssh login tacacs local
aaa authentication ssh enable tacacs local
tacacs-server key secured
tacacs-server host ********
ip ssh
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
password manager
password operator
  • +
    1 Votes
    CG IT

    Cisco Switch VTP mode server with other switches as VTP clients in same VTP domain. All switches run same VTP version.

    have to have a trunk line between switches. VTP allows all VLANs within the same VTP domain to communicate via 1 trunk line instead of having to have multiple trunk lines for multiple VLANs on swtich.

    +
    0 Votes
    frank_dcc

    VTP is Cisco proprietary, hence will not work on HP switches. Good luck

  • +
    1 Votes
    CG IT

    Cisco Switch VTP mode server with other switches as VTP clients in same VTP domain. All switches run same VTP version.

    have to have a trunk line between switches. VTP allows all VLANs within the same VTP domain to communicate via 1 trunk line instead of having to have multiple trunk lines for multiple VLANs on swtich.

    +
    0 Votes
    frank_dcc

    VTP is Cisco proprietary, hence will not work on HP switches. Good luck