Questions

Citrix Xenapp Access Denied saving to local client drive

+
0 Votes
Locked

Citrix Xenapp Access Denied saving to local client drive

stein_brian
I have taken over support of our new Xenapp 5 portal running on Windows 2008 and one of the first issues reported by our users was they don't see any options to save files from any of our published apps to save to their local client drives. I found that in the terminal server configuration for the ICA-TCP connection that under redirection 'Drives' was disabled. After enabling it, it now maps the local client drive (H$) to the V: drive and the path is 'C:\Documents and settings\username\my documents.

However when they go to save a file to this location from within our published apps (basically just office applications like Word, Excel, Powerpoint), after getting the CDM read warnings, it says 'Access Denied' and they can't save to their local drives. So I have 2 questions:

1) Why are they getting access denied when trying to save files to their local drives?

2) Is there a way to have the local drives map to the root of their C drive rather than there profile location or is this the default and just how it works?

Thank you!
  • +
    0 Votes
    lmalhoit Contributor

    I don't know the answers to your questions, but have you thought about upgrading to XenApp 6? It might fix your issues...especially since you're working on Server 2008.

    +
    0 Votes
    stein_brian

    The funny part is that I was told when I took over the Xenapp support in my environment that XA 6 was released like a few days after our XA 5 portal went live so they don't want to take it down again until summer break (We're a school district). However our server is virutal so i could just create a snapshot first then try the upgrade and if i run into an issue could always revert back I guess

    +
    0 Votes
    lmalhoit Contributor

    It's worth a try! I just put XA 6 on a virtual server here and everything seems to run well...the beauty of virtualization!

    +
    0 Votes
    stein_brian

    It turns out I had to edit one of the Java clients Java Script files to include a new 'tag' and once done, users can now save files locally with no problems. Now onto figuring out why it doesn't map their local drives to the root of the drive. Thanks all!

  • +
    0 Votes
    lmalhoit Contributor

    I don't know the answers to your questions, but have you thought about upgrading to XenApp 6? It might fix your issues...especially since you're working on Server 2008.

    +
    0 Votes
    stein_brian

    The funny part is that I was told when I took over the Xenapp support in my environment that XA 6 was released like a few days after our XA 5 portal went live so they don't want to take it down again until summer break (We're a school district). However our server is virutal so i could just create a snapshot first then try the upgrade and if i run into an issue could always revert back I guess

    +
    0 Votes
    lmalhoit Contributor

    It's worth a try! I just put XA 6 on a virtual server here and everything seems to run well...the beauty of virtualization!

    +
    0 Votes
    stein_brian

    It turns out I had to edit one of the Java clients Java Script files to include a new 'tag' and once done, users can now save files locally with no problems. Now onto figuring out why it doesn't map their local drives to the root of the drive. Thanks all!