Questions

Corrupted 750 Maxtor sata hard drive

+
0 Votes
Locked

Corrupted 750 Maxtor sata hard drive

joelg2012
hi TR this is my first time posting in this community thank you so much in advance. I'll try to be as simple as possible since i've seen a lot of comments in google where a lot gets discussed but i can't seem to see the answer right away.

Ok here we go:
1) I have a 750GB maxtor hard drive that acted as my primary repository for my files.

2) It was nearly 95% if not 98% full of data video pictures, etc.

3) One day it would simply not get recognized by my computer and it wouldn't show up in My computer next to my C: drive

4) I took it out and tried it on another computer with no luck whatsoever. I recall having used chkdisk /f, Recuva from Piriform.

5) One very important step i took was to use a program, i don't remember exactly the name, which tried and read the files and everything inside and copied them to another 1TB hard drive i have. After like 8 hours some stuff was recovered but was basically in indistinguishable folders and everything mixed up.

6)Tried some Linux distributions like Damn Small Linux, Ubuntu, Mandriva Linux and others i think. I either don't know how to mount the drive in certain distributions or it has given me an error saying "try the windows chkdisk program" on others.

7) Im currently experimenting with TESTDISK inside "PartedMagic" which came in the ULTIMATE BOOT DISK (latest version).
* the error im getting now is "the following partitions can't be recovered"


I don't really know how to use this or any other tools but I know there has to be a way....

Thank you any help is kindly apreciated! :)