Questions

Could having 2 ISP's be causing problems to connect?

Tags:
+
0 Votes
Locked

Could having 2 ISP's be causing problems to connect?

annieeee
I have 2 ISP's at home. One is used for the TV (wifi) and the other one is used in the laptop only (with a cable).
I have a Sony vaio, which uses Windows 7 Home Premium x64-based PC.
At times I was having problems connecting to the internet with the cable one, so the laptop would try to connect using the wifi. It succeeded- Since I'm not familiar with the wifi, in order to go back to the cable connection once it was working normally, I'd switch the wireless off (on the front of the case).
I haven't had any problems with it until yesterday, or so I imagine. I was using the cable connection and suddenly some sites wouldn't load. For instance twitter. It said: The server at www.twitter.com can't be found, because the DNS lookup failed. DNS is the web service that translates a website's name to its internet address. This error is most often caused by having no connection to the internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.
Anyway after trying to connect disabling the firewall and failing to do so, I figured after turning the modem off for some minutes, and then restarting everything it'd be back to normal. So last night before I went to sleep I unplugged everything. Today I turned everything back on, and the problem still persisted.
Browsing looking for answers it was suggested to try to connect to the internet using a proxy or whatever. I tried to see if twitter was loading on a webproxy, and it was.
I realized I have the wireless conn, so I gave it a shot at connecting to the internet using it so I switched the wireless connection on. To my surprise, another one of the sites which weren't loading, started to load. I checked if it was using my regular connection or the wireless one (I'd post the link to the site I used but I dunno if that's allowed), and it showed it was using the cable connection, although the switch of the wireless was on and I was also connected to the wifi.
Anyway I switched it back off, and that other site was still loading and twitter was also loading though all funny, unable to read anything.
Late at night I came to check for any improvements and still the same, so I kept on reading trying to find possible solutions. Ipconfigsys renew I think, flushing the DNS cache, etc... No use. Btw I tried to troubleshoot it, as in connecting to specific site and it said it was a DNS problem.
Finally when I was about to try again to turn everything off, unplug the modem, etc, I figured I was gonna give it a shot at switching the wireless back on. I did it, only this time I didn't turn it back off and guess what? Twitter loads perfectly and the other sites to which servers it couldn't connect before, connect just fine.
I suppose I should leave it always on? Could it be I caused a problem to the laptop while switching on and off? Is there a way I can set the cable connection as my default one so I won't have to switch the wifi on and off to prevent it from taking over? I'm sorry I'm asking questions that are so basic, but I'm not familiar at all with the wifi connections, except I'm using it for the TV.