Questions

Desktop shortcuts don't work!?

+
0 Votes
Locked

Desktop shortcuts don't work!?

Darren B - KC
Here's a strange problem that I can't figure out. One of our client computers is experiencing odd behaviour where double-clicking on a IE desktop shortcut results in absolutely nothing. I mean, nothing happens.

There's no error messages either. I see the hourglass icon for a split second or so each time I double-click the shortcut, but that's it.

It seems to only be affecting shortcuts that point to a web URL, however, because shortcuts that point to applications are okay. Even right-clicking and selecting Open doesn't do anything. But, if I open the shortcut's properties and copy/paste the URL into a browser, the page comes up just fine. I checked the file associations and it's set to use IE6, so that seems to be proper.

I tried creating brand new shortcuts, but those don't work either. Even rebooting the computer doesn't have any effect.

Now, it gets a little more bizarre in that the problem happens on some days, but not others. Or it may be that the shortcuts work in the morning, but later in the day, they stop working again! (Or vise-versa.)

We're running XP Pro SP2 clients on an AD (Server 2003) domain with roaming profiles. We use AVG 7.5 as our virus scanner, but it hasn't found any viruses thus far on the machine in question.

If it would kick out an error, then I could figure out where to start looking for the cause, but when absolutely nothing happens, it's harder to track.

Anyone have any ideas?

Thanks.
+
0 Votes
daveymac

I have the same problem - also with XP Pro. Used to be once in a while, but a restart would fix. Now even restarting doesn't help.
Help.

+
0 Votes
lawrencegallagher9

Did you ever find a fix for your problem? I'm having the same problem and don't know what to try next.

+
0 Votes
shasca

Can you open start/programs. and say word,or works in the programs list right click it in the menu "send to desktop create shortcut"

Then go to the desktop and launch the program from the newly created shortcut.

Try this and get back to us with the results.

+
0 Votes
seanferd

You may want to check the file association for URL : HTTP, and make sure it isn't broken.

+
0 Votes
Snuffy09

your desktop and set it as the wallpaper

+
1 Votes
wad11656

Go to

http://www.dougknox.com/xp/file_assoc.htm

and download
"LNK (Shortcut) File Association Fix" (Restores Default Shortcut Behavior).

Extract the reg and double-click it. (But when extracting, don't put it on your desktop 'cause it won't work!).

Worked wonders for me! ...Just when I thought I was doomed...!

:)

+
0 Votes
anthonyis2000

Use http://www.dougknox.com/xp/xp_fixes.html
registry fixes for the Link associations http://www.dougknox.com/xp/file_assoc.htm
and secondly if that doesn't fix it use the xp_exe_fix.reg on that same list of Doug's.

It was the HKEY_CLASSES_ROOT\exefile\shell\open\command default string that needed correcting. The data is suppose to be "%1" %*

I tested the xp_exe_fix.reg file on a virtual XP pc and it corrected the key to "%1" %* and all is running fine now. Rt. click on file, then left click merge, click ok to allow merge and click ok to close window. Shortcuts should work now.

That fixed it for me.