Questions

Exchange and a website on the same box

Tags:
+
0 Votes
Locked

Exchange and a website on the same box

iantrent
Setup- Win2k3, IIS, a website, Exchange 2k3.
Issue- this is all @ home - 1 IP address using DYNDNS as my DNS provider. How to I get OWA to run from the outside as well as have a working website with basically one IP address?
Simply Linksys router being used, but not setup in router mode. Thanks

btw the website has been running flawlessly for a year. Just added exchange and want OWA away from home.
  • +
    0 Votes
    Churdoo

    In IIS, are the Exchange virtual folders in a different site than your public website? If so, you need to change the port of the website containing the exchange virtual folders to a port other than 80. This article is old, but still applies:
    http://support.microsoft.com/kb/240753

    The only additional change is in your linky router, to also forward the port that you've defined for the OWA site to your server's inside IP address (unless you DMZ'd your server, not recommended).

    +
    0 Votes
    iantrent

    Well I've tried using a different base address of the exchange box than was defnied for the webiste.
    Base IP + Web -> Works
    Base IP + SMTP -> FAIL (with website up)
    New IP on WEB -> Web ok
    Old IP on SMTP -> Fail (same Port as web)
    OWA doesn't want to work unless it's the same base IP of the server. If I change it and try to run on a different IP, even with a different port, say http://server/exchange:8080 - fails - even if the one website web page is turned off (just the 1 website), it won't work. It's bizarre.

    Do I need to setup some type of port forwarding on the Linksys box for web traffic? Also there's only 1 DMZ host allowed, so that is throwing me off to. I outside IP, 2 needed ports (Http + OWA).

    Thanks

  • +
    0 Votes
    Churdoo

    In IIS, are the Exchange virtual folders in a different site than your public website? If so, you need to change the port of the website containing the exchange virtual folders to a port other than 80. This article is old, but still applies:
    http://support.microsoft.com/kb/240753

    The only additional change is in your linky router, to also forward the port that you've defined for the OWA site to your server's inside IP address (unless you DMZ'd your server, not recommended).

    +
    0 Votes
    iantrent

    Well I've tried using a different base address of the exchange box than was defnied for the webiste.
    Base IP + Web -> Works
    Base IP + SMTP -> FAIL (with website up)
    New IP on WEB -> Web ok
    Old IP on SMTP -> Fail (same Port as web)
    OWA doesn't want to work unless it's the same base IP of the server. If I change it and try to run on a different IP, even with a different port, say http://server/exchange:8080 - fails - even if the one website web page is turned off (just the 1 website), it won't work. It's bizarre.

    Do I need to setup some type of port forwarding on the Linksys box for web traffic? Also there's only 1 DMZ host allowed, so that is throwing me off to. I outside IP, 2 needed ports (Http + OWA).

    Thanks