Questions

File and Printer sharing on my home network

+
0 Votes
Locked

File and Printer sharing on my home network

p_m_morris
Hello all,

I'm having some home network problems and could use some advice (and a stiff drink). Here's what's going on:

My home network is assigned a workgroup name of ?MYHOME? and an IP range of 192.168.0.1 to 192.168.0.50. I have a file server with an shared/attached printer. I also have a networked printer with an IP address of 192.168.0.15. All PCs use DCHP to get their IP address.

I?ve shared a folder on the hard drive of my WinXP Pro SP2 file server on the MYHOME workgroup which can be seen and accessed by all the computers -- except my WinXP Pro office laptop.

All machines but my office laptop can see the shared drive, the shared printer, and the networked printer.

Each PC can ping another machine on the network. Even my office laptop can ping the other machines -- including the router/gateway -- but it cant access the mapped drive on the fie server, the shared printer on the file server or the networked printer.

FWIW, the office laptop is part of my company domain, not my MYHOME workgroup, but I dont have a VPN conection active, and the laptop connects to the Internet (via the wireless router) just fine. I just can't use any of the local resources in my home office -- the mapped drives, the shared or networked printer.

Can anyone tell me what I?m missing here? I?ve done what appears to be the obvious, trawled Google, and asked my networking buddies, but since it?s not a true domain (with Win2K3,AD, etc.), all the replies seem irrelevant for my lowly home office network workgroup.

Any and all advice is welcome.

PM
  • +
    0 Votes
    HAL 9000 Moderator

    Did you enable File & Printer Sharing?

    When you setup a Peer to Peer Workgroup it's important to have every machine on the Network in the Same Workgroup and it's generally easier to allow Auto Detection of IP Addresses so forget the Static IP Addressing except for the Network Printer.

    If the other computers in this LAN are not running XP you'll need to make the floppy that is available on the XP machine when you finish the Network Setup Wizard and then move the floppy to each non XP machine and run it to setup the Networking Protocols.

    What I do is start off with the computer connected to the Internet first no matter how that is connected unless it's through a Router then you need to remove all but 1 Computer to setup the Router properly. When you have the Router setup correctly you can then set about setting up the Network Setup Wizard which when doing you should allow File & Print Sharing and when you get to the section about how it connects to the Internet tell this system that it connects to another computer or Remote Gateway. If you have a Modem connecting to this computer and then a router from there it's different and you'll need to tell the computer that this Computer connects directly to the Internet and Other Computers connect to the Internet through this one.

    Then depending on how the LAN is actually setup and Forget about the Companies NB here you'll either need to disconnect the working computer from the Router and then connect another one and do the same thing all over again or connect 1 computer to the router if that connects to the computer that is directly connected to the Modem.

    You will need to do this for every computer on the network if everything is running through a router and then plug in all the computers and share the desired components. With Printers you need to install the software on each workstation and then tell the computer that you are installing a Network Printer click on Browse to find the location of the printer and then finish off the install. That should give you access to the printer at the very least.

    Actually just post back with a description of the way that you have setup your Home Network starting with the type of Internet connection that you are using and what connects directly to the Internet then how the computers are connected from there. Forget about the Company NB as it's not important here at the moment and is just a nuisance/distraction at the moment.

    Col

    +
    0 Votes
    p_m_morris

    thanks HAL. More to come...

    +
    0 Votes
    nic.spiers

    When a printer is on the network rather than via USB, Windows NEEDS to know what address that printer is. If devices are started up in random order then, with DHCP, the printer could have a different IP address each time it is started. Generally, if the printer stays on its address remains constant and does not cause an issue.
    BUT...
    Set the printer to a fixed IP address, say 192.168.xxx.2 and set the router to start DHCP at 192.168.xxx.3 Then either, install the printer on each PC, specifying the static address, or if already installed, change its port IP setting to 192.168.xxx.2. This can be done by entering the printer properties and ADDING A PORT. You can then assign the printer this port.

    +
    0 Votes
    kinguri

    make sure your user account on the laptop has password. You can't access workgroup share with an account without a password.

    +
    0 Votes
    michael_schau

    I have the exact same problem.
    My work laptop which is on a domain cannot access the workgroup on my home network. However I can ping the computers on the network.

    +
    0 Votes
    brian

    As far as I know, you cant be a member of a domain and a workgroup. I think your problem lies there. Become a member of the workgroup and I recon all will work. But thats not a long term solution.

    +
    0 Votes
    spiralingcrazies

    Windows XP HOme does not support domains so it can be made to "fake" domains by calling the domain in the workgroup. Maybe try the otehr way around - configure all your home PCs workgroup to be the same as the domain name and try that way?

    +
    0 Votes
    oscarc

    If you work laptop is not a member of the same workgroup, you WILL have a problem printing to the shared device. Add your laptop to the workgroup, and make sure that the computer that is controlling the shared equipment has it's firewall turn off.

    Hope this helps!

    +
    0 Votes
    larrybell_2000

    OK, since the original post is now over 20 months old, I would presume that you found an answer, or gave up.

    But for others in a similar situation who want ONE computer to work on TWO (or more) networks, this from April 2005 might help you out. I'll try to get it right. The wording of the original post was edited to match the situation here in this thread.

    " All you need to do is configure the office laptop settings so it can communicate with both networks at the same time.

    To do this, you will do the following:

    Multihome the office laptop. That is, assign multiple IP addresses to its network card. One address will be on the 192.168.0.x (home) network, the other will be on the 192.168.1.x (office) network. This will allow the office laptop to communicate with computers on both networks. For internet connectivity, you will also need to assign a default gateway and DNS server addresses. These addresses will be the same addresses you get when you "DHCP him" on the home network.

    What I would recommend doing is this. Get the office laptop talking with the 192.168.1.x (office) network. Do an "ipconfig /all" at the command line and write down all the settings. Then get the office laptop talking with the 192.168.0.x (home) network and write down the settings again. Next, turn off DHCP and *manually* assign both host IP addresses and subnet masks in office laptop's advanced TCP/IP settings. Also assign the default gateway and DNS server addresses from the 192.168.0.x network. That should be all you need to do, and office laptop should now be able to communicate on both local networks, and the Internet.

    And you do NOT need a second network card to multihome in XP:

    Go to the properties page for your network card, click on Internet Protocol (TCP/IP), click Properties, click the Use the following IP address radio button, then click the Advanced button. There you can assign as many IP addresses/subnet masks/gateways as you want)"

    Hopefully, the above post from April of 2005
    will give you the information you need to use BOTH networks without changing settings each time you move from one network to the other.


    The above information is thanks to user "Jimminy", a user on Computing.net. His Computing.net profile is located: http://www.computing.net/userinfo/111408

    +
    0 Votes
    tux_delux

    I see the original post of this was from last year, but no one has responded with this tip, and I just got the notice for it...

    Many file/print sharing problems in Windows XP can be solved easily by doing one simple step.

    Open up Windows Explorer, go to Tools->Folder Options. Click the 'View' tab. Look all the way at the bottom of the list, where the last item most likely reads "Use simple file sharing (Recommended)". If this is checked, uncheck it. This option, when checked, messes up file/print sharing as we know it, and reduces it to the method of dragging stuff to the static "Shared Folder" uh...folder.

    Also, as someone else said, make sure the account on the file server has a password (and is not the guest account). When connecting from the laptop to the file server's share(s), try putting in the file server's machine name and user name of your user from the file server, like domain notation (e.g. 'HOSTNAME\username'). This will explicitly tell the laptop that you don't want to use its own (perhaps cached) domain credentials to log in.

    +
    0 Votes
    c_corona99

    Hi,

    Maybe you have a fix IP, check first with IPCONFIG, IP must be in the MYHOME mask.

    Configure alternative IP: main with your office, secondary with 192.168.0.n.

    regards

  • +
    0 Votes
    HAL 9000 Moderator

    Did you enable File & Printer Sharing?

    When you setup a Peer to Peer Workgroup it's important to have every machine on the Network in the Same Workgroup and it's generally easier to allow Auto Detection of IP Addresses so forget the Static IP Addressing except for the Network Printer.

    If the other computers in this LAN are not running XP you'll need to make the floppy that is available on the XP machine when you finish the Network Setup Wizard and then move the floppy to each non XP machine and run it to setup the Networking Protocols.

    What I do is start off with the computer connected to the Internet first no matter how that is connected unless it's through a Router then you need to remove all but 1 Computer to setup the Router properly. When you have the Router setup correctly you can then set about setting up the Network Setup Wizard which when doing you should allow File & Print Sharing and when you get to the section about how it connects to the Internet tell this system that it connects to another computer or Remote Gateway. If you have a Modem connecting to this computer and then a router from there it's different and you'll need to tell the computer that this Computer connects directly to the Internet and Other Computers connect to the Internet through this one.

    Then depending on how the LAN is actually setup and Forget about the Companies NB here you'll either need to disconnect the working computer from the Router and then connect another one and do the same thing all over again or connect 1 computer to the router if that connects to the computer that is directly connected to the Modem.

    You will need to do this for every computer on the network if everything is running through a router and then plug in all the computers and share the desired components. With Printers you need to install the software on each workstation and then tell the computer that you are installing a Network Printer click on Browse to find the location of the printer and then finish off the install. That should give you access to the printer at the very least.

    Actually just post back with a description of the way that you have setup your Home Network starting with the type of Internet connection that you are using and what connects directly to the Internet then how the computers are connected from there. Forget about the Company NB as it's not important here at the moment and is just a nuisance/distraction at the moment.

    Col

    +
    0 Votes
    p_m_morris

    thanks HAL. More to come...

    +
    0 Votes
    nic.spiers

    When a printer is on the network rather than via USB, Windows NEEDS to know what address that printer is. If devices are started up in random order then, with DHCP, the printer could have a different IP address each time it is started. Generally, if the printer stays on its address remains constant and does not cause an issue.
    BUT...
    Set the printer to a fixed IP address, say 192.168.xxx.2 and set the router to start DHCP at 192.168.xxx.3 Then either, install the printer on each PC, specifying the static address, or if already installed, change its port IP setting to 192.168.xxx.2. This can be done by entering the printer properties and ADDING A PORT. You can then assign the printer this port.

    +
    0 Votes
    kinguri

    make sure your user account on the laptop has password. You can't access workgroup share with an account without a password.

    +
    0 Votes
    michael_schau

    I have the exact same problem.
    My work laptop which is on a domain cannot access the workgroup on my home network. However I can ping the computers on the network.

    +
    0 Votes
    brian

    As far as I know, you cant be a member of a domain and a workgroup. I think your problem lies there. Become a member of the workgroup and I recon all will work. But thats not a long term solution.

    +
    0 Votes
    spiralingcrazies

    Windows XP HOme does not support domains so it can be made to "fake" domains by calling the domain in the workgroup. Maybe try the otehr way around - configure all your home PCs workgroup to be the same as the domain name and try that way?

    +
    0 Votes
    oscarc

    If you work laptop is not a member of the same workgroup, you WILL have a problem printing to the shared device. Add your laptop to the workgroup, and make sure that the computer that is controlling the shared equipment has it's firewall turn off.

    Hope this helps!

    +
    0 Votes
    larrybell_2000

    OK, since the original post is now over 20 months old, I would presume that you found an answer, or gave up.

    But for others in a similar situation who want ONE computer to work on TWO (or more) networks, this from April 2005 might help you out. I'll try to get it right. The wording of the original post was edited to match the situation here in this thread.

    " All you need to do is configure the office laptop settings so it can communicate with both networks at the same time.

    To do this, you will do the following:

    Multihome the office laptop. That is, assign multiple IP addresses to its network card. One address will be on the 192.168.0.x (home) network, the other will be on the 192.168.1.x (office) network. This will allow the office laptop to communicate with computers on both networks. For internet connectivity, you will also need to assign a default gateway and DNS server addresses. These addresses will be the same addresses you get when you "DHCP him" on the home network.

    What I would recommend doing is this. Get the office laptop talking with the 192.168.1.x (office) network. Do an "ipconfig /all" at the command line and write down all the settings. Then get the office laptop talking with the 192.168.0.x (home) network and write down the settings again. Next, turn off DHCP and *manually* assign both host IP addresses and subnet masks in office laptop's advanced TCP/IP settings. Also assign the default gateway and DNS server addresses from the 192.168.0.x network. That should be all you need to do, and office laptop should now be able to communicate on both local networks, and the Internet.

    And you do NOT need a second network card to multihome in XP:

    Go to the properties page for your network card, click on Internet Protocol (TCP/IP), click Properties, click the Use the following IP address radio button, then click the Advanced button. There you can assign as many IP addresses/subnet masks/gateways as you want)"

    Hopefully, the above post from April of 2005
    will give you the information you need to use BOTH networks without changing settings each time you move from one network to the other.


    The above information is thanks to user "Jimminy", a user on Computing.net. His Computing.net profile is located: http://www.computing.net/userinfo/111408

    +
    0 Votes
    tux_delux

    I see the original post of this was from last year, but no one has responded with this tip, and I just got the notice for it...

    Many file/print sharing problems in Windows XP can be solved easily by doing one simple step.

    Open up Windows Explorer, go to Tools->Folder Options. Click the 'View' tab. Look all the way at the bottom of the list, where the last item most likely reads "Use simple file sharing (Recommended)". If this is checked, uncheck it. This option, when checked, messes up file/print sharing as we know it, and reduces it to the method of dragging stuff to the static "Shared Folder" uh...folder.

    Also, as someone else said, make sure the account on the file server has a password (and is not the guest account). When connecting from the laptop to the file server's share(s), try putting in the file server's machine name and user name of your user from the file server, like domain notation (e.g. 'HOSTNAME\username'). This will explicitly tell the laptop that you don't want to use its own (perhaps cached) domain credentials to log in.

    +
    0 Votes
    c_corona99

    Hi,

    Maybe you have a fix IP, check first with IPCONFIG, IP must be in the MYHOME mask.

    Configure alternative IP: main with your office, secondary with 192.168.0.n.

    regards