Questions

FTP server, Vista, and dynamic IP ISPs don't seem to mix

Tags:
+
0 Votes
Locked

FTP server, Vista, and dynamic IP ISPs don't seem to mix

keeneydj
Ok, I really just have a problem. Surely just something I'm missing.

I have Vista.

IIS6 FTP server up and running
-all default

Port 21 forwarded according to admin page of router, and a HTTP port checker.

All my other programs work properly, including games, bittorrent, utorrent finds it's forwarded port.

No problems connecting to anything else

The firewall is allowing ftp, and nothing changes even when I turn the firewall off.

FTP services are on.

I can connect via LAN, but not WAN.
most often that's just a symptom of not having your ports forwarded, or a nat/napt routing.
I really don't know what I'm missing, but it just will not connect outside the lan.

I've tried almost every configuration of the router, and nothing changes.

The request for port 21 goes through my router, but the connection is still refused. I haven't even gotten to the login dialog. it just will not connect to the ftp server.

from the LAN side everything is fine. the server runs just like it's supposed to. I'm not having any issues with permissions as far as I know.

it just seems like something isn't making it from the router to my comp.

My ISP does not block any ports. ...changing the FTP server TCP port and router forwarded ports does nothing diffrent. still just get a refused connection.

However, every fewtimes you type my external ip the title bar of the browser will start to display "FTP root at...." but then just refuse.

dunno what's goin on, but I've searched the net for hours, and none of the normal problems seem to fix mine

I suppose if you need it, I'm using Windstream DSL with a siemens speedstream 4200.

Thanks
-Dan
  • +
    0 Votes
    Cory_townsend

    I'm having the EXACT same issue, router/vista/IIS/Dynamic IP. When i disconnect my router it works fine. ISP again are not blocking any ports and my firewall is off. Ive port forwarded 21/22 and even DMZ'ed my internal IP no luck haha. Have you had any more success ?

    +
    0 Votes
    dhall

    Did you ever get an answer to your question about FTP server, Vista, and dynamic IP ISPs don't seem to mix?

    +
    0 Votes
    sybercorp

    I've tested out just about ever single FTP server available (whether it says it's Vista compatible or not) and the 1 thing I've found in EVERY ONE is that if you're using Passive Port Range(s), for whatever reason, if you put your external IP address in the field for it, and then put the port range you want to use in, you will not be able to connect to your FTP server using "PASV" mode. The trick is that you leave the port range in the settings, but you remove the external IP address all-together. Don't put ANYTHING in that IP address field. I know, it sounds weird, but it works. You will then be able to use PASV mode, which may be causing your problems.

    +
    0 Votes

    wow

    jbearden246

    This answer is 100% accurate. Seriously. It's refreshing! It's as if the IP box is just a decoration, cause it surely does not work!

    Many thanks.

  • +
    0 Votes
    Cory_townsend

    I'm having the EXACT same issue, router/vista/IIS/Dynamic IP. When i disconnect my router it works fine. ISP again are not blocking any ports and my firewall is off. Ive port forwarded 21/22 and even DMZ'ed my internal IP no luck haha. Have you had any more success ?

    +
    0 Votes
    dhall

    Did you ever get an answer to your question about FTP server, Vista, and dynamic IP ISPs don't seem to mix?

    +
    0 Votes
    sybercorp

    I've tested out just about ever single FTP server available (whether it says it's Vista compatible or not) and the 1 thing I've found in EVERY ONE is that if you're using Passive Port Range(s), for whatever reason, if you put your external IP address in the field for it, and then put the port range you want to use in, you will not be able to connect to your FTP server using "PASV" mode. The trick is that you leave the port range in the settings, but you remove the external IP address all-together. Don't put ANYTHING in that IP address field. I know, it sounds weird, but it works. You will then be able to use PASV mode, which may be causing your problems.

    +
    0 Votes

    wow

    jbearden246

    This answer is 100% accurate. Seriously. It's refreshing! It's as if the IP box is just a decoration, cause it surely does not work!

    Many thanks.