Questions

Group policy - Proxy configuration not working with IE7

+
0 Votes
Locked

Group policy - Proxy configuration not working with IE7

Grazal
Hello I am looking for suggestions on a current issue I have with I.E.7

I have a gpo publishing all my default page / security / proxy settings / favourites. Everything works fine with IE6 but IE7 users do not receive the proxy settings. I have tested my GPO and all is modelling ok but the settings do not even publish to the registry. If you uninstall IE7, rolling back to IE6 and reboot IE6 picks up the proxy settings and entries appear in the registry.

Any advice or links would be appreciated.
+
0 Votes
pwebster

Hi.
Try the microsoft article:
http://support.microsoft.com/kb/555850
We had the same problem and this solution worked for us.

+
0 Votes
igor

I ran into the same problem, and the solution listed in the http://support.microsoft.com/kb/555850 worked for us.

+
0 Votes

Pel

pknott

The above does not work. I have tried this plus everything to resolve this problem and I cannot get IE7 to inherit our GPO settings. Anyone any further advice?

+
0 Votes
jjohnson303

Pel,
Did you ever get a solution for this? I have tried all the suggestions that are out there and it just does not pick my AD GPO pac file settings.
Thanks

+
0 Votes
johan.burger

I had a very similar problem. All modelling showed that the policy was fine and that it applied correctly but the IE7 proxy settings did not update. After a long 3 day fault finding mission I played with the exclusion list and found that an illegal character caused the problem. In my case I used http://xxx.domain.net/; or http://xxx.domain.net/*;
IE7 will only accept http://xxx.domain.net without the / or the /* Hope this can help you as I coudn't find any other help on the internet.

+
0 Votes
techrepublic

Your post led to the solution. We had an entry with a leading dot which prevented IE from writing to the registry. We removed the offending character, and all was good.

+
0 Votes
rajeshnayyar

i have the same problem, my exception list in active directory policy is not working, if i go to local machine and proxy settings i saw all the sites i added through the active directory but it will not go to those sites.

+
0 Votes
rajeshnayyar

I disable the computer settings by going in to properties of the group policy link and also i changed the format of exceptions sites, now i put the sites as http://*.domain.com

+
0 Votes
stefanl

Thanks for finding and posting your findings. This solved my issue. I fought this for 2 months with out finding a fix. This is the only helpful post that I found.

+
0 Votes
d.rose

This help me on the way to our solution. It wasn't some rogue addresses the proxy exlusion list, rather some bad address configured in the internet explorer security zones gpo which had imported. Removing these allowed the proxy setting to be applied.

+
0 Votes
nickganga

So, like many people here, I have been fighting with this issue for a long time and I FINALLY found a solution.

Internet Explorer 7 no longer supports the Gopher and as a result, these Proxy Settings must be removed from the GPO otherwise IE will not apply the settings.

Straight from the mouth of the beast: http://support.microsoft.com/kb/968847#top

"Internet Explorer 7 does not support the Gopher protocol. For this problem to occur, the Gopher protocol would have to have been set in older Group Policies or from an earlier version of Internet Explorer before Internet Explorer 7 was installed."

and

"Remove the value for the Gopher proxy server specified in the Group Policy. "

THIS WORKS! FINALLY A SOLUTION.

Spread the word!