Questions

HELP! I accidentally disabled my on-board graphics card...

Tags:
+
0 Votes
Locked

HELP! I accidentally disabled my on-board graphics card...

pyromike3000
While attempting to force Windows to recognize my nice graphics card I accidentally disabled my on-board graphics card. Now I'm staring at a completely black screen whenever Windows starts up. I need to re-enable my onboard graphics card, but the only tool I have is BIOS setup (which as far as I'm aware won't let me do anything).
  • +
    0 Votes
    w2ktechman

    If you cant get in to safe mode, then pull the card and place it in a different port, or switch to the on-board video (if avail) and ininstall the disabled device.
    After it has been uninstalled, or changed ports, reboot and Win should detect it again

    +
    0 Votes
    pyromike3000

    How do I switch to the on-board video card?

    +
    0 Votes
    w2ktechman

    for the monitor? Plug in the monitor to the other port. The pull the video card out that you added.
    Or, if not, you should be able to change the port that the card is plugged into.

    Both of these require opening your system. If you do not know what you are doing, it is best to take it to the shop. You certainly do not want to damage anything.

    +
    0 Votes
    pyromike3000

    I have another port for the monitor, but I've already tried switching the plug over and removing the new video card, to no avail.

    Does anyone know how I could restart my system in MS DOS mode and then use some sort of command like ENABLE <servicename> (where servicename is my graphic card/driver)?

    +
    0 Votes
    w2ktechman

    you should be able to switch primary video adapters manually.

    Or, you can boot into the recovery console and enable the video card from there.

    +
    0 Votes
    jobart16

    if you remove the cmos battery for like 10 secs, it will erase all saved settings in the bios.kinda like a force reset for your bios.

    +
    0 Votes
    pyromike3000

    How do I remove the battery?

    +
    0 Votes
    OH Smeg

    If it was in BIOS you can re enable it by clearing the BIOS.

    If it was in Windows you need to boot with something different that allows you access to the Windows Partition so you can make a change to the settings or do a Repair Install of the OS.

    You can try a Live Linux to boot from and access the Data on the HDD or in a worst case scenario you can follow the makers instructions and do a Repair Install. Though you need to list the OS you are using and anything that you have enabled in that OS so that you do not destroy your ability to access your own data.

    For Instance if you are using XP Pro running Windows Encrypted File System and do a Repair Install you will overwrite the Encryption Key and be unable to access any Data on the HDD again unless you have a copy of the Encryption Key that you can mount.

    Col

    +
    0 Votes
    pyromike3000

    I disabled the video card by doing the following:

    - Right-click on Desktop
    - Left-click Properties
    - Goto Settings Tab
    - Left-click Advanced Button
    - Goto Adapter Tab
    - Left-click Properties Button
    - Under General Tab: Device usage: Do not use this device (disable)

    If anyone knows how to reverse this mistake, please let me know!

    +
    0 Votes
    jobart16

    boot in safe mode then try to enable it again.

    +
    0 Votes
    mrschofieldesq

    i had the exact same problem: i disabled both my old video card and then the onboard video in device manager and would get nothing but black screen after windows started. the same thing happened in safe mode and recovery console, since it was still windows and the setting not to use those drivers.

    i downloaded ERD Commander here:
    http://www.keshzone.com/2007/10/winternals-erd-commander-2005-ready-for.html

    then burned the iso with alcohol 120 to make a boot disk. this program boots to an OS very similar to Windows, but it detects its own devices, so you monitor will work. from here, you can access various windows settings, including drivers. so you can enable your vga driver. also, if you have windows doing automatic recovery points, you can just restore from a recovery point before the problem.

    I recommend always keeping an ERD Commander boot disk around. works wonderfully.

    +
    0 Votes
    tsvpipers

    I've done everything you suggested and my blank-screend PC doesn't seem to recognise the ERD disk when rebooting. Any ideas?

    +
    0 Votes
    OH Smeg

    You need to change it from Floppy, HDD, Optical Drive to Floppy, Optical Drive, HDD.

    Just do not use any device that you do not have so if you don't have a Floppy the Boot Order needs to be Optical Drive, HDD.

    You should see the POST Message and be able to enter BIOS to change the Boot Order.

    Col

    +
    0 Votes
    tsvpipers

    Ok, i got it to recognise the disk burnt with the iso file. but now it says the disk is not boot media. any more ideas?

    +
    0 Votes
    OH Smeg

    If not you have only burnt the Downloaded file and not converted it into the Bootable Format that you need.

    Look at your Burning Software to see how to convert the ISO Image to a Usable Format.

    Col

    +
    0 Votes
    michiati

    is it possible to run this process of my usb

    +
    0 Votes
    seanferd

    you can get almost any bootable ISO to run off a Flash drive.

    Having a (legal) copy of ERD Commander is on you.

    But why not boot in Safe Mode and re-enable the driver? If you can't for some reason, use Recovery Console and load the driver.

    +
    0 Votes
    dmiles

    1)Can you just reverse the process you performed to disable the graphics

    2)If you have the motherboard manual,check for reference to key that opens bios setup (ex. Del key),once open go to advance menu scroll through and locate the graphics line,highlight and then right click and choose eanble

    If you have a graphics card installed in slot on motherboard,uninstall,this would cause a conflict and render no graphics

    +
    0 Votes
    Deotriese

    I was just guilty of this problem, having attempted to force my computer to use the Nvidia graphics card instead of the Intel one, which keeps causing a game to crash on a brand new laptop.

    What you want to do is find your Device Manager in System Settings, Go to Display Adapters, right click on the card you disabled then re-enable it. This option isn't available in Personalisation>Display>Advanced Settings, etc. until you do this. Don't know if it's a fix for everyone, but it worked for me.

    Hope I helped!

  • +
    0 Votes
    w2ktechman

    If you cant get in to safe mode, then pull the card and place it in a different port, or switch to the on-board video (if avail) and ininstall the disabled device.
    After it has been uninstalled, or changed ports, reboot and Win should detect it again

    +
    0 Votes
    pyromike3000

    How do I switch to the on-board video card?

    +
    0 Votes
    w2ktechman

    for the monitor? Plug in the monitor to the other port. The pull the video card out that you added.
    Or, if not, you should be able to change the port that the card is plugged into.

    Both of these require opening your system. If you do not know what you are doing, it is best to take it to the shop. You certainly do not want to damage anything.

    +
    0 Votes
    pyromike3000

    I have another port for the monitor, but I've already tried switching the plug over and removing the new video card, to no avail.

    Does anyone know how I could restart my system in MS DOS mode and then use some sort of command like ENABLE <servicename> (where servicename is my graphic card/driver)?

    +
    0 Votes
    w2ktechman

    you should be able to switch primary video adapters manually.

    Or, you can boot into the recovery console and enable the video card from there.

    +
    0 Votes
    jobart16

    if you remove the cmos battery for like 10 secs, it will erase all saved settings in the bios.kinda like a force reset for your bios.

    +
    0 Votes
    pyromike3000

    How do I remove the battery?

    +
    0 Votes
    OH Smeg

    If it was in BIOS you can re enable it by clearing the BIOS.

    If it was in Windows you need to boot with something different that allows you access to the Windows Partition so you can make a change to the settings or do a Repair Install of the OS.

    You can try a Live Linux to boot from and access the Data on the HDD or in a worst case scenario you can follow the makers instructions and do a Repair Install. Though you need to list the OS you are using and anything that you have enabled in that OS so that you do not destroy your ability to access your own data.

    For Instance if you are using XP Pro running Windows Encrypted File System and do a Repair Install you will overwrite the Encryption Key and be unable to access any Data on the HDD again unless you have a copy of the Encryption Key that you can mount.

    Col

    +
    0 Votes
    pyromike3000

    I disabled the video card by doing the following:

    - Right-click on Desktop
    - Left-click Properties
    - Goto Settings Tab
    - Left-click Advanced Button
    - Goto Adapter Tab
    - Left-click Properties Button
    - Under General Tab: Device usage: Do not use this device (disable)

    If anyone knows how to reverse this mistake, please let me know!

    +
    0 Votes
    jobart16

    boot in safe mode then try to enable it again.

    +
    0 Votes
    mrschofieldesq

    i had the exact same problem: i disabled both my old video card and then the onboard video in device manager and would get nothing but black screen after windows started. the same thing happened in safe mode and recovery console, since it was still windows and the setting not to use those drivers.

    i downloaded ERD Commander here:
    http://www.keshzone.com/2007/10/winternals-erd-commander-2005-ready-for.html

    then burned the iso with alcohol 120 to make a boot disk. this program boots to an OS very similar to Windows, but it detects its own devices, so you monitor will work. from here, you can access various windows settings, including drivers. so you can enable your vga driver. also, if you have windows doing automatic recovery points, you can just restore from a recovery point before the problem.

    I recommend always keeping an ERD Commander boot disk around. works wonderfully.

    +
    0 Votes
    tsvpipers

    I've done everything you suggested and my blank-screend PC doesn't seem to recognise the ERD disk when rebooting. Any ideas?

    +
    0 Votes
    OH Smeg

    You need to change it from Floppy, HDD, Optical Drive to Floppy, Optical Drive, HDD.

    Just do not use any device that you do not have so if you don't have a Floppy the Boot Order needs to be Optical Drive, HDD.

    You should see the POST Message and be able to enter BIOS to change the Boot Order.

    Col

    +
    0 Votes
    tsvpipers

    Ok, i got it to recognise the disk burnt with the iso file. but now it says the disk is not boot media. any more ideas?

    +
    0 Votes
    OH Smeg

    If not you have only burnt the Downloaded file and not converted it into the Bootable Format that you need.

    Look at your Burning Software to see how to convert the ISO Image to a Usable Format.

    Col

    +
    0 Votes
    michiati

    is it possible to run this process of my usb

    +
    0 Votes
    seanferd

    you can get almost any bootable ISO to run off a Flash drive.

    Having a (legal) copy of ERD Commander is on you.

    But why not boot in Safe Mode and re-enable the driver? If you can't for some reason, use Recovery Console and load the driver.

    +
    0 Votes
    dmiles

    1)Can you just reverse the process you performed to disable the graphics

    2)If you have the motherboard manual,check for reference to key that opens bios setup (ex. Del key),once open go to advance menu scroll through and locate the graphics line,highlight and then right click and choose eanble

    If you have a graphics card installed in slot on motherboard,uninstall,this would cause a conflict and render no graphics

    +
    0 Votes
    Deotriese

    I was just guilty of this problem, having attempted to force my computer to use the Nvidia graphics card instead of the Intel one, which keeps causing a game to crash on a brand new laptop.

    What you want to do is find your Device Manager in System Settings, Go to Display Adapters, right click on the card you disabled then re-enable it. This option isn't available in Personalisation>Display>Advanced Settings, etc. until you do this. Don't know if it's a fix for everyone, but it worked for me.

    Hope I helped!