Questions

help ...stop cursor from jumping back to a different line while typing

+
0 Votes
Locked

help ...stop cursor from jumping back to a different line while typing

djlink
I have Windows XP on my laptop. While typing in any word processing program or email program, the cursor will "jump" back to an earlier line while I am typing and begin to enter the letters in the middle of something I had previously typed. Since I do not always look at the screen while I am typing, I get very frustrated to find that, when I do look up, I have to figure out what I have to cut and paste back to the end of the document...it is a great time-wasting and frustrating "glitch"! Any ideas on what is causing this and how to fix it? I am assuming it is a Windows XP problem because it happens it several different programs (even when I was typing this note!!!)
  • +
    0 Votes
    w2ktechman

    Often when this happens on a notebook, it is the heat sensor on the touchpad, or a problem with the driver.
    Try using an external keyboard/mouse temporarily to keep your hands from being over the touchpad.
    Then download the driver and install it. Try again, if it persists, replace the keyboard on the notebook (usually solves the problem).

    +
    0 Votes
    djlink

    I had never gotten used to the touchpad idea and had been using a wireless mouse with my laptop but had not considered the interference that might occur with this and the touchpad...
    I'll try your suggestions.
    Thanks for the help.

    +
    0 Votes
    w2ktechman

    try turning off the touchpad mouse, either in the BIOS or disable it in Win

    +
    0 Votes
    ThumbsUp2

    Touchpad interfeers with the external mouse. While typing along and thumb bumps the touchpad... mouse jumps. Even after adjusting sensitivity of the touchpad to something that should take a hammer to move the mouse, it was still doing it. I disabled the touchpad a long time ago because of it.

    +
    0 Votes
    sq_ft

    My cursor will randomly move to a different part of the screen. Sometimes the cursor will jump every 30-40 seconds, sometimes every 5-10. There is no rhyme or reason. Any activity on the computor, it will do it. I have tried many "solutions".
    Replace the mouse, 3 times.
    Run adaware, spybot, defrag, and virus scan with Norton.
    I am told it is a virus.
    I am getting frustrated and hearing simple solutions is heart-warming for some but, it isn't working for me.
    I am open to ANY suggestions.
    Thanks

    +
    0 Votes
    w2ktechman

    you replaced the mouse 3 times. After replacing the mouse, did it do it immediately, or over time?

    Also try a different kind of mouse, if you were using PS2, try USB.

    Are these optical or roller mice?
    What is being used for a mouse pad?
    Is it on a shiny surface?

    If it was USB mouse, did you try to re-install the USB drivers?

    +
    0 Votes
    Ironspider

    *sits in the background with his joystick remoted to djlink's laptop snickering madly*

    +
    0 Votes
    djlink

    I disabled the touchpad and that worked wonders thanks to the earlier advice (thanks again!!)....so even the evil joystick guy is out of the picture...probably terrorizing others now.
    BTW...these forums really can be very helpful for these nasty little probelms that are never covered in manuals that newbies like me try to decypher!

    +
    0 Votes

    th

    Ironspider

    th standss for trojan horse, so disabling your touchpad wont work

    +
    0 Votes
    msnook

    Have two laptops. One with XP one with Vista. Use an external mouse with both and have this problem all the time with both. If the touch pad being disabled is the fix, can it be enabled easily when out and about?

    +
    0 Votes
    w2ktechman

    a rootkit or something, passing right by AV. But I was waiting to see about other issues first.

    +
    0 Votes
    puffrooster

    That is exactly what is happening to me... EXACTLY. It didn't before! But my brother in law, who knows more than I do AND, who has "better" (pirated) software than I, (I do not have, nor do I ever use "stolen" software), did so much damage to my XPS that I had to re-format and re-load everything! And now I have djlink's problem. Oh please, what can I do to fix this. I don't want to re-load everything again. Please and Thank You.

    puffrooster@yahoo.ca

    +
    0 Votes
    kwc

    This download solved it for me on two notebooks:
    http://code.google.com/p/touchfreeze/downloads/list

    Hope that helps.

    What it does is disable the touchpad while you are typing. I type at about 200 wpm and this was driving me crazy until I found Touchfreeze.

    Best,
    kwc

    +
    0 Votes
    scheherazada

    After many years of this problem and no answers helping me in the very least I accidentally discovered the answer to my problem! I had accidentally touched the INS (insert) key. This moves the cursor back to the beginning of the last bit of typing. Simply pressing the INS key again and moving the cursor back to its proper place solves the problem.

    +
    0 Votes
    SmartAceW0LF

    there is no rehabilitation for those with my affliction.

    However, there is a workaround. One that you might find interesting djlink.

    I usually set the touchpad properties to "Automatically disable touchpad when external mouse is detected" which in my particular situation will usually be at all times unless I happen to be writing my final departing notes to loved ones just before passing on to the hereafter.
    ALso, most laptops these days come with a button to disable the touchpad temporarily. Now THAT is a tool I find handy indeed!

  • +
    0 Votes
    w2ktechman

    Often when this happens on a notebook, it is the heat sensor on the touchpad, or a problem with the driver.
    Try using an external keyboard/mouse temporarily to keep your hands from being over the touchpad.
    Then download the driver and install it. Try again, if it persists, replace the keyboard on the notebook (usually solves the problem).

    +
    0 Votes
    djlink

    I had never gotten used to the touchpad idea and had been using a wireless mouse with my laptop but had not considered the interference that might occur with this and the touchpad...
    I'll try your suggestions.
    Thanks for the help.

    +
    0 Votes
    w2ktechman

    try turning off the touchpad mouse, either in the BIOS or disable it in Win

    +
    0 Votes
    ThumbsUp2

    Touchpad interfeers with the external mouse. While typing along and thumb bumps the touchpad... mouse jumps. Even after adjusting sensitivity of the touchpad to something that should take a hammer to move the mouse, it was still doing it. I disabled the touchpad a long time ago because of it.

    +
    0 Votes
    sq_ft

    My cursor will randomly move to a different part of the screen. Sometimes the cursor will jump every 30-40 seconds, sometimes every 5-10. There is no rhyme or reason. Any activity on the computor, it will do it. I have tried many "solutions".
    Replace the mouse, 3 times.
    Run adaware, spybot, defrag, and virus scan with Norton.
    I am told it is a virus.
    I am getting frustrated and hearing simple solutions is heart-warming for some but, it isn't working for me.
    I am open to ANY suggestions.
    Thanks

    +
    0 Votes
    w2ktechman

    you replaced the mouse 3 times. After replacing the mouse, did it do it immediately, or over time?

    Also try a different kind of mouse, if you were using PS2, try USB.

    Are these optical or roller mice?
    What is being used for a mouse pad?
    Is it on a shiny surface?

    If it was USB mouse, did you try to re-install the USB drivers?

    +
    0 Votes
    Ironspider

    *sits in the background with his joystick remoted to djlink's laptop snickering madly*

    +
    0 Votes
    djlink

    I disabled the touchpad and that worked wonders thanks to the earlier advice (thanks again!!)....so even the evil joystick guy is out of the picture...probably terrorizing others now.
    BTW...these forums really can be very helpful for these nasty little probelms that are never covered in manuals that newbies like me try to decypher!

    +
    0 Votes

    th

    Ironspider

    th standss for trojan horse, so disabling your touchpad wont work

    +
    0 Votes
    msnook

    Have two laptops. One with XP one with Vista. Use an external mouse with both and have this problem all the time with both. If the touch pad being disabled is the fix, can it be enabled easily when out and about?

    +
    0 Votes
    w2ktechman

    a rootkit or something, passing right by AV. But I was waiting to see about other issues first.

    +
    0 Votes
    puffrooster

    That is exactly what is happening to me... EXACTLY. It didn't before! But my brother in law, who knows more than I do AND, who has "better" (pirated) software than I, (I do not have, nor do I ever use "stolen" software), did so much damage to my XPS that I had to re-format and re-load everything! And now I have djlink's problem. Oh please, what can I do to fix this. I don't want to re-load everything again. Please and Thank You.

    puffrooster@yahoo.ca

    +
    0 Votes
    kwc

    This download solved it for me on two notebooks:
    http://code.google.com/p/touchfreeze/downloads/list

    Hope that helps.

    What it does is disable the touchpad while you are typing. I type at about 200 wpm and this was driving me crazy until I found Touchfreeze.

    Best,
    kwc

    +
    0 Votes
    scheherazada

    After many years of this problem and no answers helping me in the very least I accidentally discovered the answer to my problem! I had accidentally touched the INS (insert) key. This moves the cursor back to the beginning of the last bit of typing. Simply pressing the INS key again and moving the cursor back to its proper place solves the problem.

    +
    0 Votes
    SmartAceW0LF

    there is no rehabilitation for those with my affliction.

    However, there is a workaround. One that you might find interesting djlink.

    I usually set the touchpad properties to "Automatically disable touchpad when external mouse is detected" which in my particular situation will usually be at all times unless I happen to be writing my final departing notes to loved ones just before passing on to the hereafter.
    ALso, most laptops these days come with a button to disable the touchpad temporarily. Now THAT is a tool I find handy indeed!