Questions

Home AD DS/DHCP/DNS server

Tags:
+
0 Votes
Locked

Home AD DS/DHCP/DNS server

MattCollinsUK
Hi All,

Having some trouble with configuring my home server's IP/DNS/Gateway settings, watched videos, read guides, just cant figure this out.

What I want to do is set my virgin super hub in modem mode and use my home server to manage the DNS/DHCP.

However once I enable modem mode, the clients pick up an address from my server, all works in DHCP etc. etc., but they have no internet access.

Current IP settings are as follows:

Use the following IP address: (almost 100% this is wrong, but what settings to use?)

IP address 192.168.0.5
Subnet Mask 255.255.255.0
Default Gateway: 192.168.0.1

Use the following DNS server address:

Preferred: 8.8.8.8
Alternate: 8.8.4.4

Now I am sure it
  • +
    0 Votes
    gechurch

    So your modem will still be doing the dialing, but you want the server to do DHCP/DNS?

    If so what you want to do is:
    - Set the modem with a static IP (192.168.0.1).
    - Disabled the DHCP server on the modem.
    - The modem will still need DNS servers (since it's got a static IP it won't be given the DNS servers your DHCP server is handing out). You can either let the ISP push down the DNS settings, or can use 8.8.8.8/8.8.4.4.
    - Enable DNS and DHCP on the server.
    - Configure DHCP to dish out 8.8.8.8 and 8.8.4.4 as DNS servers, and your modem's IP (eg. 192.168.0.1) as the default gateway.
    - Lastly, make sure 192.168.0.1 and any other static addresses you are using are not in the DHCP address pool.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you for your reply.

    The modem will be the interface between the server and the Internet.

    When I set the modem into modem only mode it gets an IP of 192.168.100.1

    So with that in mind, I am proposing the following settings to be set on the server.

    IP address 192.168.0.1 or 192.168.100.1 (not 100% on this)
    Subnet Mask 255.255.255.0
    Default Gateway: 192.168.100.1

    Use the following DNS server address:

    Preferred: 8.8.8.8 (or ISP)
    Alternate: 8.8.4.4 (or ISP)

    Thank you in advance.

    +
    0 Votes
    gechurch

    First of all I need to apologise for being misleading in my first response. I glossed over your question and focused on the DHCP bit, and missed the fact that you also want your server to handle DNS. That changes things just a little.

    Modem: Provided 192.168.100.1 is set as a static address, your modem setup is fine. With this set, you'll now need to make sure that all other computers on the network are in the same subnet as this (meaning they will all need an IP address starting with 192.168.100). If they're not in the same subnet they won't be able to talk to the modem.

    Server: It's best practice to give server's a static IP address, and it sounds like that's what you are trying to achieve. You can't use 192.168.100.1 because that is already in use by the modem. You also can't use 192.168.0.1 because it is on a different subnet. Lets go with 192.168.100.2. You've got the default gateway right (default gateway = modem). Your DNS servers (8.8.8.8 etc) would be correct if you wanted to use public DNS (which I assumed in my first post). Since you want the server to also handle DNS though, that's what you need to enter here. Type in 192.168.100.2 as the preferred DNS server, and leave the alternate one blank. At this point your server should be able to connect to the Internet.

    Next we need to configure the DHCP server so that it will hand out correct details to other computers on the network. What we are trying to achieve is to have the server hand out all of the above settings to each client, but with a unique IP address in the 192.168.100 range. To do this load the DHCP snapin and...
    * Create a new scope of 192.168.100.0 (a scope is the IP range you want the DHCP server to hand out)
    * Have an address pool of 192.168.100.3 to 192.168.100.254 (an address pool is the list of addresses that will be dished out.
    * Set the scope options (which are settings other than the IP address that will be handed out). Set:
    * Router -> 192.168.100.1 (ie. the router is the default gateway)
    * DNS Servers -> Set 192.168.100.2 only

    That's it! If you plug in a PC on the network now your DHCP server will dish it out an IP, the default gateway and a DNS server.

    If you haven't configured the DNS server already the only thing you'll have to do is tell it what to do for addresses that it can't find. The easiest thing to do is set a forwarder - a DNS server for it to hand the task off to. Just add 8.8.8.8 as the forwarder and DNS should work fine.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you very much for your advice so far.

    I have tried the above, and have successfully managed to be able to get clients to pick up DNS settings, join the domain, and I can administrate in AD, log on as domain admins etc etc. However neither the server nor the clients have internet access.

    Even if I leave the IP settings automatic (while the modem is in mode mode) I still cannot get onto the internet (with the modem plugged directly into the server)
    I have tried putting the various settings in as follows:

    IP = 192.168.100.2
    Subnet = 255.255.255.0
    Gateway = 192.168.100.1

    DNS

    I have tried 192.168.100.2 and 8.8.8.8 and 192.168.4.100/192.168.8.100 (the modems DNS server)

    I seem to be so close, I

    +
    0 Votes
    gechurch

    Well done so far Matt.

    Firstly, you should follow normal troubleshooting steps for Internet issues. Is the DSL/line sync light on? Can you log into the modem and run ping diagnostics from there? Ping a domain (google.com will reply) and an IP (like 8.8.8.8) to check whether it's just DNS that's not working, or is a fault with the Internet connection itself.

    How do you physically have things hooked up? In the setup I described I'm expecting that all devices will be able to see each other (ie. plugged into a single switch). You shouldn't have, as an example, the modem plugged into one network card in the server, and the rest of the network plugged in to a different network card. You should ping the modem's IP from the server/desktops to ensure they can see the modem.

    +
    0 Votes
    MattCollinsUK

    Thank You,

    Once the modem is in modem mode, with the built in DHCP server off, i cannot ping or use any of the advanced tools. However when the modem is in normal mode, the internet works fine.

    While in modem mode, i can ping 192.168.100.1 and that works fine.

    My network is modem---switch---devices (pc,pc,laptop,laptop, ps3,wifi access point, server)

    On rare occasions, (like now) my pc (not server) can actually work when the device is in modem mode. With all the settings left automatic, i get the following information from a ipconfig /all (from my pc)

    I have inserted a few "x's" for security in the first two bits, of the below ip's

    Connection-specific DNS Suffix . :
    Link-local IPv6 Address . . . . . : fexx::xxb0:bxxx:96d7:1551%12
    IPv4 Address. . . . . . . . . . . : xx.xx.43.249
    Subnet Mask . . . . . . . . . . . : 255.255.252.0
    Default Gateway . . . . . . . . . : xx.xx.40.1

    Can these settings be used or helpful in anyway?

    Thanks.

    +
    0 Votes
    gechurch

    Thanks Matt. It sounds like everything is physically hooked up just fine.

    I'm not sure of what you mean when you refer to 'modem mode' and 'normal mode'. Can you explain these (or if it is the terminology your brand of modem uses, tell us what make and model your modem is?

    At a guess, it sounds like you want to leave the modem in 'normal mode', then set the static IP and turn off the DHCP server. Does the interface allow you to do this?

    +
    0 Votes
    Who Am I Really

    ISP line in
    > modem
    > router (optional but recommended)
    > server
    > switches
    > LAN clients / devices

    for DHPC from the server to work correctly, the network has to be setup with all clients on the down stream side of the server

    the server should have 2 NIC jacks

    one will be used for the WAN
    the other will be used for the LAN

    otherwise with your current configuration everything is trying to communicate directly to the modem instead of passing through the server

    with everything directly connected to the modem when the server handles DHCP
    it's not going to function correctly because it can't forward the traffic back into the same LAN trying to reach the WAN

    also when a modem is setup in modem mode, which disables the router portion of the modem
    only one client can be connected at any given time which is why automatic settings work

    +
    0 Votes
    MattCollinsUK

    Thanks Gechurch,

    Your advice worked perfectly, turning the DHCP server off on the modem, worked. All clients now request DNS and DHCP from my server.

    A strange thing I have noticed the server auto configure is that, the DNS settings on the server has changed to 127.0.0.1 which I understand is the loopback address, which in a way makes sense as itself is there DNS server.

    I do now have a separate NIC on my server, but I am using that solely for HyperV traffic on a private switch, so I can play/practice without interfering.

    +
    0 Votes
    gechurch

    That's excellent to hear Matt.

    The loopback address sounds normal. I administer Windows SBS boxes and best practise with these is to specify a single DNS entry, which should point to the SBS box itself. I normally enter the servers IP address, but when I go back in later a lot of boxes tend to have 127.0.0.1 set. Windows is probably changing it after it realises it is it's own address. Perhaps they found people would change their IP and forget to update the DNS entry, or perhaps it's slightly faster to use the loopback address.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you for your reply.

    The modem will be the interface between the server and the Internet.

    When I set the modem into modem only mode it gets an IP of 192.168.100.1

    So with that in mind, I am proposing the following settings to be set on the server.

    IP address 192.168.0.1 or 192.168.100.1 (not 100% on this)
    Subnet Mask 255.255.255.0
    Default Gateway: 192.168.100.1

    Use the following DNS server address:

    Preferred: 8.8.8.8 (or ISP)
    Alternate: 8.8.4.4 (or ISP)

    Thank you in advance.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you very much for your advice so far.

    I have tried the above, and have successfully managed to be able to get clients to pick up DNS settings, join the domain, and I can administrate in AD, log on as domain admins etc etc. However neither the server nor the clients have internet access.

    Even if I leave the IP settings automatic (while the modem is in mode mode) I still cannot get onto the internet (with the modem plugged directly into the server)
    I have tried putting the various settings in as follows:

    IP = 192.168.100.2
    Subnet = 255.255.255.0
    Gateway = 192.168.100.1

    DNS

    I have tried 192.168.100.2 and 8.8.8.8 and 192.168.4.100/192.168.8.100 (the modems DNS server)

    I seem to be so close, I

    +
    0 Votes
    MattCollinsUK

    Thank You,

    Once the modem is in modem mode, with the built in DHCP server off, i cannot ping or use any of the advanced tools. However when the modem is in normal mode, the internet works fine.

    While in modem mode, i can ping 192.168.100.1 and that works fine.

    My network is modem---switch---devices (pc,pc,laptop,laptop, ps3,wifi access point, server)

    On rare occasions, (like now) my pc (not server) can actually work when the device is in modem mode. With all the settings left automatic, i get the following information from a ipconfig /all (from my pc)

    I have inserted a few "x's" for security in the first two bits, of the below ip's

    Connection-specific DNS Suffix . :
    Link-local IPv6 Address . . . . . : fexx::xxb0:bxxx:96d7:1551%12
    IPv4 Address. . . . . . . . . . . : xx.xx.43.249
    Subnet Mask . . . . . . . . . . . : 255.255.252.0
    Default Gateway . . . . . . . . . : xx.xx.40.1

    Can these settings be used or helpful in anyway?

    Thanks.

    +
    0 Votes
    Who Am I Really

    ISP line in
    > modem
    > router (optional but recommended)
    > server
    > switches
    > LAN clients / devices

    for DHPC from the server to work correctly, the network has to be setup with all clients on the down stream side of the server

    the server should have 2 NIC jacks

    one will be used for the WAN
    the other will be used for the LAN

    otherwise with your current configuration everything is trying to communicate directly to the modem instead of passing through the server

    with everything directly connected to the modem when the server handles DHCP
    it's not going to function correctly because it can't forward the traffic back into the same LAN trying to reach the WAN

    also when a modem is setup in modem mode, which disables the router portion of the modem
    only one client can be connected at any given time which is why automatic settings work

    +
    0 Votes
    MattCollinsUK

    Thanks Gechurch,

    Your advice worked perfectly, turning the DHCP server off on the modem, worked. All clients now request DNS and DHCP from my server.

    A strange thing I have noticed the server auto configure is that, the DNS settings on the server has changed to 127.0.0.1 which I understand is the loopback address, which in a way makes sense as itself is there DNS server.

    I do now have a separate NIC on my server, but I am using that solely for HyperV traffic on a private switch, so I can play/practice without interfering.

  • +
    0 Votes
    gechurch

    So your modem will still be doing the dialing, but you want the server to do DHCP/DNS?

    If so what you want to do is:
    - Set the modem with a static IP (192.168.0.1).
    - Disabled the DHCP server on the modem.
    - The modem will still need DNS servers (since it's got a static IP it won't be given the DNS servers your DHCP server is handing out). You can either let the ISP push down the DNS settings, or can use 8.8.8.8/8.8.4.4.
    - Enable DNS and DHCP on the server.
    - Configure DHCP to dish out 8.8.8.8 and 8.8.4.4 as DNS servers, and your modem's IP (eg. 192.168.0.1) as the default gateway.
    - Lastly, make sure 192.168.0.1 and any other static addresses you are using are not in the DHCP address pool.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you for your reply.

    The modem will be the interface between the server and the Internet.

    When I set the modem into modem only mode it gets an IP of 192.168.100.1

    So with that in mind, I am proposing the following settings to be set on the server.

    IP address 192.168.0.1 or 192.168.100.1 (not 100% on this)
    Subnet Mask 255.255.255.0
    Default Gateway: 192.168.100.1

    Use the following DNS server address:

    Preferred: 8.8.8.8 (or ISP)
    Alternate: 8.8.4.4 (or ISP)

    Thank you in advance.

    +
    0 Votes
    gechurch

    First of all I need to apologise for being misleading in my first response. I glossed over your question and focused on the DHCP bit, and missed the fact that you also want your server to handle DNS. That changes things just a little.

    Modem: Provided 192.168.100.1 is set as a static address, your modem setup is fine. With this set, you'll now need to make sure that all other computers on the network are in the same subnet as this (meaning they will all need an IP address starting with 192.168.100). If they're not in the same subnet they won't be able to talk to the modem.

    Server: It's best practice to give server's a static IP address, and it sounds like that's what you are trying to achieve. You can't use 192.168.100.1 because that is already in use by the modem. You also can't use 192.168.0.1 because it is on a different subnet. Lets go with 192.168.100.2. You've got the default gateway right (default gateway = modem). Your DNS servers (8.8.8.8 etc) would be correct if you wanted to use public DNS (which I assumed in my first post). Since you want the server to also handle DNS though, that's what you need to enter here. Type in 192.168.100.2 as the preferred DNS server, and leave the alternate one blank. At this point your server should be able to connect to the Internet.

    Next we need to configure the DHCP server so that it will hand out correct details to other computers on the network. What we are trying to achieve is to have the server hand out all of the above settings to each client, but with a unique IP address in the 192.168.100 range. To do this load the DHCP snapin and...
    * Create a new scope of 192.168.100.0 (a scope is the IP range you want the DHCP server to hand out)
    * Have an address pool of 192.168.100.3 to 192.168.100.254 (an address pool is the list of addresses that will be dished out.
    * Set the scope options (which are settings other than the IP address that will be handed out). Set:
    * Router -> 192.168.100.1 (ie. the router is the default gateway)
    * DNS Servers -> Set 192.168.100.2 only

    That's it! If you plug in a PC on the network now your DHCP server will dish it out an IP, the default gateway and a DNS server.

    If you haven't configured the DNS server already the only thing you'll have to do is tell it what to do for addresses that it can't find. The easiest thing to do is set a forwarder - a DNS server for it to hand the task off to. Just add 8.8.8.8 as the forwarder and DNS should work fine.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you very much for your advice so far.

    I have tried the above, and have successfully managed to be able to get clients to pick up DNS settings, join the domain, and I can administrate in AD, log on as domain admins etc etc. However neither the server nor the clients have internet access.

    Even if I leave the IP settings automatic (while the modem is in mode mode) I still cannot get onto the internet (with the modem plugged directly into the server)
    I have tried putting the various settings in as follows:

    IP = 192.168.100.2
    Subnet = 255.255.255.0
    Gateway = 192.168.100.1

    DNS

    I have tried 192.168.100.2 and 8.8.8.8 and 192.168.4.100/192.168.8.100 (the modems DNS server)

    I seem to be so close, I

    +
    0 Votes
    gechurch

    Well done so far Matt.

    Firstly, you should follow normal troubleshooting steps for Internet issues. Is the DSL/line sync light on? Can you log into the modem and run ping diagnostics from there? Ping a domain (google.com will reply) and an IP (like 8.8.8.8) to check whether it's just DNS that's not working, or is a fault with the Internet connection itself.

    How do you physically have things hooked up? In the setup I described I'm expecting that all devices will be able to see each other (ie. plugged into a single switch). You shouldn't have, as an example, the modem plugged into one network card in the server, and the rest of the network plugged in to a different network card. You should ping the modem's IP from the server/desktops to ensure they can see the modem.

    +
    0 Votes
    MattCollinsUK

    Thank You,

    Once the modem is in modem mode, with the built in DHCP server off, i cannot ping or use any of the advanced tools. However when the modem is in normal mode, the internet works fine.

    While in modem mode, i can ping 192.168.100.1 and that works fine.

    My network is modem---switch---devices (pc,pc,laptop,laptop, ps3,wifi access point, server)

    On rare occasions, (like now) my pc (not server) can actually work when the device is in modem mode. With all the settings left automatic, i get the following information from a ipconfig /all (from my pc)

    I have inserted a few "x's" for security in the first two bits, of the below ip's

    Connection-specific DNS Suffix . :
    Link-local IPv6 Address . . . . . : fexx::xxb0:bxxx:96d7:1551%12
    IPv4 Address. . . . . . . . . . . : xx.xx.43.249
    Subnet Mask . . . . . . . . . . . : 255.255.252.0
    Default Gateway . . . . . . . . . : xx.xx.40.1

    Can these settings be used or helpful in anyway?

    Thanks.

    +
    0 Votes
    gechurch

    Thanks Matt. It sounds like everything is physically hooked up just fine.

    I'm not sure of what you mean when you refer to 'modem mode' and 'normal mode'. Can you explain these (or if it is the terminology your brand of modem uses, tell us what make and model your modem is?

    At a guess, it sounds like you want to leave the modem in 'normal mode', then set the static IP and turn off the DHCP server. Does the interface allow you to do this?

    +
    0 Votes
    Who Am I Really

    ISP line in
    > modem
    > router (optional but recommended)
    > server
    > switches
    > LAN clients / devices

    for DHPC from the server to work correctly, the network has to be setup with all clients on the down stream side of the server

    the server should have 2 NIC jacks

    one will be used for the WAN
    the other will be used for the LAN

    otherwise with your current configuration everything is trying to communicate directly to the modem instead of passing through the server

    with everything directly connected to the modem when the server handles DHCP
    it's not going to function correctly because it can't forward the traffic back into the same LAN trying to reach the WAN

    also when a modem is setup in modem mode, which disables the router portion of the modem
    only one client can be connected at any given time which is why automatic settings work

    +
    0 Votes
    MattCollinsUK

    Thanks Gechurch,

    Your advice worked perfectly, turning the DHCP server off on the modem, worked. All clients now request DNS and DHCP from my server.

    A strange thing I have noticed the server auto configure is that, the DNS settings on the server has changed to 127.0.0.1 which I understand is the loopback address, which in a way makes sense as itself is there DNS server.

    I do now have a separate NIC on my server, but I am using that solely for HyperV traffic on a private switch, so I can play/practice without interfering.

    +
    0 Votes
    gechurch

    That's excellent to hear Matt.

    The loopback address sounds normal. I administer Windows SBS boxes and best practise with these is to specify a single DNS entry, which should point to the SBS box itself. I normally enter the servers IP address, but when I go back in later a lot of boxes tend to have 127.0.0.1 set. Windows is probably changing it after it realises it is it's own address. Perhaps they found people would change their IP and forget to update the DNS entry, or perhaps it's slightly faster to use the loopback address.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you for your reply.

    The modem will be the interface between the server and the Internet.

    When I set the modem into modem only mode it gets an IP of 192.168.100.1

    So with that in mind, I am proposing the following settings to be set on the server.

    IP address 192.168.0.1 or 192.168.100.1 (not 100% on this)
    Subnet Mask 255.255.255.0
    Default Gateway: 192.168.100.1

    Use the following DNS server address:

    Preferred: 8.8.8.8 (or ISP)
    Alternate: 8.8.4.4 (or ISP)

    Thank you in advance.

    +
    0 Votes
    MattCollinsUK

    Hi gechurch,

    Thank you very much for your advice so far.

    I have tried the above, and have successfully managed to be able to get clients to pick up DNS settings, join the domain, and I can administrate in AD, log on as domain admins etc etc. However neither the server nor the clients have internet access.

    Even if I leave the IP settings automatic (while the modem is in mode mode) I still cannot get onto the internet (with the modem plugged directly into the server)
    I have tried putting the various settings in as follows:

    IP = 192.168.100.2
    Subnet = 255.255.255.0
    Gateway = 192.168.100.1

    DNS

    I have tried 192.168.100.2 and 8.8.8.8 and 192.168.4.100/192.168.8.100 (the modems DNS server)

    I seem to be so close, I

    +
    0 Votes
    MattCollinsUK

    Thank You,

    Once the modem is in modem mode, with the built in DHCP server off, i cannot ping or use any of the advanced tools. However when the modem is in normal mode, the internet works fine.

    While in modem mode, i can ping 192.168.100.1 and that works fine.

    My network is modem---switch---devices (pc,pc,laptop,laptop, ps3,wifi access point, server)

    On rare occasions, (like now) my pc (not server) can actually work when the device is in modem mode. With all the settings left automatic, i get the following information from a ipconfig /all (from my pc)

    I have inserted a few "x's" for security in the first two bits, of the below ip's

    Connection-specific DNS Suffix . :
    Link-local IPv6 Address . . . . . : fexx::xxb0:bxxx:96d7:1551%12
    IPv4 Address. . . . . . . . . . . : xx.xx.43.249
    Subnet Mask . . . . . . . . . . . : 255.255.252.0
    Default Gateway . . . . . . . . . : xx.xx.40.1

    Can these settings be used or helpful in anyway?

    Thanks.

    +
    0 Votes
    Who Am I Really

    ISP line in
    > modem
    > router (optional but recommended)
    > server
    > switches
    > LAN clients / devices

    for DHPC from the server to work correctly, the network has to be setup with all clients on the down stream side of the server

    the server should have 2 NIC jacks

    one will be used for the WAN
    the other will be used for the LAN

    otherwise with your current configuration everything is trying to communicate directly to the modem instead of passing through the server

    with everything directly connected to the modem when the server handles DHCP
    it's not going to function correctly because it can't forward the traffic back into the same LAN trying to reach the WAN

    also when a modem is setup in modem mode, which disables the router portion of the modem
    only one client can be connected at any given time which is why automatic settings work

    +
    0 Votes
    MattCollinsUK

    Thanks Gechurch,

    Your advice worked perfectly, turning the DHCP server off on the modem, worked. All clients now request DNS and DHCP from my server.

    A strange thing I have noticed the server auto configure is that, the DNS settings on the server has changed to 127.0.0.1 which I understand is the loopback address, which in a way makes sense as itself is there DNS server.

    I do now have a separate NIC on my server, but I am using that solely for HyperV traffic on a private switch, so I can play/practice without interfering.