Questions

Home Network

+
0 Votes
Locked

Home Network

dvcster
I have a 3 PC network (2 Win XP PC's and 1 Ubuntu Linus PC) connected via D-Link 504T ADSL Router.

the 2 WinXP Pc's connect correctly, the Ubuntu Linux PC will connect to the Win XP pc's and can share files satisfactorilly, but the XP PC's show a connection to the Linux PC but when trying open the Linux PC for veiwing by the WinXP PC's they require a password,

Neither of the 2 Win PC's have passwords, the Linux PC does but the password for that PC will not pass the WinXP machines.

How do I overcome the problem .

Thank yo for reading.

Don
  • +
    0 Votes
    Toivo Talikka

    You need to set up the SMB (Samba) password for the user in the Ubuntu PC which is going to be used by the Windows XP PCs.

    Select Applications - Accessories - Terminal and type in the following if you want to set up the SMB password for the currently logged-in user:

    sudo smbpasswd -a `whoami`

    Type in first the password of the currently logged-in Ubuntu user. Then type in the new SMB password and confirm it.

    It is safest to restart the Ubuntu PC, or, while in the terminal window, type in:

    sudo /etc/init.d/samba restart

    If you need to check anything else, here are the key settings:

    http://doc.gwos.org/index.php/Share_files_using_Samba

    +
    0 Votes
    dvcster

    Thank you your advice was out to good use and now all is working well, with the exception of being able to share the Printer (Canon i550) which is on the Win XP PC.

    This is not of great concern as I have installed another on the Ubuntu PC and this is working well also.

    One day I will work out how to share the Win XP printer.

    Greetings from Tasmania.

    Don.

    +
    0 Votes
    Toivo Talikka

    I am glad it worked because I tested the procedure on my super-duper AMD 600MHz based Ubuntu server.

    I spent a couple of weeks in Tazzie and saw some penguins on the north coast, Lake St Clair and the Wineglass Bay, it was great.

    Toivo, Sydneysider

  • +
    0 Votes
    Toivo Talikka

    You need to set up the SMB (Samba) password for the user in the Ubuntu PC which is going to be used by the Windows XP PCs.

    Select Applications - Accessories - Terminal and type in the following if you want to set up the SMB password for the currently logged-in user:

    sudo smbpasswd -a `whoami`

    Type in first the password of the currently logged-in Ubuntu user. Then type in the new SMB password and confirm it.

    It is safest to restart the Ubuntu PC, or, while in the terminal window, type in:

    sudo /etc/init.d/samba restart

    If you need to check anything else, here are the key settings:

    http://doc.gwos.org/index.php/Share_files_using_Samba

    +
    0 Votes
    dvcster

    Thank you your advice was out to good use and now all is working well, with the exception of being able to share the Printer (Canon i550) which is on the Win XP PC.

    This is not of great concern as I have installed another on the Ubuntu PC and this is working well also.

    One day I will work out how to share the Win XP printer.

    Greetings from Tasmania.

    Don.

    +
    0 Votes
    Toivo Talikka

    I am glad it worked because I tested the procedure on my super-duper AMD 600MHz based Ubuntu server.

    I spent a couple of weeks in Tazzie and saw some penguins on the north coast, Lake St Clair and the Wineglass Bay, it was great.

    Toivo, Sydneysider