Questions

How can I stop Windows 7 64 bit from crashing every few hours?

Tags:
+
1 Votes
Locked

How can I stop Windows 7 64 bit from crashing every few hours?

Muhammad Mahdi
For some time now I've been using WIn 7 64 bit version.
In the beginning it used to freeze after every 5-6hours but recently this happnes after around 2 hours of use.

The screen freezes whilst sound keeps playing. No BSOD.

I called Dell customer service and they replaced the motherboard and graphic card bu the problem still persists.

What can I do?
  • +
    0 Votes
    Noshmon

    Leaving it switched off? It won't crash then.

    On a serious note, have you tried checking your drivers are up to date and are the 64bit versions? I noticed similar when I was on Windows 7, and it was my graphics driver

    +
    0 Votes
    Muhammad Mahdi

    Hehe, unfortunately I can't leave it off. I usually have it on around 20hrs a day.

    I uninstalled the graphics driver, downloaded the latest one from ATI and tried those. Same problem. I undid and redid this but the same problem persists.

    +
    0 Votes
    Darryl~ Moderator

    it could be a heat issue (or maybe the HDD is getting too warm).

    Are all the vents clear & fans running proper?

    +
    0 Votes
    Muhammad Mahdi

    All the fans are clear, the laptop is placed on a table and for good measure Dell even changed the fans for me.

    +
    0 Votes
    MikeBerg

    I had a similar issue with an HP Win 7 64bit machine that had 8 GB of memory and a high end PCI video card. If you have 8 GB's try reducing it to only 6 GB and see if that makes your system more stable.

    The error message i got was:
    **Hardware Malfunction
    Call your hardware vendor for support
    NMI: Parity check / Memory Parity Error
    ***The system has halted***

    The Solution is:
    Disabling the PCI SERR Generation feature in the BIOS.

    This has no impact on system performance or the performance of the PCI graphics cards. Now you can add back any memory you took out and run the System as normal with 8 GB.

    +
    0 Votes
    Muhammad Mahdi

    I don't get any errors messages and all the memory tests that I ran passed.

    With regards to reducing RAM, do you mean I should unplug one of them? Or is there a way to deactivate or reduce their speed via bios?

    +
    0 Votes
    MikeBerg

    Unplug the power( as a best practice), then remove one of memory sticks. Plug the power back in and restart the computer.

    See if that works better for you, if it does:
    Disable the PCI SERR Generation feature in the BIOS.

    +
    0 Votes
    mperata

    I am with Darryl.

    Make sure in your power settings you are allowing the HDDs to power down and the screen to turn off. You don't have to put the system to sleep or hibernate to do this.

    +
    0 Votes
    Muhammad Mahdi

    I will try out enabling the the HDD to power down and see what happens tonight but the screen turn off was enabled.

    I will inform you all of what happened. Thanks for the help

    +
    0 Votes
    rick.manderville

    I have had my 64 bit Windows 7 OS freeze on me a couple of times. It was not the fault of the OS. I was using Adobe Flash 10.3 inside of Mozilla that wanted to place Local Shard Objects (LSOs) on the C drive durng a streaming download. Once I let it place them there for the duration of the streaming, there were no issues .. I deleted them afterwards.

    +
    0 Votes
    OH Smeg

    And I always insist that my customers use a Cool Pad like the one here

    http://www.antec.com/Believe_it/global/product.php?id=NzI=

    They help keep the thing cool and stop overheating. They also stop or at the very least cut down the instances of the Cooling Ducts inside the NB from getting clogged with Airborne Crud which causes the system to hang.

    The other thing you can look at is what software do you have installed? Pay particular attention to things like Adobe Flash which has known issues with the 64 Bit version of 7.

    Col

  • +
    0 Votes
    Noshmon

    Leaving it switched off? It won't crash then.

    On a serious note, have you tried checking your drivers are up to date and are the 64bit versions? I noticed similar when I was on Windows 7, and it was my graphics driver

    +
    0 Votes
    Muhammad Mahdi

    Hehe, unfortunately I can't leave it off. I usually have it on around 20hrs a day.

    I uninstalled the graphics driver, downloaded the latest one from ATI and tried those. Same problem. I undid and redid this but the same problem persists.

    +
    0 Votes
    Darryl~ Moderator

    it could be a heat issue (or maybe the HDD is getting too warm).

    Are all the vents clear & fans running proper?

    +
    0 Votes
    Muhammad Mahdi

    All the fans are clear, the laptop is placed on a table and for good measure Dell even changed the fans for me.

    +
    0 Votes
    MikeBerg

    I had a similar issue with an HP Win 7 64bit machine that had 8 GB of memory and a high end PCI video card. If you have 8 GB's try reducing it to only 6 GB and see if that makes your system more stable.

    The error message i got was:
    **Hardware Malfunction
    Call your hardware vendor for support
    NMI: Parity check / Memory Parity Error
    ***The system has halted***

    The Solution is:
    Disabling the PCI SERR Generation feature in the BIOS.

    This has no impact on system performance or the performance of the PCI graphics cards. Now you can add back any memory you took out and run the System as normal with 8 GB.

    +
    0 Votes
    Muhammad Mahdi

    I don't get any errors messages and all the memory tests that I ran passed.

    With regards to reducing RAM, do you mean I should unplug one of them? Or is there a way to deactivate or reduce their speed via bios?

    +
    0 Votes
    MikeBerg

    Unplug the power( as a best practice), then remove one of memory sticks. Plug the power back in and restart the computer.

    See if that works better for you, if it does:
    Disable the PCI SERR Generation feature in the BIOS.

    +
    0 Votes
    mperata

    I am with Darryl.

    Make sure in your power settings you are allowing the HDDs to power down and the screen to turn off. You don't have to put the system to sleep or hibernate to do this.

    +
    0 Votes
    Muhammad Mahdi

    I will try out enabling the the HDD to power down and see what happens tonight but the screen turn off was enabled.

    I will inform you all of what happened. Thanks for the help

    +
    0 Votes
    rick.manderville

    I have had my 64 bit Windows 7 OS freeze on me a couple of times. It was not the fault of the OS. I was using Adobe Flash 10.3 inside of Mozilla that wanted to place Local Shard Objects (LSOs) on the C drive durng a streaming download. Once I let it place them there for the duration of the streaming, there were no issues .. I deleted them afterwards.

    +
    0 Votes
    OH Smeg

    And I always insist that my customers use a Cool Pad like the one here

    http://www.antec.com/Believe_it/global/product.php?id=NzI=

    They help keep the thing cool and stop overheating. They also stop or at the very least cut down the instances of the Cooling Ducts inside the NB from getting clogged with Airborne Crud which causes the system to hang.

    The other thing you can look at is what software do you have installed? Pay particular attention to things like Adobe Flash which has known issues with the 64 Bit version of 7.

    Col