Questions

How to setup Window 2003 Domain at home?

+
0 Votes
Locked

How to setup Window 2003 Domain at home?

ramvan03
I am looking to setup a Windows 2003 domain in my home for testing.
I have a Windows 2003 server loaded.
My connection is Comcast that goes to a Linksys WRT320N that is currently handling DHCP and I also guess it is orwarded the DNS from the ISP. I have wired and wireless connections on the WRT320N I could not get my client machines to join the domain. I am sure it is an issue with the DNS and DHCP. Need assistance in finding a solution.
  • +
    0 Votes
    njcsamuels

    is your ipconfig info correct?

    what message do you get when you try?

    +
    0 Votes
    ramvan03

    At this point I have my dc which is also the dns set to use the isp's dns server. When I ran the ipconfig I got the ip address of the computer and subnet but no gateway. The only way I was able to get this to work was to go into the advanced tcp/ip setting and add a default gateway or use static ip's on the client machines. Also after I entered in the advanced setting for the tcp/ip the default gateway when I check the router setting and look at the dhcp table nothing shows up.

    +
    1 Votes
    Seonix

    Generally if you follow these you should be able to get it working. It sounds like your problem is DNS and thus the workstations and even the domain controller can't read the domain itself.
    - Configure your DNS server to (obviously) have its domain zone as a primary zone (AD integrated if you like).
    - Ensure your DNS server can see outside of your domain by configuring root hints or conditional forwarding. (Google this if you unsure what to do).
    - Configure your domain controller/DNS server NIC settings to have itself as the primary DNS server.
    - Install DHCP on your domain controller and turn off DHCP on your router ( currently your router is dishing out DNS details to your clients which means it's unaware of your internal DNS, therefore you can't see the domain from workstations).
    - Configure the DHCP scope with the correct default gateway and your internal DNS server.

    All done. Reply and let me know how it goes.

    +
    0 Votes
    ramvan03

    Sorry it took so long to get back to you. I finally had some time to use your suggestions and things worked just fine. Thanks for you help.

  • +
    0 Votes
    njcsamuels

    is your ipconfig info correct?

    what message do you get when you try?

    +
    0 Votes
    ramvan03

    At this point I have my dc which is also the dns set to use the isp's dns server. When I ran the ipconfig I got the ip address of the computer and subnet but no gateway. The only way I was able to get this to work was to go into the advanced tcp/ip setting and add a default gateway or use static ip's on the client machines. Also after I entered in the advanced setting for the tcp/ip the default gateway when I check the router setting and look at the dhcp table nothing shows up.

    +
    1 Votes
    Seonix

    Generally if you follow these you should be able to get it working. It sounds like your problem is DNS and thus the workstations and even the domain controller can't read the domain itself.
    - Configure your DNS server to (obviously) have its domain zone as a primary zone (AD integrated if you like).
    - Ensure your DNS server can see outside of your domain by configuring root hints or conditional forwarding. (Google this if you unsure what to do).
    - Configure your domain controller/DNS server NIC settings to have itself as the primary DNS server.
    - Install DHCP on your domain controller and turn off DHCP on your router ( currently your router is dishing out DNS details to your clients which means it's unaware of your internal DNS, therefore you can't see the domain from workstations).
    - Configure the DHCP scope with the correct default gateway and your internal DNS server.

    All done. Reply and let me know how it goes.

    +
    0 Votes
    ramvan03

    Sorry it took so long to get back to you. I finally had some time to use your suggestions and things worked just fine. Thanks for you help.